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1 Introduction 

 

This Tutorial Manual contains an overview of dealing with structural problems such as rafts, 

slabs, grids, plane frame and plane stress. It describes the processes of modeling the problems, 

carrying out the calculations, viewing and printing the results. It provides the user skills, which 

he needs to use ELPLA. It also takes the user step by step through some simple examples. 

Carrying out these examples will help the user to become familiar with the most important 

functions of ELPLA. Before attempting a real project with ELPLA, it is recommended that the 

user tries to carry out the given problems. 

 

This Tutorial Manual will not present the theoretical background of modeling the problems. For 

more information concerning the methods of analysis, a complete reference for calculation 

methods and numerical models is well documented in the User’s Guide of ELPLA. Also a 

complete reference for all menus and dialog boxes of the program is to be found in the User’s 

Guide or in the online help system. 

 

 

2 Installing ELPLA 

 

ELPLA is distributed on a CD-ROM containing an installer program to install the ELPLA 

software on your computer. 

 

To install ELPLA follow these steps: 

 

- Insert the CD-ROM into your drive 

 

The installer program is automatically loaded when the CD-ROM is inserted into the drive, 

Figure 1. The installer will guide you through the steps required to install ELPLA on your 

computer. 

 

 
Figure 1 ELPLA Installer form 

 

- Click "Next" button in the form of Figure 1 to install ELPLA on your computer 
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ELPLA Installer program begins execution. Follow the instructions (Figure 2). 

 

- Click "Next" button in the form of Figure 2 to install ELPLA software to the specified 

destination folder 

 

You can specify the folder for ELPLA files. By default, ELPLA suggests …\Program 

Files\ELPLA PE 9.x. However, you can optionally indicate a different folder name, if desired. 

ELPLA creates the folder name you specify. 

 

 
Figure 2 "Select Installation Folder" form 

 

After selecting the installation folder, ELPLA Installer program will be ready to install ELPLA 

software on your computer, Figure 3. 

 

- Click "Next" button in the form of Figure 3 to start the installation 

 

ELPLA will be installed and a statues form will show the process of installation (Figure 4). 

 

 
Figure 3 "Confirm Installation" form 
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Figure 4 "Installing ELPLA" form 

 

ELPLA installation will be completed and a message appears to inform you that the installation 

was completed successfully, Figure 5. 

 

 
Figure 5 Final Installer message 

 

Note 

 

Installer cannot install update system or shared files, if they are in use. Before installing ELPLA, 

it is recommended that you close any application may be running.  
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3 Starting ELPLA 

 

After successfully installing ELPLA, a new program group and program items will be created 

automatically for ELPLA in the Windows-Start-Menu. Also a program icon will be created on 

the Windows desktop, Figure 6. ELPLA professional package contains the individual programs 

ELPLA-Boring, ELPLA-Data, ELPLA-Graphic, ELPLA-List, ELPLA-Section, ELPLA-Solver 

and GEOTEC-Text, besides the help program ELPLA-Help. All those programs can run 

separately or through the main program ELPLA. The usage of the program is typically such that 

first data files are created describing a certain problem by the program ELPLA-Data. Then the 

project problem is analyzed by using the program ELPLA-Solver. Finally, the results can be 

presented as graphical drawings, graphs and tables using the five separate programs ELPLA-

Graphic, ELPLA-Section, ELPLA-List, ELPLA-Boring and GEOTEC-Text. Names and short 

descriptions of the function of the ELPLA sub programs are given in Table 1. 

 

 
Figure 6 Starting ELPLA 

 

Start the main program ELPLA PE 9.x by choosing it from the Windows-Start-Menu, Figure 6. 

A shortcut to start ELPLA is double clicking on ELPLA PE 9.x icon on the Windows desktop. 

After starting ELPLA PE 9.x for the first time, the window in Figure 7 appears. This window 

belongs to the sub program ELPLA-Data. The function of ELPLA-Data is defining the project 

data such as FE-Net, soil properties, raft material, boundary conditions, loads, etc. 

 

On the upper-left corner of this window, the menu bar of ELPLA-Data appears which is used for 

entering the project data. In order to use the programs ELPLA-Solver, ELPLA-Graphic, ELPLA-

List, ELPLA-Section, ELPLA-Boring, first the user must define the project data by the program 

ELPLA-Data. 
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Table 1 Names and descriptions of ELPLA sub programs 

Program name                      Description of the program 

ELPLA-Data                     Editing project data 

ELPLA-Solver                         Analyzing the project problem 

ELPLA-Graphic                                Displaying data and results graphically 

ELPLA-List                                     Listing project data and calculated results 

ELPLA-Section                               Displaying results graphically at specified sections 

ELPLA-Boring                               Editing and displaying boring logs graphically 

GEOTEC-Text                               Simple word processing program 

 

In the following section the user will find a brief description of some of the essential interface 

commands. This section will help the user to be familiar with some of the commands, which will 

be used in this Tutorial. 

 

 

 

Status bar 

Toolbar Programs menu Sub program menu 

Project name Sub program name 

   
Figure 7 Opening screen of the sub program ELPLA-Data 

 

Switching between ELPLA sub programs 

 

On the upper-right corner of the window in Figure 7 the menu bar of the sub programs appears 

which is used for switching between the individual subprograms of ELPLA package. The user 

can switch to a specified sub program by clicking on the name of that sub program. When 

switching to a new sub program, ELPLA automatically opens the data file of the current example 

and displays the data file name in the title bar of this sub program. 
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Toolbar Buttons and Keyboard Shortcuts 

 

Many of ELPLA commands can be accessed by clicking buttons on the toolbars, or by pressing 

shortcut keys on the keyboard. When you select a menu, the available toolbar buttons and 

keyboard shortcuts for that menu are shown next to their corresponding commands as shown in 

Figure 8. You can also directly see what command is associated with a toolbar button by holding 

the mouse cursor over the button. After a brief pause a legend (Screen Tip) will appear next to 

the cursor showing the menu command associated with the button. 

 

 
Figure 8 Available toolbar buttons and keyboard shortcuts for the file menu 

 

Mouse Cursor Modes 

 

ELPLA-Data has two modes of mouse cursor operation in ELPLA-Data window: View mode 

and Edit mode. The program can only be in one mode at a time. By default, the program is in 

view mode and the mouse cursor is an arrow. For edit mode, the cursor will change from an 

arrow to a cross hair indicating the mode in which is being operated. Press "Esc" key to exit the 

edit mode and return to the view mode. 

 

Node Selection 

 

In edit mode nodes are selected by clicking on each node individually or selecting a group of 

nodes. A group of nodes can be selected by holding the left mouse button down at the corner of 

the region. Then, dragging the mouse until a rectangle encompasses the desired group of nodes. 

When the left mouse button is released, all nodes in the rectangle are selected. 

 

Undo and Redo Commands 

 

ELPLA-Data allows you to go back up to 12 steps at a time when defining project process. 

Therefore it is possible to undo a series of actions previously performed. If you go too far in the 

undo process you may redo those actions. You can undo/ redo most drawing, editing and 

assignment operations. To undo/ redo a certain action, choose the "Undo/ Redo" command from 

"Edit" menu. 

 

Snap Tools 

 

The snap tools are essentially a fast and accurate way to draw and edit objects. Snap tools find 

the closest snap location to your pointer as you move it over your model. The snap tools can be 

turned on and off as you draw, so you can snap to different locations for every point. More than 

one snap tool can also be set at the same time giving you a choice of snap locations. The snap 

options are set by the data located in the "Plot Parameters" dialog box under the "Options" menu. 
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Defining Data 

 

Most of ELPLA data can be defined either graphically or numerically (in tables). In this tutorial 

the user will learn how to carry out the data using one method depending on the specified 

example. By completing the all examples, the user will learn to define most of the data both 

graphically and numerically. 

 

Project identification 

 

The user can define three lines of texts to identify a project and the basic information about the 

task. These texts are required only for printing and plotting the data and results. Project 

identification does not play any role in the analysis. The three lines are optionally and maybe not 

completely entered. 

 

Reinforcement data 

 

The design code parameters such as partial safety factors for concrete strength, steel strength and 

internal stresses are defined by choosing the "Design code parameters" command from the "Main 

data" menu in ELPLA-Data, while reinforcement data such as design code, concrete grade, steel 

grade and concrete covers are defined by choosing the "Reinforcement" command from "Data" 

menu in ELPLA-Data. Design code parameters are standard data for all projects while 

reinforcement data may be varied from project to another. 

 

Edit List Box 

 

Some ELPLA data are defined by list box dialog as shown in Figure 9. In this list box the 

"Insert", "Copy" and "Delete" commands are applied for the selected row. To define or modify a 

value in this table, type that value in the corresponding cell, then press "Enter" key. 

 

 
Figure 9 List box used by ELPLA 
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Analysis progress 

 

During the analysis of problems all computations and analysis progression according to the 

defined method are progressively reported. As shown in Figure 10, the analysis progress menu 

reports the various phases of calculations. Also the status bar of ELPLA-Solver displays 

information about the progress of calculation as the program analyzes problems. 

 

 
Figure 10 Analysis progress menu 

 

 

4 Description of the examples 

 

This Tutorial contains 13 examples. These examples are presented in order to illustrate how to 

use ELPLA for analyzing rafts, pile groups, piled raft, slab floor, grid, truss, frame and beam. For 

each example discussed in this Tutorial, data files and some computed files are included in 

ELPLA software package. The file names and contents of the examples are given as follows. 

Besides, a key figure of each problem is shown that contains the main data concerning the 

structure shape and loads. Examples can be run again by ELPLA to examine the details of the 

analysis or to see how the problem was defined or computed and to display, print or plot the 

results. 

 

 

Example 1 Analysis of an irregular shaped raft on irregular subsoil 

File   Content     Foundation shape and load 

Example Raft data 

 

800

1538

1565

1350

x 

1254

1600120 

1265

500

1560

350

750
89 

2150

1368 

y 

 
 

 

An irregular shaped raft on irregular subsoil is selected to illustrate some of the essential 

features of ELPLA for analyzing rafts 
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Example 2 Analysis of a slab floor  

File   Content      Slab shape and loads 

Floor  Slab data 
3 2 

1 

1 

D 

A 

B 

C 

D 

3 2 

A 

B 

C 

P 1 =3.5 [kN/m 
2 
] 

P 2 =4.5 [kN/m 
2 
] P 1 =3.5 [kN/m 

2 
] 

P 1 =3.5 [kN/m 
2 
] 

3.94 0.06 0.06 2.94 

0.94 

0.06 

7.00 [m] 

3.00 

0.06 

1.94 

6.00 [m] 

 
 

 

A slab floor with girders is selected to illustrate some features of ELPLA  

for analyzing slab floors 

 

 

Example 3 Analysis of system of two circular rafts  

File   Content     Foundation shapes and loads 

Raft 1  Data of raft1 

Raft 2  Data of raft2 

Raft 1+2 Data of system of rafts1 and 2  

 

Raft 2Raft 1

P1=1250 kN

P2=1000 kN

P1P1

P2

y

x

P2

 
 

 

A system of two equal large circular rafts is selected to illustrate some features of ELPLA 

for analyzing system of foundations 
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Example 4 Analysis of a grid 

File   Content     Grid shape and loads 

Grid  Grid data 

P1 = 10 [kN/m]
P2 = 15 [kN/m]

4.0 [m]

3.0 [m]

2.0 [m]

1.0 [m]

3.0 [m]

P1

P1

P1

P1
P

1

P1

P1

P1

P2

P2

50 [kN]

  
 

 

A grid resting on 8 supports is selected to illustrate some features of ELPLA  

for analyzing grids 

 

 

Example 5 Plane Stress Analysis of a Wrench 

File   Content     Wrench shape and loads 

Wrench Wrench data 

a

100 [mm]

2 [N/mm]

b

c

R = 10 [mm] 20 [mm]25 [mm]35 [mm]

45 [mm]

22.5 [mm]

45 [mm]

2.5 [mm]

32.5 [mm]

R =10 [ mm]

Thickness =10 [mm]

 

 

 

 

195 [mm]

R =30 [ mm]

 
 

 

 

An example for analyzing the stresses and deformations of a wrench is selected to illustrate 

some features of ELPLA for analyzing plane stress problems 
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Example 6 Analysis of Two-dimensional Truss 

File   Content     Truss shape and loads 

Truss  Truss data 

60 [kN]60 [kN] 60 [kN]

4*3 = 12 [m]

4 [m]

 
 

An example of a two-dimensional truss structure is selected to illustrate some features of 

ELPLA for analyzing plane frame problems 

 

 

Example 7 Analysis of Plane Frame 

File   Content     Frame shape and loads 

Frame  Frame data 
100 [kN]60 [kN/m]

80 [kN]

5 [m]

2 [m]

3 [m] 2 [m]

1 [m]

2 [m]

50 [kN/m]

 
 

An example for analyzing two-dimensional frame structure is selected to illustrate some 

features of ELPLA for analyzing plane frames 
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Example 8 Analysis of Beam 

File   Content     Beam shape and loads 

Beam  Beam data 

100 [kN]

40 [kN/m]

3 [m]2 [m] 3 [m]

80 [kN/m]

2 [m] 1 [m]

60 [kN.m]

 
 

An example for analyzing a beam is selected to illustrate some features of ELPLA  

for analyzing beams 
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Example 9 Influence of a new neighboring building II on an old one I 

File     Content    Rafts shape and loads 

New Building II  Raft (1) 

Old Building I   Raft (2) 

1 4  *  0 . 7 2  =  1 0 . 0 8  m 1 4  *  0 . 7 2  =  1 0 . 0 8  m
b )  P l a n

P 1

P 3  P 2  

P 1P 1P 1 P 1

P 1P 1
P 1

P 2  P 2  

P 2  

P 2  

P 2  P 2  

P 2  

P 3  P 3  

N e w  b u i l d i n g  I I O l d  b u i l d i n g  I

a a

a )  S e c t i o n  a - a
R o c k

( 0 . 0 0 )

P 3  P 3  P 2  P 2  P 2  P 2  

( 7 . 2 0 )

( 1 . 5 0 )

C l a y ,  s t i f f  p l a s t i c

d  = 1 . 0  m

P 1  =  5 0 0  [ k N ]
P 2  =  1 0 0 0  [ k N ]
P 3  =  2 0 0 0  [ k N ]

E s  =  5  0 0 0  [ k N / m 2 ]
W s  =  1 5  0 0 0  [ k N / m 2 ]
 s  =  1 8  [ k N / m 3 ]

E b  =  2  *  1 0  7  [ k N / m 2 ]
 b  =  0 . 1 5  [ - ]
 b  =  0 . 0  [ k N / m 3 ]

 
  

 

An example of two neighboring buildings is selected to illustrate some of the essential 

features of ELPLA for studying the influence of a new building on an existing old one 
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Example 10 Analysis of raft with straight and curved borders 

File    Content     Raft shape and loads 

Curved raft  Raft 

80

x [m]

42 166 1210 14 18

y [m]

4

2

6

10

8

0

P = 500 [kN]

GW (2.00)

Rigid base

Soil properties:
Es = 10000 [kN/m3]
Ws= 10000 [kN/m3]
 = 18 [kN/m3]
s = 0.3 [-]

d = 1.0 [m]

GS

I I

P

P

P

P

P

PPPP

P P

H = 10 [m]

 
 

An example of a raft with straight and curved borders is selected to illustrate some of the 

essential features of ELPLA 
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Example 11 Analysis of pile groups 

File    Content    Pile groups and load 

Pile groups  Pile groups 

 

3.8  

P = 8000 [kN]

1.6*4 = 6.4 [m]

o

y

x

1.21.4

 
 

An example of pile groups is selected to illustrate some of the essential features of ELPLA 

for analyzing pile groups 
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Example 12 Analysis of piled raft 

File    Content    Piled raft and pile locations 

Piled raft  Piled raft 

24.5 [m]

 
 

An example of piled raft is selected to illustrate some of the essential features of ELPLA for 

analyzing piled raft 
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Example 13 Interaction of lowering the foundation of a building with an underground 

tunnel 

File    Content    Piled raft and pile locations 

TU1   Raft 

TU2   Tunnel 

 
An example of lowering the foundation of a building with an underground tunnel is selected 

to illustrate some of the essential features of ELPLA for studying the influence of an 

underground tunnel on a building foundation. 

 

 

P = 18000 [kN] 

p 

P 

p = 300 [kN/m] 

P 

y 

x 

P 

21.0 [kN] 

B3 (20.5, 2.5) 

B2 (17.0, 13.5) 

B1 (2.0, 3.5) 

a) 
24.0 

0.0 

12.0 

8.0 

4.0 

20.0 16.0 10.0 6.0 0.0 

T, Clay 
E s  = 10 000 [kN/m2] 
W s  = 30 000 [kN/m2] 
 s  = 18 [kN/m3] 

B1 

(14.00) 

GW (12.00) 

(7.00) 
(6.30) 

(5.50) 

(0.00) 

Sst, Sand ston 
E s  = 160 000 [kN/m2] 
W s  = 400 000 [kN/m2] 
 s  = 21 [kN/m3] 

 

B3 B2 

b) 
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raft on irregular subsoil 
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1 Description of the problem 

 

A simple example of an irregular shaped raft on irregular subsoil is selected to illustrate some of 

the essential features of ELPLA for analyzing rafts. 

 

1.1 Loads 

 

The raft carries many types of external loads: concentrated loads [kN], uniform load [kN/m2], 

line load [kN/m] and moments [kN.m] in both x- and y-directions as shown in Figure 1-1 and in 

Table 1-1 to Table 1-5. 

 

 

 

Figure 1-1 Raft dimensions [m] and loads 

 

1.2 Raft material and thickness 

 

Raft material and thickness are supposed to have the following parameters: 

 

Young's modulus   Eb = 2 * 107  [kN/m2] 

Poisson's ratio   vb  = 0.25   [-] 

Unit weight of raft material  γb  = 0.0   [kN/m3] 

Raft thickness    d  = 0.5   [m] 

 

Unit weight of raft material is chosen to be γb = 0.0 [kN/m3] to neglect the own weight of the raft 

in the analysis. 

 

 

 

 

 

800

1538

1565

1350

x 

1254

1600120 

1265

500

1560

350

750
89 

2150

1368 

y 
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1.3 Soil properties 

 

Three boring logs characterize the subsoil under the raft. Each boring has three layers with 

different soil materials. The Moduli of Elasticity of the three layers for loading are Es1 = 9 500 

[kN/m2], Es2 = 22 000 [kN/m2] and Es3 = 120 000 [kN/m2] while for reloading are Ws1 = 26 000 

[kN/m2], Ws2 = 52 000 [kN/m2] and Ws3 = 220 000 [kN/m2]. Poisson's ratio is 0.3 [-] for all soil 

layers. Unit weight of the soil above the ground water is γs = 19 [kN/m3] while that under the 

ground water is γ’s = 9 [kN/m3]. The foundation depth df = 2.7 [m], the ground water depth under 

the ground surface is GW = 1.5 [m]. Figure 1-2 shows boring logs and locations. 

 

1.4 Method of analysis 

 

It is required to analyze the raft according to the following soil models and numerical calculation 

methods: 

 

- Layered soil medium - Continuum Model 

- Modulus of compressibility method for an elastic raft on layered soil medium  

(Solving system of linear equations by iteration-method 6) 

 

In the analysis the following items will be taken into account: 

 

- The effect of reloading of the soil due to the overburden pressure 

- The effect of water pressure on the raft 

- The irregularity of the subsoil under the raft using the interpolation method (Figure 1-2) 

 

This Tutorial Manual will not present the theoretical background of modeling the problem. For 

more information concerning the method of analysis, a complete reference for the soil models 

and numerical calculation methods is well documented in the User’s Guide of ELPLA. 
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Table 1-1 Point loads P 
 ----------------------------------------------------- 

 Load No.     Load value     x-position     y-position 

        I              P              x              y 

      [-]           [kN]            [m]            [m] 

 ----------------------------------------------------- 

        1           1265            1.5            1.4 

        2           1600            1.5            5.5 

        3           1350            1.5            9.9 

        4           1368            1.5           12.6 

        5           1560              5            1.4 

        6           1538              5           12.6 

        7            800            9.2            1.4 

        8            750            9.2            5.5 

        9           1565            9.2           12.6 

       10           2150           13.4            5.5 

       11           1450           13.4            9.9 

       12           1254           13.4           12.6 

 ----------------------------------------------------- 

 

Table 1-2 Moment Mx 
 --------------------------------------------------- 

 Moment   Moment value     x-position     y-position 

    No.             Mx              x              y 

    [-]         [kN.m]            [m]            [m] 

 --------------------------------------------------- 

      1            350              5            1.4 

 --------------------------------------------------- 

 

Table 1-3 Moment My 
 --------------------------------------------------- 

 Moment   Moment value     x-position     y-position 

    No.             My              x              y 

    [-]         [kN.m]            [m]            [m] 

 --------------------------------------------------- 

      1            500            9.2            5.5 

 --------------------------------------------------- 

 

Table 1-4 Line load pl 
 -------------------------------------------------------------------- 

 Load No.  Load value  Load start  Load start    Load end    Load end 

        I          Pl          x1          y1          x2          y2 

      [-]      [kN/m]         [m]         [m]         [m]         [m] 

 -------------------------------------------------------------------- 

        1          89        10.5         4.8          15         2.8 

 -------------------------------------------------------------------- 

 

Table 1-5 Distributed load p 
 -------------------------------------------------------------------- 

 Load No.  Load value  Load start  Load start    Load end    Load end 

        I           P          x1          y1          x2          y2 

      [-]     [kN/m2]         [m]         [m]         [m]         [m] 

 -------------------------------------------------------------------- 

        1         120           0           0         0.5       13.97 

 -------------------------------------------------------------------- 
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a)

Fine sand
E

s
 = 22 000 [kN/m2]

Ws = 52 000 [kN/m
2
]

3.80

20.00

10.00

GW=1.50

20.00

18.20

12.70

0.00

B2 B3 B1  

20.00

14.10

8.20

Silt
E

s
 = 9 500 [kN/m2]

W
s
 = 26 000 [kN/m2]

s=19 [kN/m
3
]

Gravel
E

s
 = 120 000 [kN/m2]

W
s
 = 220 000 [kN/m2]

b)

B1 (4.00, 3.00)

B2 (1.00, 9.00)

B3 (10.00, 11.00)

 
 

Figure 1-2 a) Boring locations and interpolation zones 

  b) Boring logs B1 to B3 
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2 Creating the project 

 

In this section the user will learn how to create a project for analyzing raft foundation. The 

project will be processed step by step to show the possibilities and abilities of the program. To 

enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

Choose "New project" command from the "File" menu of ELPLA-Data. The following 

"Calculation methods" wizard appears, Figure 1-3. This wizard will help the user to define the 

analysis type and the calculation method of the problem through a series of forms. The first form 

of "Calculation methods" wizard is the "Analysis type" form (Figure 1-3). 

 

 
Figure 1-3 "Analysis type" form 

 

In the "Analysis type" form in Figure 1-3 define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a foundation problem, select 

"Analysis of slab foundation" then click "Next" button to go to the next form. After clicking 

"Next" button, the "Calculation methods" form appears, Figure 1-4. 

 

To define the calculation method 

 

- Select the calculation method "6-Modulus of Compressibility (Iteration)" 

- Select subsoil model "Layered soil model" 

- Click "Next" button to go to the next form 
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Figure 1-4 "Calculation methods" form 

 

The next form is the "System symmetry" in Figure 1-5. In this form select "Unsymmetrical 

system" and then click "Next" button to go to the next form. 

 

 
Figure 1-5 "System symmetry" form 

 

The last form in the wizard is the "Options" form, Figure 1-6. In this form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to 

other. Since no option will be considered in the analysis, click the "Save" button. 
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Figure 1-6 "Options" form 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 1-7. In this dialog box 

type a file name for the current project in "File name" edit box. For example type "Example". 

ELPLA will use automatically this file name in all reading and writing processes. 

 

 
Figure 1-7 "Save as" dialog box 

 

Click "Save" button to complete the definition of the calculation method and the file name of the 

project. ELPLA will activate the "Data" menu. Also the file name of the current project 

[Example] will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, see 

Figure 1-8. 
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Figure 1-8 ELPLA-Data after defining the calculation method 

 

In the "Data" menu of ELPLA-Data, the user can enter the remaining data of the project using 

the same sequence of commands in this menu. The first command in the menu is "Calculation 

methods", which has been already entered. Therefore, ELPLA has put the sign "√" beside this 

command (Figure 1-8). ELPLA puts this sign beside the commands those the user has entered so 

that the user can know which data were defined. 

 

2.2 Project identification 

 

The user can enter three lines of texts to describe the problem and the basic information about 

the task. These texts are required only for printing and plotting the data and results. Project 

identification does not play any role in the analysis. The three lines are optionally and maybe not 

completely entered. To identify the project, choose "Project identification" command from 

"Data" menu. The dialog box in Figure 1-9 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of an irregular raft on irregular subsoil" 

- Type the date of the project in the "Date" edit box 

- Type the word "Example" in the "Project" edit box 

- Click "Save" button 
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Figure 1-9 "Project identification" dialog box 

 

2.3 FE-Net data 

 

For the given problem, the raft has irregular shape and is divided into 15 * 15 elements. Element 

size in both x- and y-directions is variable as shown in Figure 1-1. ELPLA has different 

procedures for defining the FE-Net. The easy procedure to define the FE-Net of this raft is 

generating a mesh for the entire area first and then removing the unnecessary nodes to get the 

foundation shape. 

 

To define the FE-Net for this raft, choose "FE-Net data" command from the "Data" menu. "FE-

Net generation" wizard appears as shown in Figure 1-10. This wizard will guide you through the 

steps required to generate a FE-Net. As shown in Figure 1-10, the first form of the wizard is the 

"Slab type" form which contains a group of templates of different shapes of nets. These net 

templates are used to generate standard nets. 

 

 
Figure 1-10 "FE-Net generation" wizard with "Slab type" form 

 

To generate the FE-Net 

 

- In the "Slab type" options choose the rectangular slab option 

- In the "Rectangular slab" frame enter the total length and width of the raft in the 

corresponding edit boxes 

- Click "Next" button to go to the next form 
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After clicking "Next" in "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 1-11. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. Choose the first type of rectangular elements, then click "Next" button. 

 

 
Figure 1-11 "Generation type" form 

 

The next form of the "FE-Net generation" wizard is the "Grid definition" form. In this form, the 

default values of constant element size appear, Figure 1-12. To edit the variable grid spacing in 

x-direction, do the following steps in "Grid in x-direction" frame: 

 

- Uncheck the "Constant grid spacing" check box. "Grid spacing" button will be activated 

- Click the button "Grid spacing". "Grid spacing in x-direction" list box appears, Figure 1-13. 

In this list box the spacing width can be entered individually for every space 

- Enter the grid spacing in x-direction in this list box 

- Click "OK" button to return to "Net of finite elements" dialog box 

 

To edit the variable grid spacing in y-direction, repeat the previous steps. After that, click 

"Finish" button in "FE-Net generation" wizard to see the FE-Net on the screen. 

 

 
Figure 1-12 "Grid definition" form 
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Figure 1-13 "Grid spacing in x-direction" list box 

 

Deleting nodes from the FE-Net 

 

To select the unnecessary nodes which are required to be removed from the net, first choose 

"Select nodes" command from "Graphically" menu. When "Select nodes" command is chosen, 

the cursor will change from an arrow to a cross hair. The command "Remove nodes" in the menu 

"Graphically" will be enabled, indicating the mode in which is being operated. Next, select the 

required nodes by clicking on each node individually or selecting a group of nodes as shown in 

Figure 1-14. To remove the selected nodes, choose "Remove nodes" command from the 

"Graphically" menu. The action of this command is indicated in Figure 1-15. To leave the 

graphic mode, press "Esc" key. 

 

 
Figure 1-14 Generated FE-Net after selecting the unnecessary nodes 
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Figure 1-15 Final FE-Net after deleting the unnecessary nodes 

 

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 1-15 to save the data of  the 

FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 1-15 to close the "FE-Net" 

embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

2.4 Soil properties 

 

In ELPLA there are three different soil models with several calculation methods. Therefore, the 

soil properties for each method are required to be defined according to the used soil model. In the 

current example, the soil model, which is used in the analysis, is Layered Soil Model. This 

model requires that the subsoil has to be defined by boring logs. In the example, three boring 

logs at different locations define the soil under the raft. Each boring log has multi-layers with 

different soil materials. The geotechnical data for each layer are unit weight of the soil γs and 

modulus of Elasticity for loading Es and reloading Ws. 

 

To define the soil properties, choose "Soil properties" command from "Data" menu. The 

following sub program in Figure 1-16 appears with a default-boring log. 
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Figure 1-16 ELPLA-Boring with a default-boring log 

 

In Figure 1-16, soil properties are defined through the "Data" menu which contains the following 

two commands: 

 

- "Soil data" command defines the individual boring logs 

- "Main soil data" command defines the general data for all soil layers 

 

To enter the soil properties for the three boring logs of the current example 

 

- Choose "Soil data" command from "Data" menu in the window of Figure 1-16. 

The following dialog box in Figure 1-17 with default-boring log data appears 
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Figure 1-17 "Soil data" dialog box with default-boring log data 

 

In the "Geotechnical data of the layer" dialog group box in Figure 1-17, define the geotechnical 

data of the first soil layer of the first boring log as follows: 

  

Es   = 9 500  [kN/m2] 

Ws   = 26 000 [kN/m2] 

Gam  = 19   [kN/m3] 

 

In the current example, the angle of internal friction φ and the cohesion c of the soil are not 

required because the selected type of the analysis is linear analysis. Therefore, the user can let the 

default values of the internal friction and the cohesion. 

 

Due to the presence of the ground water, the soil above the ground water level has a differential 

unit weight from the soil under that level. Therefore, the layer depth of the first layer for all 

boring logs is taken to be 1.5 [m], which is equal to the ground water level. Now, type this value 

in "Layer depth under the ground surface" edit box. 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 

4023, the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "U, Silt" as the soil type in "Main soil 

type 1" combo box in "Soil and rock symbols" dialog group box in Figure 1-17. The color of the 

silt according to the German Standard DIN 4023 will be automatically created. The user can 

change this color. Also, a short text "U" will be automatically created for the silt. 
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To enter the second layer of the first boring log 

 

- Click "Layer copy" button in Figure 1-17. A layer that has the same properties of the first 

layer will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be typed 

automatically at the upper-left corner of the main dialog box of soil layers as a head title 

- Change the value of the unit weight of the soil for the second soil layer from 19 [kN/m3] 

to 9 [kN/m3] 

- Change the value of the layer depth under the ground surface from 1.5 [m] to 3.8 [m] 

 

To enter the fine sand and gravel layers 

 

- Click twice "Layer insert" button in Figure 1-17, two layers will be inserted 

- Use the vertical scrollbar to move to the third soil layer 

- In "Geotechnical data of the layer" dialog group box in Figure 1-17, define the 

geotechnical data of the fine sand layer as follows: 

  

Es   = 22 000  [kN/m2] 

Ws   = 52 000 [kN/m2] 

 Gam  = 9   [kN/m3] 

Phi   = 30  [°] 

c   = 5  [kN/m2] 

 

 

- Select "fs, Fine sand" as the soil type in "Main soil type 1" combo box in "Soil and rock 

symbols" dialog group box 

- Type 10 in "Layer depth under the ground surface" edit box 

- Use the vertical scrollbar to move to the fourth soil layer  

- Type the following data for the gravel layer: 

 

Es   = 22 000  [kN/m2] 

Ws   = 52 000 [kN/m2] 

 Gam  = 9   [kN/m3] 

Phi   = 30  [°] 

c   = 5  [kN/m2] 

 

 

- Select "G, Gravel" as the soil type in "Main soil type 1" combo box in "Soil and rock 

symbols" dialog group box 

- Type 20 in the "Layer depth under the ground surface" edit box 

 

Note that the unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due 

to the removed soil, which is equal to γs * df. This means that the unit weight of the soil under the 

foundation depth df  is not required. However, the unit weight of the soil under the foundation depth 

for all soil layers is entered by the value 9 [kN/m3]. 

 

After editing the geotechnical data for the first boring log, the boring coordinates and labels 

which describe the boring will be entered.   

 

To enter the boring coordinates and the label 

 

- Type 4 for x-coordinate in "x-coordinate of boring log [m]" edit box 

- Type 3 for y-coordinate in "y-coordinate of boring log [m]" edit box 

- Type B1 as a label name for the first boring in "Label of boring log" edit box 
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Now all data and parameters for the first boring log have been entered. The next step is to enter 

the data of the other two boring logs. As the three boring logs contain the same soil layers, data 

of the other two boring logs are created by first copying the data of the first boring log and then 

modifying boring logs individually. Only layer depths, boring coordinates and labels are required 

to be modified. 

 

To create the other two boring logs, click twice "Boring log copy" button in Figure 1-17. Two 

boring logs with the same data and parameters of the first boring log will be copied. 

 

Modifying data of boring logs 

 

Modifying boring coordinates is carried out only numerically while modifying the other data of 

boring logs may be carried out either numerically or graphically. In this example all data will be 

modified numerically. 

 

To modify the boring coordinates and labels 

 

- Use the horizontal scrollbar to switch to the second boring log. Boring log No. will be 

typed automatically at the upper-left corner of the main dialog box of boring logs as a 

head title 

- Type 1 as x-coordinate in "x-coordinate of boring log [m]" edit box in Figure 1-17 

- Type 9 as y-coordinate in "y-coordinate of boring log [m]" edit box in Figure 1-17 

- Type B2 as a label name for the second boring in "Label of boring log" dialog box in 

Figure 1-17 

- Use the vertical scrollbar to move from a layer to another. Then modify the layer depth 

under the ground surface for each layer 

- In "Layer depth under the ground surface" edit box in Figure 1-17 type the following 

values for layer depths: 

 

Layer depth under the ground surface (2nd layer)   8.2 [m] 

Layer depth under the ground surface (3rd layer) 14.1 [m] 

Layer depth under the ground surface (4th layer) 20 [m] 

 

Repeat the previous steps to modify the boring data for the third boring log. Data, which are 

required to be modified for the third boring log, are: 

 

x-coordinate of boring log    10 [m] 

y-coordinate of boring log     11  [m] 

Label of boring log     B3 

Layer depth under the ground surface (2nd layer) 12.7 [m] 

Layer depth under the ground surface (3rd layer) 18.2 [m] 

Layer depth under the ground surface (4th layer) 20 [m] 

 

Now, after finishing the creation of boring logs, click "OK" button in "Soil data" dialog box in 

Figure 1-17 to see the defined boring logs on the screen where the user can control or modify the 

input data and parameters. As a default plot parameter, ELPLA displays only the first boring log 

on the screen (Figure 1-18). 
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Figure 1-18 First boring log on the screen 

 

To display all boring logs or specified boring logs on the screen, choose "Drawing boring logs" 

command from "Graphically" menu in Figure 1-18. The following list box in Figure 1-19 

appears. 

 

To select the boring logs you want to display 

 

- Select the boring log that is required to be displayed from the list of the available boring 

logs in Figure 1-19 

- Click "Boring insert" button. Double clicking on the required boring log in the list of the 

 available boring logs gives the same action. Removing a boring log from the drawing list 

 is carried out by double clicking on that boring log in the list of the selected boring logs 

- Click "OK" button in Figure 1-19. The selected boring logs appear on the screen to 

control or modify the boring data graphically, Figure 1-20 
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Figure 1-19 "List of boring logs" list box 

 

 
Figure 1-20 Boring logs on the screen 

 

To enter the main soil data for all layers, choose "Main soil data" command from "Data" menu in 

Figure 1-20. The following dialog box in Figure 1-21 appears with default main soil data. The 

main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other 

data corresponding to main soil data are not required in this example. Therefore, the user can 

take these data from the default soil properties. 

 

In the dialog box of Figure 1-21 enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 
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Figure 1-21 "Main soil data" dialog box 

 

After entering all data and parameters of boring logs, do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 1-20 to save the data of 

boring logs 

- Choose "Close boring logs" command from "File" menu in Figure 1-20 to close the  sub 

program ELPLA-Boring and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Soil properties" command in the "Data" 

menu of ELPLA-Data. 

 

2.5 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu. The following embedded program in Figure 1-22 appears with default foundation 

properties. The data of foundation properties for the current example, which are required to be 

defined, are raft material, raft thickness and foundation depth. Any other data corresponding to 

foundation properties in the program menus are not required in this example. Therefore, the user 

can take these data from the default foundation properties. 

 

To enter the raft material and thickness, choose "Element groups" command from "In Table" 

menu. The following list box in Figure 1-23 appears. In this list box, enter E-Modulus of the raft, 

Poisson’s ratio of the raft and raft thickness. Then click "OK" button to go to the next step. 
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Bild 1-22 "Foundation properties" embedded program 

 

 
Figure 1-23 "Defining element groups" list box 

 

To enter the unit weight of the raft, choose "Unit weight of the foundation" command from 

"Foundation properties" menu in the window of Figure 1-22. The following dialog box in Figure 

1-24 with a default unit weight of 25 [kN/m3] appears. To neglect the self-weight of the raft in 

the analysis, type 0 in the "Unit weight of the foundation" edit box. Click "OK" button. 
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Figure 1-24 "Unit weight of the foundation" dialog box 

 

To enter the foundation depth under the ground surface, choose "Foundation depth" command 

from "Foundation properties" menu in the window of Figure 1-22. The following dialog box in 

Figure 1-25 appears to define the foundation depth under the ground surface. Type 2.7 in the 

"Foundation depth under the ground surface" edit box. Then click "OK" button. 

 

 
Figure 1-25 "Foundation depth" dialog box 

 

After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 1-22 to save 

the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 1-22 to close 

the "Foundation properties" embedded program and return to the main window of 

ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Foundation properties" command in "Data" 

menu of ELPLA-Data. 
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2.6 Boring fields 

 

If the subsoil under the raft is defined by two boring logs or more such as in the current example, 

the irregularity of the subsoil must be taken into account. "Boring fields" command let the user 

define which method is to be used to consider the irregularity of the subsoil. In the current 

example, the Interpolation Method will be used. 

 

To consider the Interpolation Method in the analysis, choose "Boring fields" command from 

"Data" menu. The following embedded program in Figure 1-26 appears with a default method. 

ELPLA considers that the Interpolation Method is the default one, which takes into account the 

irregularity of the subsoil. In most cases ELPLA defines the interpolation zone types I, II, III 

automatically such as in this example. But in the case of extreme boring arrangements, the user 

must define these zones. 

 

 
Figure 1-26 "Boring fields" embedded program 

 

You do not need to change anything. Now do the following two steps: 

 

- Choose "Save boring fields" command from "File" menu in Figure 1-26 to save the data 

of boring fields 

- Choose "Close boring fields" command from "File" menu in Figure 1-26 to close the 

"Boring fields" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Boring fields" command in "Data" menu of 

ELPLA-Data. 
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2.7 Loads 

 

In ELPLA, loads on the raft such as point loads, line loads, uniform loads or moments may be 

applied to the net of the finite elements at any position independently on the node position. The 

coordinates of the loads are related to the lower-left corner of the raft (local coordinates). 

 

To define the loads, choose "Loads" command from "Data" menu. The following embedded 

program in Figure 1-27 appears. 

 

In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using 

the commands of "Graphically" menu in Figure 1-27. In this example the user will learn the 

definition of loads numerically. 

 

 
Figure 1-27 "Loads" embedded program 

 

To enter point loads 

 

- Choose "Point loads" command from "In Table" menu in the window of Figure 1-27. 

The following list box in Figure 1-28 appears. ELPLA can distribute concentrated loads 

under columns. In this example, data corresponding to column dimensions are not 

required. Therefore, the user can take these data from the default column dimensions and 

consider all loads have column type 1 

- Enter the external point loads P [kN] and their corresponding coordinates (x, y) in the list 

box of Figure 1-28 by typing the value in the corresponding cell and pressing "Enter" key 

- The coordinates of the point load are related to the lower-left corner of the raft (local 

coordinates) 

- Click "OK" button 
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Repeat the previous steps for moments Mx, moments My, line loads and distributed loads using  

"Moments Mx", "Moments My", "Line loads" and "Distributed loads" commands from "In 

Table" menu respectively. After that the screen should look like the following Figure 1-29. 

 

 
Figure 1-28 "Point loads P" List box 

 

 
Figure 1-29 Loads on the screen 

 

To save the load data, choose "Save loads" command from "File" menu. Then choose "Close 

loads" command from this menu to close "Loads" embedded program and return to the main 

window of ELPLA-Data. Note that the sign "√" is typed automatically beside the "Loads" 

command in the "Data" menu of ELPLA-Data. 

 

Creating the project of the raft is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 
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3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem which you have just defined, leave ELPLA-Data to ELPLA-Solver. This 

is done by clicking on "Solver" in the menu bar at the upper-right corner of ELPLA-Data. 

ELPLA-Solver window appears, Figure 1-30. This window belongs to ELPLA-Solver. Like 

ELPLA-Data, on the upper-right corner of ELPLA-Solver window appears the menu bar of the 

sub programs, which are used for switching between individual sub programs of ELPLA 

package. On the upper-left corner of this window appears the menu bar of ELPLA-Solver, which 

is used for analyzing the problem. 

 

In Figure 1-30, the "Calculation" menu is active. This menu contains commands of all 

calculations. Commands of calculation depend on the used calculation method in the analysis. 

For the current example, the items, which are required to be calculated, are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix 

- Iteration process 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time. 

 

 
Figure 1-30 Opening screen of ELPLA-Solver 
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3.2 Carrying out all computations 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Calculation" menu in ELPLA-Solver 

Window. The following "Iteration parameters" option box in Figure 1-31 appears 

- In "Iteration parameters" option box, select which option is ending the iteration process.  

For this example, choose an accuracy of 0.0001 [m] to end the iteration process 

- Click "OK" button 

 

 
Figure 1-31 "Iteration parameters" option box 

 

The progress of all computations according to the defined method will be carried out 

automatically with displaying information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 1-32 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 1-32 Analysis progress menu 

 

Iteration process 

 

Information about the convergence progress of the computations is displayed in the "Iteration 

process" list box in Figure 1-33 during the iteration process.  
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Figure 1-33 "Iteration process" list box 

 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 1-34. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy.  

 

 
Figure 1-34 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 

 

 

4 Viewing data and results 

 

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the 

three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed 

again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data 

is used only to define and view the data of the problem. ELPLA-Graphic is used to print data 

graphically while ELPLA-List is used to print data numerically. 
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4.1 Viewing data and result graphics 

 

To view graphically the data and results of a problem that has already been defined and analyzed, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window appears, 

Figure 1-35. This window belongs to the sub program ELPLA-Graphic. Like in other sub 

programs of ELPLA, on the upper-right corner of ELPLA-Graphic window appears the menu 

bar, which is used for switching between individual sub programs of the ELPLA package. On the 

upper-left corner of this window appears the menu bar of ELPLA-Graphic, which is used for 

displaying the data and results. 

 

 
Figure 1-35 Opening screen of the sub program ELPLA-Graphic 

 

The "Graphic" menu contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the 

data and results are: 

 

- Results in isometric view 

- Results as contour lines 

- Result values in the plan 

- Distribution of results in the plan 

- Results as circular diagrams 

- Slab deformation 

- Principal moments as streaks 

- Data in isometric view 

- Data in the plan 

- Boring locations 

- Boring logs 
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Only the first command of the "Graphic" menu is explained here. In the same way, the user can 

carry out the remaining commands of the previous list. The commands of "Options", "Format" 

and "Window" menus, which are used to define the preferences of the drawing such as plot 

parameters, scale, font, etc., are discussed in detail in the User’s Guide of ELPLA.  

 

To view the results in isometric view 

 

- Choose "Results in isometric view" command from "Graphic" menu. The following 

option box in Figure 1-36 appears 

- In the "Results in isometric view" option box, select "Contact pressures q" as an example 

for the results to be displayed 

- Click "OK" button 

 

The contact pressures are now displayed in an isometric view as shown in Figure 1-37. 

 

 
Figure 1-36 "Results in isometric view" option box 

 

 
Figure 1-37 Contact pressures in an isometric view 
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4.2 Plot a diagram of the results at a specified section 

 

To plot a diagram of the results, switch to ELPLA-Section. This is done by clicking on "Section" 

in the menu bar of the sub programs at the upper-right corner of ELPLA-Graphic window. 

ELPLA-Section window appears, Figure 1-38. The function of ELPLA-Section is plotting and 

printing the results in diagrams. ELPLA-Section automatically opens the data file of the current 

example and displays the data file name in the title bar of ELPLA-Section window. 

 

 
Figure 1-38 Opening screen of the sub program ELPLA-Section 

 

The "Section" menu in ELPLA-Section contains the commands of drawing the diagrams. The 

commands for presenting the results in diagrams are: 

 

- Section in x-direction 

- Max./ Min. values in x-direction 

- Overlapping in x-direction 

- Arbitrary section 

- Section in y-direction 

- Max./ Min. values in y-direction 

- Overlapping in y-direction 

 

 

Only the first command of the "Sections" menu is explained here. In the same way, the user can 

carry out the remaining commands of the previous list. The commands of "Options", "Format" 

and "Window" menus, which are used to define the preferences of the drawing such as plot 

parameters, scale, font, etc., are discussed in detail in the User’s Guide of ELPLA.  
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To plot a section in x-direction 

 

- Choose "Section in x-direction" command from "Sections" menu. The following option 

 box in Figure 1-39 appears 

- In the "Section in x-direction" option box, select "Settlements s" as an example for the 

 results to be plotted in a diagram 

- Click "OK" button 

 

 
Figure 1-39 "Section in x-direction" option box 

 

The following dialog box in Figure 1-40 appears to specify the section in x-direction. In this 

dialog box, click "OK" button to plot the default section. The settlements are now plotted in a 

diagram as shown in Figure 1-41. 

 

 
Figure 1-40 "Section in x-direction" dialog box with a default section 
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Figure 1-41 Diagram of settlements in x-direction 

 

4.3 Print the drawing 

 

To print the drawing 

 

- Choose "Print" command from "File" menu in ELPLA-Graphic or ELPLA-Section 

Window. The following "Print" dialog box in Figure 1-42 appears 

- In the "Print" dialog box, define the printer properties and drawing copies 

- Click "OK" button 

 

Only the objects currently displayed on the drawing are printed. 
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Figure 1-42 "Print" dialog box 

 

4.4 Listing data and results in tables 

 

To list tables of data and results, switch to ELPLA-List. This is done by clicking on "List" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Section window. ELPLA-List 

window appears, Figure 1-43. The function of ELPLA-List is listing and printing data and results 

in tables. Data and results can be exported to other Windows applications to prepare reports or 

add further information. ELPLA-List automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-List window. 

 

The "List" menu in ELPLA-List contains the commands of listing data and results. The 

commands for listing data and results in tables are: 

 

- Display tables of data 

- Print tables of data 

- List tables of data through Text-

 Editor 

- Display tables of results 

- Print tables of results 

- List tables of results through Text-

 Editor 

 

Only the first command of the "List" menu is explained here. In the same way, the user can carry 

out the remaining commands of the previous list. The commands of "Format" and "Window" 

menus, which are used to define the preferences of the tables such as page format, font, etc., are 

discussed in detail in the User’s Guide of ELPLA.  
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Figure 1-43 Opening screen of the sub program ELPLA-List 

 

To list data in a table 

 

- Choose "Display tables of data" command from "List" menu. The following option box in 

Figure 1-44 appears 

- In the "Display tables of data" option box, select "Loading" as an example for the data to 

 be listed in a table 

- Click "OK" button. The loading data are now listed on the screen (Figure 1-45) 

- Choose "Send to Word" from "File" menu if you wish to export the table to a MS Word 

application, Figure 1-46 

 

 
Figure 1-44 "Display tables of data" option box 
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Figure 1-45 List of loading data 

 

 
Figure 1-46 Exported data in MS Word 
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1 Description of the problem 

 

An example of a slab floor with girders is selected to illustrate some features of ELPLA for 

analyzing slab floors. 

 

1.1 Loads and dimensions 

 

The slab floor has a thickness of 10 [cm] and carries uniform loads with different intensities as 

shown in Figure 2-1. All girders have the same dimensions of 15 [cm] * 60 [cm]. Own weight of 

the girder may be taken as 1.875 [kN/m]. 
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Figure 2-1 Dimensions of the slab with loads 

 

1.2 Slab material 

 

Material of the slab is concrete (C 30/37) that has the following parameters: 

 

Young's modulus of concrete Eb   = 3.2 * 107 [kN/m2] 

Poisson's ratio of concrete vb   = 0.20   [-] 

Unit weight of concrete  γb    = 25  [kN/m3] 

Shear modulus of concrete Gb = 0.5 Eb (1+ vb) = 1.3 * 107 [kN/m2] 
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1.3 Analysis and concrete design 

 

The concrete sections are designed according to EC2 code for the following parameters: 

 

Concrete grade C 30/37 

Steel grade  BSt 500 

Characteristic compressive cylinder strength of concrete fck 

Characteristic tensile yield strength of reinforcement fyk 

Partial safety factor for concrete strength γc 

Design concrete compressive strength fcd = fck/ γc 

Partial safety factor for steel strength γs  

Design tensile yield strength of reinforcing steel fyd  = fyk/ γs 

 

 

= 30 

= 500 

= 1.5 

= 30/1.5 = 20 

= 1.15 

= 500/1.15 = 435 

 

 

[MN/m2] 

[MN/m2] 

[-] 

[MN/m2] 

[-] 

[MN/m2] 

 

This Tutorial Manual will not present the theoretical background of modeling the problem. For 

more information concerning the method of analysis, a complete reference for numerical 

calculation methods is well documented in the User’s Guide of ELPLA.  

 

 

2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a slab floor. The example 

will be processed step by step to show the possibilities and abilities of the program. To enter the 

data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project start the sub program ELPLA-Data and choose "New project" command 

from "File" menu. The "Calculation method" wizard appears, Figure 2-2. As shown in this 

Figure, the first form of the wizard is the "Analysis type" form. 

 

 
Figure 2-2 "Calculation method" wizard with "Analysis type" form 
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In the "Analysis type" form in Figure 2-2, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a slab floor problem, select 

"Analysis of slab floor" then click "Next" button to go to the next form. The next form is the 

"System symmetry", Figure 2-3. 

 

In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

 
Figure 2-3 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 2-4. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. 

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Check "Slab with girders" check box 

- Check "Concrete design" check box 

- Click "Save" button 

 



 

 

          ELPLA-Tutorial 

 

 

   2-6 

 
Figure 2-4 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box in Figure 2-5 appears. In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Floor". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 

 

 
Figure 2-5 "Save as" dialog box 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Floor] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 2-6. 

 

In the "Data" menu, the user can enter the remaining data of the project using the same sequence 

of commands in this menu. The first command in the menu is "Calculation methods", which has 

been already entered. Therefore, ELPLA has put the sign "√" beside this command, Figure 2-6. 
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ELPLA puts this sign beside the commands those the user has entered so that the user can know 

which data were defined. 

 

 
Figure 2-6 ELPLA-Data after defining the calculation method 

 

2.2 Project identification 

 

To identify the project choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 2-7 appears. 

 

In this dialog box 

 

- To describe the problem type the following line in the "Title" edit box:  

"Analysis of a slab floor" 

- Type the date of the project in the "Date" edit box 

- Type "Slab floor" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 2-7 "Project identification" dialog box 
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2.3 FE-Net data 

 

For the given problem, the slab has irregular shape and is divided into 7 * 6 elements. Element 

size in both x- and y-directions is 1.0 [m] as shown in Figure 2-1. ELPLA has different 

procedures for defining the same problem. The easy procedure to define the FE-Net of this slab 

is generating a mesh for the entire area first and then removing the unnecessary nodes to get the 

slab shape. 

 

To define the FE-Net for this slab, choose "FE-Net data" command from "Data" menu. The "FE-

Net generation" wizard appears as shown in Figure 2-8. This wizard will guide you through the 

steps required to generate the FE-Net. As shown in Figure 2-8, the first form of the wizard is the 

"Slab type" form which contains a group of templates of different shapes of nets. These net 

templates are used to generate standard nets that have constant size in both x- and y-directions.  

 

To generate the FE-Net 

 

- Choose the rectangular slab option in the "Slab type" options 

- Type 7 in the "Length of rectangular slab" edit box 

- Type 6 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 2-8 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "Slab type" form, the following "Generation type" form appears, 

Figure 2-9. ELPLA can deal with various types of generation with triangle and/ or rectangular 

elements. 

 

In the "Generation type" form 

 

- Choose rectangular elements 

- Click "Next" 
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Figure 2-9 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 2-10 appears with default values of constant element size. 

 

In this dialog box 

 

- In "Grid in x-direction" frame, type 7 in the "No. of  grid spaces" edit box 

- In "Grid in y-direction" frame, type 6 in the "No. of  grid spaces" edit box 

- Click "Finish" button 

 

ELPLA will generate a FE-Net for a rectangular slab of 7 [m] length and 6 [m] width with square 

elements of 1.0 [m] each side. The following embedded program in Figure 2-11 appears with the 

generated net. 

 

 
Figure 2-10 "FE-Net generation" dialog box 
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Figure 2-11 FE-Net of a rectangular slab on the screen 

 

Deleting nodes from the FE-Net 

 

To select the unnecessary nodes, that are required to be removed from the net, first choose 

"Select nodes" command from the "Graphically" menu in Figure 2-12. When "Select nodes" 

command is chosen, the cursor will change from an arrow to a cross hair. The command 

"Remove nodes" in the menu "Graphically" will be enabled, indicating the mode in which is 

being operated. Next, select the required nodes by clicking on each node individually or selecting 

a group of nodes as shown in Figure 2-12. A group of nodes can be selected by holding the left 

mouse button down at the corner of the region. Then, drag the mouse until a rectangle 

encompasses the required group of nodes. When the left mouse button is released, all nodes in 

the rectangle are selected. 
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Figure 2-12 Generated FE-Net after selecting the unnecessary nodes 

 

To remove the selected nodes, choose "Remove nodes" command from the "Graphically" menu. 

The action of this command is indicated in Figure 2-13. To leave the graphic mode, press "Esc" 

key. 

 

 
Figure 2-13 Final FE-Net after deleting the unnecessary nodes 
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After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 2-13 to save the data of the 

FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 2-13 to close "FE-Net" 

embedded program and to return to the main window of ELPLA-Data 

 

2.4 Girders 

 

To define the girders choose "Girders" command from "Data" menu of ELPLA-Data. The 

following embedded program in Figure 2-14 appears. 

 

 
Figure 2-14 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 2-14. The following 

option box in Figure 2-15 appears 

- In this option box, select the option of cross section definition. Although the cross section 

of the girder must be defined whether it is T or L girder type, but for simplicity a 

rectangular cross section is chosen in this example to define the girder cross section 

- Click "OK" button 
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Figure 2-15 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 2-16 appears. 

 

In this list box 

 

- Enter the material properties of the girder, cross section dimensions and the girder weight 

as indicated in Figure 2-16. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" button 

 

 
Figure 2-16 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define girder locations on the net 

graphically. 

 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 2-14. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder. Then drag the mouse until 

the end node of that girder (Figure 2-17) and click on the end node. The "Girder 

elements" dialog box in Figure 2-18 appears 
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Figure 2-17 Add girder by mouse 

 

In this dialog box click "OK" button. 

 

 
Figure 2-18 "Girder elements" dialog box 

 

Now, the first girder is defined as shown in Figure 2-19. Note that ELPLA has already typed 1 on 

the girder indicating the No. of girder group. 
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Figure 2-19 First girder on the screen 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 2-20. 

 

 
Figure 2-20 Girders on the screen 
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After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 2-20 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 2-20 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

In general, columns under the slab are considered as rigid supports. These supports are defined 

by the "Supports/ Boundary conditions" command. To define supports choose "Supports/ 

Boundary conditions" command from "Data" menu of ELPLA-Data. The following embedded 

program in Figure 2-21 appears. 

 

 
Figure 2-21 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads, etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. 

 

To view the girder on the FE-Net when defining the other data 

 

- Choose "View grouping" command from "Option" Menu in Figure 2-21. The "View 

grouping" check group box in Figure 2-22 appears 

- In this check group box, check "Girders" check box 

- Click "OK" button 
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Figure 2-22 "View grouping" check group box 

 

After clicking "OK" in the "View grouping" check group box, the screen should look like the 

following Figure 2-23. 

 

 
Figure 2-23 Girders in the window of the "Supports/ Boundary conditions" embedded program 

 

Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. 
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To define supports on the net 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 2-23. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have supports as shown in Figure 2-23 

- After selecting nodes of supports, choose "Add boundaries" command from 

"Graphically" menu (Figure 2-23). The "Supports/ Boundary conditions" dialog box in 

Figure 2-25 appears 

 

In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define a rigid support 

- Click "OK" button 

 

ELPLA can calculate the punching stresses due to reactions of column supports. In this example, 

data corresponding to column dimensions are not required. Therefore, the user can take these 

data from the default column dimensions and consider all supports have column type 1. 

 

 
Figure 2-24 Selection of nodes that have supports 
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Figure 2-25 "Supports/ Boundary conditions" dialog box 

 

After you have completed the definition of the supports, the screen should look like the 

following Figure 2-26. 

 

 
Figure 2-26 Supports on the screen 
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After entering supports, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 2-26 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure 

2-26 to close the "Supports/ Boundary conditions" embedded program and to return to 

the main window of ELPLA-Data 

 

2.6 Slab properties 

 

To define the slab properties choose "Slab properties" command from "Data" menu of ELPLA-

Data. The following embedded program in Figure 2-27 appears with default slab properties. The 

data of slab properties for the current example, which are required to define, are raft material and 

slab thickness. 

 

 
Figure 2-27 "Slab properties" embedded program 

 

To enter the slab material and thickness 

 

- Choose "Element groups" command from "In Table" menu in the window of Figure 2-27. 

The following list box in Figure 2-28 with default data appears. To enter or modify a 

value in this list box, type that value in the corresponding cell and then press "Enter" key. 

In the list box of Figure 2-28, enter E-Modulus of the slab, Poisson’s ratio of the slab and 

slab thickness 

- Click "OK" button 
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Figure 2-28 "Defining element groups" list box 

 

To enter the unit weight of the slab 

 

- Choose "Unit weight of the slab" command from "Slab properties" menu in the 

window of Figure 2-27. The following dialog box in Figure 2-29 with a default unit 

weight of 25 [kN/m3] appears 

- Click "OK" button 

 

 
Figure 2-29 "Unit weight of the slab" dialog box 

 

After entering the slab properties, do the following two steps: 

 

- Choose "Save slab properties" command from "File" menu in Figure 2-27 to save the slab 

properties 

- Choose "Close slab properties" command from "File" menu in Figure 2-27 to close the 

"Slab properties" embedded program and to return to the main window of ELPLA-Data 

 

2.7 Reinforcement data 

 

The reinforcement of the slab can be carried out according to the design codes EC 2, DIN 1045, 

ACI and ECP (working stress and limit state design methods). In the current example, the 

concrete sections of the slab are designed according to EC 2 for Concrete grade C 30/37 and 

Steel grade BSt 500. The concrete cover for the slab may be taken as (Figure 2-30): 

 

Top concrete cover +1/2 bar diameter in x-direction 

Bottom concrete cover +1/2 bar diameter in x-direction 

Top concrete cover +1/2 bar diameter in y-direction 

Bottom concrete cover +1/2 bar diameter in y-direction 

d1x = 1.5 

d2x = 1.5 

d1y = 2 

d2y = 2 

[cm] 

[cm] 

[cm] 

[cm] 
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As,topx

As,topy

As,boty
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d1y
d1x

d2y
d2x

d

 
 

Figure 2-30 Section geometry and reinforcement parallel to x-direction 

 

It is important to say that the design code parameters such as partial safety factors for concrete 

strength, steel strength and internal forces are defined by choosing the "Design code parameters" 

command from "Main data" menu in ELPLA-Data, while reinforcement data such as design 

code, concrete grade, steel grade and concrete covers are defined by choosing the 

"Reinforcement" command from "Data" menu in ELPLA-Data. Design code parameters are 

standard data for all projects while reinforcement data may be varied from one project to another. 

 

To define the reinforcement data choose "Reinforcement" command from "Data" menu of 

ELPLA-Data. The dialog box in Figure 2-31 appears with default reinforcement data. 

 

 
Figure 2-31 "Reinforcement" dialog box 

 

In this dialog box 

 

- Select design code "EC 2" in the "Design code" combo box 

- Select steel grade "BSt 500" in the "Steel grade" option box 

- Select concrete grade "C 30/37" in the "Concrete grade" option box 

- Select the default concrete covers as indicted in the "Concrete cover" dialog group box 

- Click "Save" button 
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2.8 Loads 

 

To define the loads choose "Loads" command from "Data" menu of ELPLA-Data. The following 

embedded program in Figure 2-32 appears with girders on the net. 

 

 
Figure 2-32 "Loads" embedded program 

 

Defining loads on the net may be carried out either graphically or numerically (in a table). In the 

current example the user will learn how to define loads on the net graphically. 

 

To enter the first distributed loads 

 

- Choose "Distributed loads" command from "Graphically" menu in the window of Figure 

2-32. When "Distributed loads" command is chosen, the cursor is changed from an arrow 

to a cross hair. Then the load can be defined by holding the left mouse button down at the 

starting point of the distributed load. As the mouse is dragged, a box appears, indicating a 

distributed load is being defined. When the left mouse button is released, the following 

dialog box in Figure 2-33 appears with the load value and coordinates 

 

In this dialog box 

 

- Type 3.5 in the "Load value" edit box 

- Click "OK" button 
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Figure 2-33 "Loading" dialog box 

 

After you have completed the definition of the first distributed load, the screen should look like 

the following Figure 2-34. 

 

 
Figure 2-34 First distributed load on the screen 
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Repeat the previous steps to enter the remaining distributed loads on the net. After you have 

completed the definition of all loads on the net, the screen should look like the following Figure 

2-35. 

 

 
Figure 2-35 Loads on the FE-Net 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure  2-35 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 2-35 to close the "Loads" 

embedded program and to return to the main window of ELPLA-Data 

 

Creating the project of the slab floor is now complete. It is time to analyze this project. In the 

next section you will learn how to use ELPLA for analyzing projects. 
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3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 2-36 appears.  

 

 
Figure 2-36 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Assembling the load vector 

- Assembling the girder stiffness matrix 

- Assembling the slab stiffness matrix 

- Solving system of linear equations (band matrix) 

- Determining deformation, internal forces 

- Design of the slab 

 

These calculation items can be carried out individually or in one time. 
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3.2 Carrying out all computations 

 

To carry out all computations in one time choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 2-37 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 2-37 Analysis progress menu 

 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution in Figure 2-38 appears. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 2-38 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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4 Viewing data and result graphics  

 

ELPLA can view the data and results for the slab and girders either separately or together. 

Individual data or results for the slab can be viewed in a manner similar to that in the previous 

example. Here, the user will learn to view the results of the girders through the following sample. 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. 

 

ELPLA-Graphic window in Figure 2-39 appears. ELPLA-Graphic automatically opens the data 

file of the current example and displays the data file name in the title bar of ELPLA-Graphic 

window. 

 

 
Figure 2-39 Opening screen of the sub program ELPLA-Graphic 

 

To view the results of girders choose "Girders" command and then the "Distribution of internal 

forces in the plan" command from "Graphic" menu of ELPLA-Graphic. The following option 

box in Figure 2-40 appears. 

 

In this option box 

 

- Select "Beam-Bending moments Mb" as a sample for the results to be displayed 

- Click "OK" button 

 

The moments are now displayed for the girders as shown in Figure 2-41. 
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Figure 2-41 "Distribution of internal forces in the plan" option box 

 

 
Figure 2-41 Beam-Bending moments Mb 
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1 Description of the problem 

 

An example of a system of two equal large circular rafts is selected to illustrate some features of 

ELPLA for analyzing system of foundations. 

 

1.1 Loads and dimensions 

 

Each raft has a diameter of 22 [m] and thickness of 0.65 [m]. Loading on each raft consists of 24 

column loads, in which 16 column loads have P1 = 1250 [kN] and 8 column loads have P2 = 

1000 [kN] as shown in Figure 3-1 and Table 3-1. The origin coordinates for raft 1 in the global 

system are (0.0, 0.0) while for raft 2 they are (0.0, 22.5). 

 

 

Platte 2Platte 1

P1=1250 [kN]

P2=1000 [kN]

P1
P1

P2

y

x

P2

 
 

 

Figure 3-1 System of two equal circular rafts 

 

1.2 Raft material 

 

Material of the two rafts is supposed to have the following parameters: 

 

Young's modulus   Eb = 2.6 * 107  [kN/m2] 

Poisson's ratio   νb  = 0.15   [-] 

Unit weight of raft material  γb  = 0.0   [kN/m3] 

 

Unit weight of the raft material is chosen to be γb = 0.0 to neglect the own weight of the raft in 

the analysis. 
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1.3 Soil properties 

 

The rafts rest on a silt layer of 15 [m] thickness. The Modulus of compressibility of the silt is Es = 

9 500 [kN/m2]. Poisson's ratio of the soil is taken to be νs = 0.0 [-]. The level of foundation under 

the ground surface is assumed to be df = 0.0 [m]. The effect of the reloading pressure on the soil 

and the uplift pressure on the rafts are neglected. 

 

1.4 Method of analysis 

 

It is required to analyze the system of rafts together according to the following soil model and 

numerical calculation method: 

 

- Layered soil medium - Continuum Model 

- Modulus of compressibility method for an elastic raft on layered soil medium  

(Solving system of linear equations by iteration-method 6) 

 

This Tutorial Manual will not present the theoretical background of modeling the problem. For 

more information concerning the method of analysis, a complete reference for the soil models 

and numerical calculation methods are well documented in the User’s Guide of ELPLA.  

 

Table 3-1 Point loads P 

 
 ----------------------------------------------------- 

 Load No.     Load value     x-position     y-position 

        I              P              x              y 

      [-]           [kN]            [m]            [m] 

 ----------------------------------------------------- 

        1           1250           7.75             11 

        2           1250          14.25             11 

        3           1250             11           7.75 

        4           1250             11          14.25 

        5           1250            8.7            8.7 

        6           1250           13.3            8.7 

        7           1250            8.7           13.3 

        8           1250           13.3           13.3 

        9           1000              2             11 

       10           1000             20             11 

       11           1000             11              2 

       12           1000             11             20 

       13           1000           4.64           4.64 

       14           1000          17.36           4.64 

       15           1000           4.64          17.36 

       16           1000          17.36          17.36 

       17           1000           2.69           7.56 

       18           1000           7.56           2.69 

       19           1000          14.44           2.69 

       20           1000          19.31           7.56 

       21           1000           2.69          14.44 

       22           1000           7.56          19.31 

       23           1000          14.44          19.31 

       24           1000          19.31          14.44 

 ----------------------------------------------------- 
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2 Creating the project of raft 1 

 

In this section the user will learn how to create a project for analyzing system of two rafts. Thus 

is done by first entering the data of the two rafts individually in the same manner of the previous 

foundation example and then creating a project for the system of two rafts. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 3-2. This wizard will 

guide you through the steps required to create the project. As shown in this Figure, the first form 

of the wizard is the "Analysis type" form. In this form define the analysis type of the problem, 

where ELPLA can deal with different structural systems. As the analysis type is a foundation 

problem, select "Analysis of slab foundation" then click "Next" button to go to the next form. 

 

 
Figure 3-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button the "Calculation methods" form appears, Figure 3-3. 

 

To define the calculation method 

 

- Select the calculation method "6-Modulus of Compressibility (Iteration)" 

- Select subsoil model "Layered soil model" 

- Click "Next" button to go to the next form 
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Figure 3-3 "Calculation methods" form 

 

The next form is the "System symmetry" (Figure 3-4). In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

 
Figure 3-4 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 3-5. In this list ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. Since no option will be considered in the analysis, click the "Save" button. 
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Figure 3-5 "Options" list 

 

After clicking "Save" button the "Save as" dialog box appears, Figure 3-6. 

 

In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example type 

"Raft 1". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button 

 

 
Figure 3-6 "Save as" dialog box 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Raft1] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 3-7. 

 

In the "Data" menu the user can enter the remaining data of the project using the same sequence 

of commands in this menu. The first command in the menu is "Calculation methods", which has 

been already entered. Therefore ELPLA has put the sign "√" beside this command (Figure 3-7). 

ELPLA puts this sign beside the commands those the user has entered so that the user can know 

which data were defined. 
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Figure 3-7 ELPLA-Data after defining the calculation method 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data window. The dialog box in Figure 3-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of system of two circular rafts" 

- Type the date of the project in the "Date" edit box 

- Type "Raft 1" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 3-8 "Project identification" dialog box 
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2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data window. The "FE-Net 

generation" wizard appears (Figure 3-9). This wizard will guide you through the steps required to 

generate the FE-Net. As shown in this Figure the first form of the wizard is the "Slab type" form 

which contains a group of templates of different shapes of nets. These are used to generate 

standard nets that have irregular shapes. For the given problem the raft has a circular shape. 

 

To generate the FE-Net 

 

- In the "Slab type" options choose the circular slab option 

- Type 22 in the "Diameter of circular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 3-9 "Slab type" form 

 

The following "Generation type" form appears, Figure 3-10. ELPLA can deal with various types 

of generations with triangle and/ or rectangular elements. Choose the combination of triangle and 

rectangular elements option as the generation type. Click "Next" button to go to the next form. 

 

 
Figure 3-10 "Generation type" page 
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The next form of the "FE-Net generation" wizard is the "Generation parameters" form. In this 

form the default values of generation parameters appear, Figure 3-11. For the given problem 

mesh optimization options are not required. 

 

In this form 

 

- In the x-direction frame type 8 in the "No. of  circular divisions" edit box 

- Uncheck the "Smoothing mesh" option 

- Uncheck the "Directing border elements" option 

 

 
Figure 3-11 "Generation parameters" form 

 

Click "Finish" button in the "Generation parameters" form. ELPLA will generate a suitable FE-

Net for the circular raft of 22 [m] diameter with a combination of triangle and rectangular 

elements, which have equal areas. The following embedded program in Figure 3-12 appears with 

the generated net. 
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Figure 3-12 FE-Net on the screen 

 

After finishing generation of the FE-Net do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 3-12 to save the data of the 

FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 3-12 to close "FE-Net" 

embedded program and to return to the main window of ELPLA-Data 

 

2.4 Soil properties 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data window. The following sub program in Figure 3-13 appears with a default-boring log. 
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Figure 3-13 ELPLA-Boring sub program with a default-boring log 

 

Modifying data of boring log graphically 

 

In ELPLA it is also possible to define or modify the boring log graphically which makes the 

definition of the boring log very easy. By double-clicking the left mouse button on a specified 

screen position, the user can define or modify the soil data and input parameters graphically.  

 

To enter the geotechnical data of the soil layer 

 

- Double-click on the geotechnical data of the soil layer. The corresponding dialog box to 

modify the geotechnical data of the soil layer appears (Figure 3-14) 

- In the dialog group box "Geotechnical data of the layer" in Figure 3-14 define the 

geotechnical data of the soil layer as follows: 

  

Es   = 9500  [kN/m2] 

Ws   = 9500  [kN/m2] 

 

The values Es and Ws are the same, because the effect of reloading on the soil is not required. 

The unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due to the 

removed soil, which is equal to γs * df. In the current example df = 0.0, which means the unit 

weight of the soil is not required. However, the unit weight of the soil under the foundation 

depth is entered by the default value. Also the angle of internal friction φ and the cohesion c of 

the soil are not required because the selected type of the analysis is linear analysis. Therefore the 

user can let the default values of the internal friction and the cohesion. Next, click "OK" button. 

 



 

 

ELPLA-Tutorial 

 

 

 3-13 

 
Figure 3-14 "Geotechnical data of the soil layer" dialog box 

 

To define the soil type and color for the layer 

 

- Double-click on the soil symbol of the soil layer. The corresponding dialog box to modify 

the soil symbols of that layer appears (Figure 3-15) 

- Select "U, Silt" as the soil type in the "Main soil type 1" combo box in the dialog group 

box "Soil and rock symbols" in Figure 3-15. The color of the silt and a short text "U" 

according to the German specification code DIN 4023 will be automatically created 

- Click "OK" button 

 

 
Figure 3-15 "Soil and rock symbols" dialog box 

 

To modify the groundwater depth under the ground surface 

 

- Double-click on the groundwater level. The corresponding edit box to modify the 

groundwater depth under the ground surface appears, Figure 3-16. To neglect the uplift 

pressure on the raft, groundwater level is chosen at anywhere under the raft basement 

- Type 15 in the "Groundwater depth under the ground surface" edit box 

- Click "OK" button 
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Figure 3-16 "Groundwater depth under the ground surface" edit box 

 

To modify a layer depth 

 

- Double-click on the layer depth. The corresponding dialog edit box to modify the layer 

depth under the ground surface appears, Figure 3-17 

- Type 15 in the "Layer depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 3-17 "Layer depth under the ground surface" edit box 

 

To modify the label of a boring log 

 

- Double-click on the label of the boring log. The corresponding edit box to modify the 

label of the boring log appears, Figure 3-18 

- Type B1 in the edit box of Figure 3-18 

- Press "Enter" key to consider the text 

 

 
Figure 3-18 "Label of the boring log" edit box 

 

To enter the main soil data for the layer 

 

- Choose "Main soil data" from "Data" menu in Figure 3-13. The following dialog group 

box in Figure 3-19 appears 

- In this dialog group box enter the settlement reduction factor α [-], Poisson’s ratio of the 

soil νs [-] and the groundwater depth under the ground surface Gw [m] as indicated in 

Figure 3-19. Note that the groundwater depth under the ground surface was typed in the 

corresponding edit box because this value has been already defined graphically 

- Click "OK" button in the "Main soil data" dialog group box in Figure 3-19 
 



 

 

ELPLA-Tutorial 

 

 

 3-15 

 
Figure 3-19 "Main soil data" dialog group box 

 

After the user has completed the definition of all soil properties and parameters, the screen 

should look like the following Figure 3-20. 

 

 
Figure 3-20 Boring log on the screen 
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After entering all data and parameters of boring log do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 3-20 to save the data of 

the boring log 

- Choose "Close boring logs" command from "File" menu in Figure 3-20 to close ELPLA-

Boring and to return to the main window of ELPLA-Data 

 

2.5 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data window. The following embedded program in Figure 3-21 appears with 

default foundation properties. The data of foundation properties for the current example, which 

are required to define, are raft material and raft thickness. Any other data corresponding to 

foundation properties in the program menus are not required. Therefore the user can take these 

data from the default foundation properties. 

 

 
Figure 3-21 "Foundation properties" embedded program 

 

To enter the raft material and thickness 

 

- Choose "Element groups" command from "In Table" menu in the window of Figure 3-21. 

The following list box in Figure 3-22 with default data appears. To enter or modify a 

value in this list box, type that value in the corresponding cell, then press "Enter" key. In 

the list box of Figure 3-22 enter E-Modulus of the raft, Poisson’s ratio of the raft and raft 

thickness 

- Click "OK" button 
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Figure 3-22 "Defining element groups" list box 

 

To enter the unit weight of the raft 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" menu in 

the window of Figure 3-21. The following dialog box in Figure 3-23 with a default unit 

weight of 25 [kN/m3] appears. To neglect the self-weight of the raft in the analysis, type 0 

in the edit box "Unit weight of the foundation" 

- Click "OK" button 

 

 
Figure 3-23 "Unit weight of the foundation" dialog box 

 

After entering the foundation properties do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 3-21 to save 

the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 3-21 to close 

the "Foundation properties" embedded program and to return to the main window of 

ELPLA-Data 

 

2.6 Loads 

 

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data window. The 

following embedded program in Figure 3-24 appears. 
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Figure 3-24 "Loads" embedded program 

 

To enter loads 

 

- Choose "Point loads" command from "In Table" menu in the window of Figure 3-24. 

The following list box in Figure 3-25 appears 

- Enter the external point loads P [kN] and their corresponding coordinates (x, y) in the list 

box of Figure 3-25. This is done by typing the value in the corresponding cell and then 

press "Enter" key. The coordinates of the point load are related to the lower-left corner of 

the raft (local coordinates) 

- Click "OK" button 

 

 
Figure 3-25 "Point loads P" list box 
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After you have completed the definition of all load data, the screen should look like the 

following Figure 3-26. 

 

 
Figure 3-26 Loads on the screen 

 

After finishing the definition of load data do the following two steps: 

 

- Choose "Save loads" command from "File menu in Figure 3-26 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 3-26 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

The project creation of raft 1 is now complete. 

 

 

3 Creating the project of raft 2 

 

The data of the two rafts are quite similar except the origin coordinates of the global system, 

which are chosen to be (0, 0) and (0, 22.5) for rafts 1 and 2 respectively. Project identification is 

entered here so that the user can distinguish between the two projects. The data of raft 2 are 

created by first saving the data of raft 1 under a new file name and then modifying the project 

identification and origin coordinates. 

 

To save the data under a new file name 

 

- Choose "Save project as" command from "File" menu of ELPLA-Data window. The 

following "Save as" dialog box appears, Figure 3-27 
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In this dialog box 

 

- Type a file name for the project of raft 2 in the file name edit box, for example "Raft 2" 

- Click "Save" button 

 

 
Figure 3-27 "Save as" dialog box 

 

3.1 Modifying the project identification 

 

To modify the project identification of raft 2 choose "Project identification" command from 

"Data" menu of ELPLA-Data window. The dialog box in Figure 3-28 appears. 

 

In this dialog box 

 

- Type "Raft 2" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 3-28 "Project identification" dialog box 

 

3.2 Modifying origin coordinates 

 

To modify the origin coordinates of raft 2, choose "Foundation properties" command from 

"Data" menu of ELPLA-Data window. The following embedded program in Figure 3-29 appears.  
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Figure 3-29 "Foundation properties" embedded program 

 

In this "Foundation properties" embedded program 

 

- Choose "Origin coordinates" command from "Foundation properties" menu in the 

window of Figure 3-29. The following dialog box in Figure 3-30 appears 

- Type 22.5 in the "x-coordinate" edit box 

- Click "OK" button 

 

 
Figure 3-30 "Origin coordinates" dialog box 
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After entering the foundation properties do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 3-29 to save 

the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 3-29 to close 

the "Foundation properties" embedded program and return to ELPLA-Data 

 

Creating the projects of the two rafts 1 and 2 is now complete. 

 

 

4 Creating the project of the system of rafts 1 and 2 

 

Data of system of many slabs are defined through the "Data" menu in ELPLA-Data, which in this 

case contains the following two commands: 

 

- "Filenames of slabs foundations" command 

- "Project identification" command 

 

4.1 Filenames of slab foundations 

 

Choose "New project" command from the "File" menu of ELPLA-Data window. The following 

"Calculation method" wizard in Figure 3-31 appears. 

 

 
Figure 3-31 "Calculation method" wizard 

 

In this wizard 

 

- Select "Analysis of system of many slab foundations", as the analysis type is a system of 

two rafts 

- Click "Next" button 
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After clicking "Next" button "Filenames of slab foundations" list box in Figure 3-32 appears. 

 

 
Figure 3-32 "Filenames of slab foundations" list box 

 

To enter the file names of the rafts, which are required to be analyzed as a system of foundations, 

click "Add project". After clicking "Add project" the "Open" dialog box in Figure 3-33 appears. 

 

In this dialog box 

 

- Type the file name of raft 1 in the file name edit box 

- Click "Open" 

 

 
Figure 3-33 "Open" dialog box 

 

Repeat the previous steps and enter the file name of raft 2. After the user has completed the 

definition of file names of the projects, the list box should look like the following Figure 3-34. 
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Figure 3-34 "Filenames of slab foundations" list box after entering file names of the projects 

 

Click "Save" button in the "List of filenames of slab foundations" list box in Figure 3-34. After 

clicking "Save" button the "Save as" dialog box in Figure 3-35 appears. 

 

In this dialog box 

 

- Type a file name for the project of a system of rafts in the file name edit box. For 

example type "Raft 1 + 2" 

- Click "Save" button 

 

 
Figure 3-35 "Save as" dialog box 

 

4.2 Project identification 

 

The project of a system of rafts is considered as an independent project. Therefore, like the single 

rafts, a new identification of the project of the system of rafts must be entered.  

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data window. The dialog box in Figure 3-36 appears. 
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In this dialog box 

 

- Click "Load" button and open the project identification data of raft 1 

- Modify "Raft 1" to "Raft 1 + 2" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 3-36 "Project identification" dialog box 

 

Creating the project is now complete. The next step is analyzing the problem. 

 

 

5 Carrying out the calculations 

5.1 Starting ELPLA-Solver 

 

To analyze the problem, leave ELPLA-Data to ELPLA-Solver. This is done by clicking on 

"Solver" in the menu bar of the sub programs at the upper-right corner of ELPLA-Data window. 

Then ELPLA-Solver window appears, Figure 3-37. 

 

 
Figure 3-37 Opening screen of the sub program ELPLA-Solver 
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ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis. 

For the current example the items, which are required to be calculated, are: 

 

- Assembling the load vector        

- Determining flexibility coefficients of the soil      

- Determining flexibility coefficients of the soil for system of slabs 

- Assembling the soil stiffness matrix       

- Iteration process  

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time.  

 

5.2 Carrying out all computations 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Calculation" menu in ELPLA-Solver 

Window. The following "Iteration parameters" option box in Figure 3-38 appears 

- In "Iteration parameters" option box select the option of the iteration condition 

- Click "OK" button 

 

 
Figure 3-38 "Iteration parameters" option box 

 

The progress of all computations according to the defined method will be carried out 

automatically with displaying information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 3-39 appears, in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 3-39 Analysis progress menu 
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Iteration process 

 

Information about the convergence progress of the computations is displayed in the "Iteration 

process" list box in Figure 3-40 during the iteration process.  

 

 
Figure 3-40 "Iteration process" list box 

 

Check of convergence 

 

An accuracy number controls the convergence progress of the solution. The solution is 

considered convergent if the accuracy number of the step i + 1 is less than that of the previous 

step i. The maximum difference between the soil settlement and the slab deflection in [m] is 

considered as an accuracy number. A message box appears during the iteration process when the 

convergence becomes no longer convergent for example (Figure 3-41), 

 

where  the accuracy number of the iteration No. 5 = 0.00021766310 [m] 

 

while  the accuracy number of the iteration No. 4 = 0.00020922720 [m] 

 

 
Figure 3-41 "Check of convergence" message box 

 

In this case the user can either stop the iteration process and save the results of iteration No. 5 or 

continue the iteration process until reaching the convergence.  

 

Do the next steps to continue the iteration process: 

 

- Click "OK" button in the "Check of convergence" message box in Figure 3-41. 

The "Iteration process" list box in Figure 3-42 appears. Note that the "Pause" button 

changes to "Continue" button 

- Click "Continue" button 
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Figure 3-42 "Iteration process" list box 

 

Check of the solution 

 

Once the analysis is complete, a check menu of the solution appears, Figure 3-43. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 3-43 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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6 Viewing data and results 

 

ELPLA can view the data and results for each raft separately or for the system of rafts together. 

Individual data or results can be viewed in a manner similar to that in the previous examples. 

Here the user will learn to view the results of the system of rafts together through the following 

two samples. 

 

6.1 Viewing result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Solver window. 

 

ELPLA-Graphic window appears, Figure 3-44. ELPLA-Graphic automatically opens the data file 

of the current example and displays the data file name in the title bar of ELPLA-Graphic 

window. 

 

 
Figure 3-44 Opening screen of the sub program ELPLA-Graphic 

 

To view the results as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The following option box in Figure 3-45 appears 

- In "Results as contour lines" option box select "Settlements s" as a sample for the results 

to be displayed 

- Click "OK" button 
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The settlements are now displayed as contour lines for the two rafts together as shown in Figure 

3-46. 

 

 
Figure 3-45 "Results as contour lines" option box 

 

 
Figure 3-46 Settlements as contour lines 

 

6.2 Plot a diagram of the results 

 

To plot a diagram of the results, leave ELPLA-Graphic to ELPLA-Section. This is done by 

clicking on "Section" in the menu bar of the sub programs at the upper-right corner of ELPLA-

Graphic window. 
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ELPLA-Section window appears without file name in the window title bar, Figure 3-47. The 

disappearance of the file name in the window title bar indicates that ELPLA-Section cannot deal 

with the results of a system of rafts directly. 

 

 
Figure 3-47 Opening screen of the sub program ELPLA-Section 

 

To consider the results for the system of rafts together 

 

- Choose "Open" command from "File" menu of ELPLA-Section. Then open the project 

"Raft 1" 

- Choose "Combination from many projects" command from "File" menu of ELPLA-

Section. The following list box in Figure 3-48 appears. ELPLA-Section automatically 

considers the project "Raft 1" in the list of projects to be combined 

- Click "Add project" button in "Combination from many projects" list box. Then open the 

project "Raft 2" 

- Click "OK" button in the "Combination from many projects" list box 
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Figure 3-48 "Combination from many projects" list box 

 

To plot a section in x-direction 

 

- Choose "Section in x-direction" command from "Sections" menu of ELPLA-Section.  

The following option box in Figure 3-49 appears 

- In "Section in x-direction" option box select "Settlements s" as a sample for the results to 

be plotted in a diagram 

- Click "OK" button 

 

 
Figure 3-49 "Section in x-direction" option box 

 

The following option box in Figure 3-50 appears, to specify the section in x-direction that is 

required to be plotted. 

 

In this dialog box 

 

- Type 11 in the "Section at y-coordinate" edit box, to plot a diagram at the middle of the 

two rafts 

- Click "OK" button 

 

The settlements are now plotted in a diagram at the middle of the two rafts together as shown in 

Figure 3-51. 
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Figure 3-50 "Section in x-direction" dialog box 

 

 
Figure 3-51 Diagram of settlements in x-direction at nodal row No. 14 for the two rafts 
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1 Description of the problem 

 

An example of a grid resting on 8 supports is selected to illustrate some features of ELPLA for 

analyzing grids. 

 

1.1 Loads and dimensions 

 

The grid consists of equal girders that have dimensions of 0.15 [cm] * 0.60 [cm]. Geometry of 

the grid and loads on it including the own weight are shown in Figure 4-1. 
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Figure 4-1 Geometry of the grid and loads 

 

1.2 Grid material 

 

Material of the grid has the following parameters: 

 

Young's modulus Eb = 3.2 * 107  [kN/m2] 

Shear modulus Gb = 1.3 * 107  [kN/m2] 

 

1.3 Analysis of the grid 

 

It is required to analyze the grid using 1.0 [m] beam element in both x- and y-directions and 

considering the supports to be rigid in z-direction only. This Tutorial Manual will not present the 

theoretical background of modeling the problem. For more information concerning the method 

of analysis a complete reference for numerical calculation methods are well documented in the 

User’s Guide of ELPLA. 
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2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a grid. The example will 

be processed step by step to show the possibilities and abilities of the program. To enter the data 

of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose "New project" command from 

the "File" menu. The "Calculation methods" wizard appears, Figure 4-2. The wizard will guide 

you through the steps required to create the system data of the project. As shown in Figure 4-2, 

the first form of the wizard is the "Analysis type" form.  

 

 
Figure 4-2 "Calculation method" wizard with "Analysis type" form 

 

In Figure 4-2 define the analysis type of the problem where ELPLA can deal with different 

structural systems. As the analysis type is a grid problem, select "Analysis of grid". Then click 

"Next" button to go to the next form. 

 

The next form is the "System symmetry" (Figure 4-3). In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 
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Figure 4-3 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 4-4. In this list ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. 

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 

 

 
Figure 4-4 "Options" list 
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After clicking "Save" button the "Save as" dialog box appears (Figure 4-5). 

 

In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Grid". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Grid] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 4-5 "Save as" dialog box 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data window. The dialog box in Figure 4-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title edit" box:  

"Analysis of a grid" 

- Type the date of the project in the "Date" edit box 

- Type "Grid" in the "Project edit" box 

- Click "Save" button 

 

 
Figure 4-6 "Project identification" dialog box 
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2.3 FE-Net data 

 

To enter the grid geometry, an imaginary net must be first defined with suitable dimensions and 

then the grid is entered lately by connecting the corresponding nodes on the net that defines the 

grid shape. To define the net for the grid geometry, choose "FE-Net data" command from "Data" 

menu. The "FE-Net generation" wizard appears as shown in Figure 4-7. This wizard will guide 

you through the steps required to generate the FE-Net. The first form of the wizard is the "Slab 

type" form which contains a group of templates of different shapes of nets. These net templates 

are used to generate standard nets that have constant size in both x- and y-directions. 

 

To generate an imaginary net 

 

- Choose the rectangular slab option to create an imaginary net of a rectangular area 

- Type 7 in the "Length of rectangular slab" edit box 

- Type 6 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 4-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard the following "Generation type" form 

appears, Figure 4-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 
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Figure 4-8 "Generation type" form 

 

After clicking "Next" button in "Generation type" form the following "Grid definition" dialog 

box in Figure 4-9 appears with default values of constant element size. 

 

 
Figure 4-9 "FE-Net generation" dialog box 

 

In this dialog box 

 

- In "Grid in x-direction" frame type 7 in the "No. of  grid spaces" edit box 

- In "Grid in y-direction" frame type 6 in the "No. of  grid spaces" edit box 

- Click "Finish" button 

 

ELPLA will generate an imaginary net for a rectangular area of 7 [m] length and 6 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 4-10 

appears with the generated imaginary net. 
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Figure 4-10 Imaginary net of a rectangular area on the screen 

 

After finishing generation of the imaginary net do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu to save the data of the imaginary net 

- Choose "Close FE-Net" command from "File" menu to close "FE-Net" embedded 

program and to return to the main window of ELPLA-Data 

 

2.4 Girders 

 

To define the girders, choose "Girders" command from "Data" menu of ELPLA-Data window. 

The following embedded program in Figure 4-11 appears. 
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Figure 4-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 4-11. The following 

option box in Figure 4-12 appears 

- In this option box select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 4-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box the following list box in 

Figure 4-13 appears. In this list box 

 

- Enter the material properties of the girder, cross section dimensions and the girder weight 

as indicated in Figure 4-13. This is done by entering the value in the corresponding cell 

and press "Enter" key. For simplicity, the line loads, which include the own weight of the 

girder, are entered in the cell "Girder weight". Here two groups of girders are defined, the 

first group for girders that have a line load of 10 [kN/m] while the second group for 

girders that have a line load of 15 [kN/m] 

- Click "OK" button 
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Figure 4-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

This may be carried out either graphically or numerically (in a table). In the current example the 

user will learn how to define girder locations on the net graphically. 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 4-11. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 4-14). Then click on the end node. The "Girder 

elements" dialog box in Figure 4-15 appears 

 

 
Figure 4-14 Add girder by mouse  
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In this dialog box 

 

- Select the group No 

- Click "OK" button 

 

 
Figure 4-15 "Girder elements" dialog box 

 

Now the first girder is defined as shown in Figure 4-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

 
Figure 4-16 First girder on the screen 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 4-17. 
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Figure 4-17 Girders on the screen 

 

After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 4-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 4-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data window. The following embedded program in Figure 4-18 appears. 
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Figure 4-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data.  As shown in Figure 4-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. 

The "Plot parameters" dialog box in Figure 4-19 appears 

- In the "General plot parameters" tab uncheck the "Draw thickness" check box in the 

"Girder systems" dialog box 

- Click  "OK" button 
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Figure 4-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box the girders are drawn as simple lines as 

shown in Figure 4-20. 

 

 
Figure 4-20 Girders are drawn in simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define supports on the net 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 4-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have supports as shown in Figure 4-21 

-  After selecting nodes of supports choose "Add boundaries" command from 

"Graphically" menu in Figure 4-21. "Supports/ Boundary conditions" dialog box in 

Figure 4-22 appears 

 

 
Figure 4-21 Selection of nodes that have supports 

 

In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define a rigid support 

- Click "OK" button 
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Figure 4-22 "Supports/ Boundary conditions" dialog box 

 

ELPLA can calculate the punching stresses due to column reactions. In this example data 

corresponding to column dimensions are not required. Therefore the user can take these data 

from the default column dimensions and consider all supports have column type 1. After you 

have completed the definition of supports, the screen should look like the following Figure 4-23. 

 

 
Figure 4-23 Supports on the screen 
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After entering supports, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 4-23 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure 4-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data 

window. The following embedded program in Figure 4-24 appears with girders on the net. 

 

 
Figure 4-24 "Loads" embedded program 

 

The vertical concentrated loads on the grid can be defined at any position (x, y) on the grid. The 

position of the load is independent on nodes of the net. 

 

To enter the concentrated load choose "Point loads" command from "Graphically" menu in the 

window of Figure 4-24. When "Point loads" command is chosen, the cursor is changed from an 

arrow to a cross hair. Then the load can be defined by clicking on the screen (grid). The 

following dialog box in Figure 4-25 appears with the load value and coordinates. 

 

In this dialog box 

 

- Type 50 in the "Load value" edit box 

- Click "OK" button 
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Figure 4-25 "Point loads P" dialog box 

 

After you have completed the definition of the concentrated load, the screen should look like the 

following Figure 4-26. 

 

 
Figure 4-26 Concentrated load on the screen 
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After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 4-26 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 4-26 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

Creating the project of the grid is now complete. See how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver by clicking on "Solver" in the menu bar of the 

sub programs at the upper-right corner of ELPLA-Data window (Figure 4-27). 

 

 
Figure 4-27 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also ELPLA will activate the "Calculation" 

menu. This menu contains commands of all calculations, which depend on the analysis type. For 

the current example the items, which are required to be calculated, are: 

 

- Assembling the load vector 

- Assembling the girder stiffness matrix 

- Assembling the slab stiffness matrix 

- Solving system of linear equations (band matrix) 

- Determining deformation, internal forces 



 

 

ELPLA-Tutorial 

 

 

 4-21 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 4-28 appears, in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 4-28 Analysis progress menu 

 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution in Figure 4-29 appears. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 4-29 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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4 Viewing data and result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

4-30 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 4-30 Opening screen of the sub program ELPLA-Graphic 

 

To view the results of girders, choose "Girders" command and then "Internal forces in isometric 

view" command from "Graphic" menu of ELPLA-Graphic. The following option box in Figure 

4-31 appears. 

 

In this option box 

 

- Select "Beam-Bending moments Mb" as an example for the results to be displayed 

- Click "OK" button 

 

 
Figure 4-31 "Internal forces in isometric view" option box 

 

The moments are now displayed for the girders as shown in Figure 4-32. 
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Figure 4-32 Beam-Bending moments Mb 
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1 Description of the problem 

 

An example for analyzing stresses and deformations of a wrench is selected to illustrate some 

features of ELPLA for analyzing plane stress problems. 

 

1.1 Loads and dimensions 

 

The wrench shown in Figure 5-1 is 10 [mm] thick and about 200 [mm] in length. The wrench 

end is loaded with a pressure of 2 [N/mm] along 100 [mm] of its handle as shown.  

 

a

100 [mm]

2 [N/mm]

b

c

R = 10 [mm] 20 [mm]25 [mm]35 [mm]

45 [mm]

22.5 [mm]

45 [mm]

2.5 [mm]

32.5 [mm]

R =10 [ mm]

Thickness =10 [mm]

 

 

 

 

195 [mm]

R =30 [ mm]

 
 

Figure 5-1 Wrench dimensions and loads 

 

1.2 Wrench material 

 

Material of the wrench has the following parameters: 

 

Young's modulus Eb = 200000  [N/mm2] 

Poisson's ratio  νb = 0.3   [-] 

 

1.3 Analysis of the wrench 

 

It is required to analyze the stresses and deformations of the wrench when it is being used to 

tighten a bolt. Consider that there is no horizontal or vertical displacement along the lines where 

the wrench contacts the bolt. This Tutorial Manual will not present the theoretical background of 

modeling the problem. For more information concerning the method of analysis a complete 

reference for numerical calculation methods are well documented in the User’s Guide of ELPLA.  

 

1.4 System units 

 

Since the wrench dimensions are relatively small compared with those of foundations, it is 

preferred to use small units for measurement. To change the system units, choose "System of 

units" command from "Main data" menu of ELPLA-Data. The dialog box in Figure 5-2 appears. 

In this dialog box change the units for lengths and forces to [mm] and [N] respectively and then 

click "Save" button. 
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Figure 5-2 "System of units" dialog box 

 

Also ELPLA checks the element size when a mesh is generated. Since the element size of slab 

foundation is relatively large compared with those of a wrench, it is required to disable the 

element size check. To uncheck the element size when generating FE-Net, choose the 

"Preferences" command from "Main data" menu of ELPLA-Data. The dialog box in Figure 5-3 

appears. In this dialog box uncheck the "Check element size" option then click "Save" button. 

 

 
Figure 5-3 "Preferences" dialog box 

 

 

2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a plane stress problem. 

The example will be processed step by step to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation methods" wizard appears, Figure 5-4. The wizard will 

guide you through the steps required to create the system data of the project. As shown in this 

Figure, the first form of the wizard is the "Analysis type" form.  
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Figure 5-4 "Calculation method" wizard with "Analysis type" form  

 

In the "Analysis type" form in Figure 5-4, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a plane stress problem, select 

"Analysis of plane stress" option then click "Next" button to go to the next form.  

 

The next form is the "System symmetry" (Figure 5-5). In this form choose "Unsymmetrical 

system" and click "Next" button. 

 

The last form of the wizard assistant contains the "Option" list, Figure 5-6. In this list ELPLA 

displays some of the available options corresponding to the used numerical models, which differ 

from model to other. 

 

In this list check "Supports/ Boundary conditions" check box then click "Save" button. 
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Figure 5-5 "System symmetry" form 

 

 
Figure 5-6 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 5-7.  

 

In this dialog box, type a file name for the current project in the file name edit box. For example 

type "Wrench". ELPLA will use automatically this file name in all reading and writing processes. 

Then click "Save" button to complete the definition of the calculation method and the file name 

of the project. 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Wrench] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 
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Figure 5-7 "Save as" dialog box 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 5-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a Plane Stress Problem" 

- Type the date of the project in the "Date" edit box 

- Type "Wrench" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 5-8 "Project identification" dialog box 

 

2.3 FE-Net data 

 

To define the net for the wrench geometry, choose "FE-Net data" command from "Data" menu. 

The "FE-Net generation" wizard appears as shown in Figure 5-9. This wizard will guide you 

through the steps required to generate a FE-Net. The first form of the wizard is the "Slab type" 

form which contains a group of templates of different shapes of nets. These net templates are 

used to generate standard nets that have constant size in both x- and y-directions.  

 

To generate the FE-Net, choose the irregular slab option then click "Next" button to go to the 

next form. 
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Figure 5-9 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 5-10. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. In this form, choose the triangle elements option then click "Next". 

 

 
Figure 5-10 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "FE-Net generation" 

dialog box in Figure 5-11 appears with the default generation parameters. In this dialog box click 

"Finish" button. 
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Figure 5-11 "FE-Net generation" dialog box 

 

ELPLA will generate an imaginary net as shown in the following embedded program, Figure 5-

12. 

 

 
Figure 5-12 Imaginary net of a rectangular area on the screen 

 

You can either draw the wrench directly on this imaginary net or input the wrench corner points 

in tabulated form. To input the FE-Net corner points, choose "Slab corners" command from "In 

Table" menu. The dialog box in Figure 5-13 appears.  
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To define the first segment of the wrench which connects points a and b (Figure 5-1) 

 

- Type 45 in the "x1" edit box to define the x-coordinate of point a 

- Type 32.5 in the "y1" edit box to define the y-coordinate of point a 

- Type 190 in the "x2" edit box to define the x-coordinate of point b 

- Type 30 in the "y2" edit box to define the y-coordinate of point b 

 

 
Figure 5-13 "Slab corners" dialog box 

 

To define the second segment of the wrench which connects points b and c 

 

- Use the Scroll bar to define segment No. 2 

- Type 190 in the "x2" edit box to define the x-coordinate of point c 

- Type 10 in the "y2" edit box to define the y-coordinate of point c 

- Select the "Use arc data" option to convert the line segment to arc segment 

- Type 10 in the "Arc radius" edit box to define the radius of the arc segment 

 

In the "Slab corners" dialog box, ELPLA assumes that there are at least three segments with three 

corner points. Since the wrench drawing contains 11 segments, you can use the command 

"Segment insert" to insert the rest of the wrench segments. Use the corner points and arc 

information provided in Table 5-1 to complete the definition of the wrench corner points. Repeat 

the steps used for defining segment No. 1 to define any line segment and repeat those used for 

segment No. 2 to define any arc segment. 
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Table 5-1 Wrench Corner Points 

Segment 

 

[-] 

Start position  End position  Arc Radius 

 

[mm] 

x1 

[mm] 

y1 

[mm] 

x2 

[mm] 

y2 

[mm] 

1 45 32.5 190 30  

2 190 30 190 10 10 

3 190 10 45 7.5  

4 45 7.5 2.5 0 30 

5 2.5 0 0 5 10 

6 0 5 22.5 5  

7 22.5 5 32.5 20  

8 32.5 20 22.5 35  

9 22.5 35 0 35  

10 0 35 2.5 40 10 

11 2.5 40 45 32.5 30 

 

After completing the definition of the wrench corner points, the slab corner dialog box should be 

like this in Figure 5-14 where a small sketch of the wrench appears in the dialog box picture. 

Click the "OK" button to see the drawing of the wrench outlines as shown in Figure 5-15. 

 

 
Figure 5-14 "Slab corners" dialog box after defining the wrench corner points 
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Figure 5-15 Wrench outlines 

 

To complete the FE-Generation of the problem, choose "Generating FE-Net" command from 

"FE-Generation" menu. The following "Generation of FE-Net" dialog box appears. 

 
Figure 5-16 "Generation of FE-Net" dialog box 
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To enter the generation data 

 

- Type 4 in the "Element circumradius" edit box to define the radius of circles containing 

elements 

- Type 2 in the "Min. element circumradius" edit box to define the minimum radius of  

circles containing elements 

- Check the "Smoothing mesh" option to optimize the dimension of FE-Net by making all 

elements having nearly the same area as possible as 

- Click "OK" button 

 

After clicking the "OK" button, FE-Net generation progress menu in Figure 5-17 appears in 

which various phases of the generation are progressively reported. After finishing the generation 

of the FE-Net and creating the wrench FE-Net as shown in Figure 5-18, do the following two 

steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 5-18 to save the data of the 

FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 5-18 to close the "FE-Net" 

embedded program and return to the main window of  ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

 
Figure 5-17 "FE-Net generation" progress menu 
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Figure 5-18 Final FE-Net of the wrench 

 

2.4 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 5-19 appears. 
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Figure 5-19 "Supports/ Boundary conditions" embedded program 

 

Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. Considering that there are no horizontal or vertical displacements along the lines 

where the wrench contacts the bolt, all constrains will be applied only to the upper and bottom 

jaws of the wrench. 

 

To define supports on the net 

 

- Choose the "Zoom window" command from the "Window" menu to zoom the wrench 

head 

- Choose "Select nodes" command from the "Graphically" menu in Figure 5-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nods that have supports as shown in Figure 5-20 

- After selecting nodes of supports, choose "Add boundaries" command from 

"Graphically" menu in Figure 5-20. "Supports/ Boundary conditions" dialog box in 

Figure 5-21 appears 
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Figure 5-20 Selection of nodes that have supports 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Click "OK" button 

 

 
Figure 5-21 "Supports/ Boundary conditions" dialog box 

 

After you have completed the definition of supports, the screen should look like the following 

Figure 5-22. 
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Figure 5-22 Supports on the screen 

 

After entering supports, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 5-22 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure 5-

22 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of  ELPLA-Data 

 

2.5 Slab properties 

 

To define the material properties, choose "Slab properties" command from "Data" menu. The 

following embedded program in Figure 5-23 appears with default slab properties. The data of 

material properties for the current example, which are required to be defined, are wrench 

material and wrench thickness. 

 

To enter the wrench material and thickness, choose "Element groups" command from "In Table" 

menu. The following list box in Figure 5-24 appears. In this list box, enter the E-Modulus and 

Poisson’s ratio of the wrench material and wrench thickness. Then, click "OK" button to go to 

the next step. 
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Figure 5-23 "Slab properties" embedded program 

 

 
Figure 5-24 "Defining element groups" list box  

 

To enter the unit weight of the wrench material, choose "Unit weight of slab material" command 

from "Slab properties" menu in the window of Figure 5-23. The following dialog box in Figure 

5-25 with a default unit weight of 25 [kN/m3] appears. To neglect the self-weight of the wrench 

in the analysis, type 0 in the "Unit weight of slab material" edit box then click "OK" button. 
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Figure 5-25 "Unit weight of slab material" dialog box  

 

After entering the wrench material properties, do the following two steps: 

 

- Choose "Save Slab properties" command from "File" menu in Figure 5-23 to save the 

foundation properties 

- Choose "Close Slab properties" command from "File" menu in Figure 5-23 to close the 

"Slab properties" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Slab properties" command in "Data" menu 

of ELPLA-Data. 

 

2.6 Loads 

 

To define the load applied to the wrench, choose "Loads" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 5-26 appears. 

 

 
Figure 5-26 "Loads" embedded program 
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In plane stress problems, loads can be applied to nodes only. In this example the line load 

applied to the wrench will be converted to vertical concentrated loads applied to the wrench FE-

Net nodes. 

 

To enter the vertical concentrated load 

 

- Choose the "Zoom window" command from the "Window" menu to zoom the wrench 

end as shown in Figure 5-27  

- Choose "Select nodes" command from the "Graphically" menu in Figure 5-26. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair  

- Click the left mouse button on nodes that would have loads. Since the total force is 

200 [N] over a length of 100 [mm] and the nodes are generated at about [4] mm 

spacing, choose 25 nodes from the wrench end as shown in Figure 5-27 

- After selecting nodes of loads, choose "Add nodal loads" command from "Graphically" 

menu in Figure 5-27. "Nodal loads" dialog box in Figure 5-28 appears 

 

In this dialog box 

 

- Type 8 in the "Load Pv" edit box to define the vertical nodal loads 

- Click "OK" button 

 

After you have completed the definition of the concentrated loads, the screen should look like 

Figure 5-29. 

 

 
Figure 5-27 Select load nodes  
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Figure 5-28 "Nodal loads" dialog box 

 

 
Figure 5-29 Final loads 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 5-29 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 5-29 to close the "Loads" 

embedded program and return to the main window of  ELPLA-Data 

 

Creating the project of the wrench is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 
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3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 5-30 appears.  

 

 
Figure 5-30 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation        

- Analysis of plane stress 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 5-31 appears in which various phases of the calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 5-31 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

5-32 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 5-32 Opening screen of the sub program ELPLA-Graphic 
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ELPLA can show solid elements in three dimension view. To view elements with real dimension 

in 3D-view, choose "Plot parameters" command from "Options" menu of ELPLA-Graphic. The 

following "Plot parameters" dialog box in Figure 5-33 appears. In the "Solid elements" tab, 

check the following check boxes: "draw solid elements", "draw element border" and "color solid 

element", then click "OK". 

 

 
Figure 5-33 "Plot parameters" option box 

 

To view the wrench in 3D-view, choose "Data in isometric view" command from "Graphic" 

menu of ELPLA-Graphic. The following option box in Figure 5-34 appears. In this option box, 

select "Slab thickness" option, then click "OK" button. The wrench is now displayed as solid 

elements in 3D-view as shown in Figure 5-35. 

 

 
Figure 5-34 "Data in isometric view" option box 
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Figure 5-35 Wrench in isometric view 

 

To view the results as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The following option box in Figure 5-36 appears 

- In this option box, select "Maximum shear stresses max_Sigma" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The maximum shear stresses are now displayed as contour lines as shown in Figure 5-37. 

 

 
Figure 5-36 "Results as contour lines" option box 
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Figure 5-37 Maximum shear stresses max_Sigma 
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1 Description of the problem 

 

Since truss structure is considered as a special case of plane frame problems, an example of a 

two-dimensional truss structure is selected to illustrate some features of ELPLA for analyzing 

plane frames. 

 

1.1 Loads and dimensions 

 

The truss consists of 4 equal spans. All truss members have a cross section area of 0.01 [m2] and 

moment of inertia of 0.00001 [m4]. Geometry of the truss and loads are shown in Figure 6-1.  

 

 

60 [kN]60 [kN] 60 [kN]

4*3 = 12 [m]

4 [m]

 
 

Figure 6-1 Geometry of the truss and loads 

 

1.2 Truss properties 

 

The properties of the truss are: 

 

Young's modulus   Eb = 2 * 108  [kN/m2] 

Area of the member   A = 0.01   [m2] 

Moment of inertia of the member I = 0.00001  [m4] 

 

1.3 Analysis of the grid 

 

It is required to analyze the truss assuming that all members are pin connected. This Tutorial 

Manual will not present the theoretical background of modeling the problem. For more 

information concerning the method of analysis, a complete reference for numerical calculation 

methods is well documented in the User’s Guide of ELPLA. 
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2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a truss as a plane frame 

example. The example will be processed step by step to show the possibilities and abilities of the 

program. To enter the data of the example, follow the instructions and steps in the next 

paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation methods" wizard appears, Figure 6-2. The wizard will 

guide you through the steps required to create the system data of the project. As shown in Figure 

6-2, the first form of the wizard is the "Analysis type" form.  

 

 
Figure 6-2 "Calculation method" wizard with "Analysis type" form  

 

In the "Analysis type" form in Figure 6-2, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a truss problem, select 

"Analysis of plane frame". Then click "Next" button to go to the next form. 

 

The next form is the "System symmetry", Figure 6-3. In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

The last form of the wizard assistant contains the "Option" list, Figure 6-4. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other.  

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 

 



 

 

                   ELPLA-Tutorial 

 

 

   6-5 

 
Figure 6-3 "System symmetry" form 

 

 
Figure 6-4 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 6-5.  

 

In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Truss". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 
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ELPLA will activate the "Data" menu. Also the file name of the current project [Truss] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 6-5 "Save as" dialog box 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 6-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box: 

"Analysis of a plane frame" 

- Type the date of the project in the "Date" edit box 

- Type "Truss" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 6-6 "Project identification" dialog box 

 

2.3 FE-Net data 

 

To enter the truss geometry, an imaginary net must be first defined with suitable dimensions and 

then the truss is entered lately by connecting the corresponding nodes on the net that define the 

truss shape. To define the net for the truss geometry, choose "FE-Net data" command from 

"Data" menu. The "FE-Net generation" wizard appears as shown in Figure 6-7. This wizard will 

guide you through the steps required to generate the FE-Net. The first form of the wizard is the 

"Slab type" form which contains a group of templates of different shapes of nets (Figure 6-7). 
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These net templates are used to generate standard nets that have constant size in both x- and y-

directions. 

 

To generate an imaginary net 

 

- In the "Slab type" options, choose the rectangular slab option to create an imaginary net 

of a rectangular area 

- Type 12 in the "Length of rectangular slab" edit box 

- Type 4 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 6-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 6-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 
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Figure 6-8 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 6-9 appears with default values of constant element size.  

 

In this "Grid definition" dialog box 

 

- Type 12 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 4 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 1 in the "Grid interval Dx" edit box 

- Type 1 in the "Grid interval Dy" edit box 

- Click "Finish" 

 

ELPLA will generate an imaginary net for a rectangular area of 12 [m] length and 4 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 6-10 

appears with the generated imaginary net. 

 

 
Figure 6-9 "FE-Net generation" dialog box 
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Figure 6-10 Imaginary net of a rectangular area on the screen 

 

After finishing the generation of the imaginary net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 6-10 to save the data of the 

imaginary net 

- Choose "Close FE-Net" command from "File" menu in Figure 6-10 to close "FE-Net" 

embedded program and to return to the main window of  ELPLA-Data 

 

2.4 Girders 

 

To define the truss members, choose "Girders" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 6-11 appears. 
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Figure 6-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 6-11. The following 

option box in Figure 6-12 appears 

- In this option box select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 6-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 6-13 appears. 

 

In this list box 

 

- Enter the material properties of the girder, cross section dimensions and the girder weight 

as indicated in Figure 6-13. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" 
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Figure 6-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define girder locations on the net 

graphically. 

 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 6-11. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 6-14). Then, click on the end node. The "Girder 

elements" dialog box in Figure 6-15 appears 
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Figure 6-14 Add girder by mouse 

 

In this dialog box 

 

- Select the group No. 

- Click "OK" 

 

 
Figure 6-15 "Girder elements" dialog box 

 

Now, the first girder is defined as shown in Figure 6-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 6-17. 



 

 

                   ELPLA-Tutorial 

 

 

   6-13 

 
Figure 6-16 First girder on the screen 

 

 
Figure 6-17 Girders on the screen 
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After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 6-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 6-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 6-18 appears. 

  

 
Figure 6-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads, etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data. As shown in Figure 6-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. The "Plot parameters" dialog 

box in Figure 6-19 appears 

- In the "General plot parameters" tab, uncheck the "Draw thickness" check box in the 

"Girder systems" dialog box 

- Click "OK" button 

 



 

 

                   ELPLA-Tutorial 

 

 

   6-15 

 
Figure 6-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box, the girders are drawn as simple lines as 

shown in Figure 6-20. 

 

 
Figure 6-20 Girders are drawn in simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define the hinged support 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 6-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have hinged supports as shown in Figure 6-21 

- Choose "Add boundaries" command from "Graphically" menu in Figure 6-21. "Supports/ 

Boundary conditions" dialog box in Figure 6-22 appears 

 

 
Figure 6-21 Selection of hinged support node 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Click "OK" button 
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Figure 6-22 "Supports/ Boundary conditions" dialog box 

 

To define the roller support, repeat the steps used to define the hinged support except that the 

displacement in x-direction is free. To make the displacement of the roller support is free in x-

direction, type "F" in the "Displacement u" instead of typing "0". 

 

After you have completed the definition of supports, the screen should look like the following 

Figure 6-23. 

 

 
Figure 6-23 Supports on the screen 
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Defining hinges for truss members 

 

Assuming all truss members are pin connected, these members will be defined as hinged-hinged 

elements. Defining element hinges on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define element hinges 

on the net graphically. 

 

To define the element hinged, choose "Edit hinges" command from the "Graphically" menu in 

Figure 6-20. When "Edit hinges" command is chosen, the cursor will change from an arrow to a 

cross hair. Double click on the element that has the hinges. "Edit hinges" dialog box in Figure 6-

24 appears. 

 

 
Figure 6-24 "Edit hinges" dialog box 

 

In this dialog box, choose "I and J Hinge" from the hinge types list to define both ends of the 

element as hinges. Then click "OK" button. 

 

After you have completed the definition of element hinges, the screen should look like the 

following Figure 6-25. 
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Figure 6-25 Supports and hinges on the screen 

 

After entering supports and hinges, do the following two steps: 

 

- Choose "Save supports/ boundary conditions" command from "File" menu in Figure 6-23 

to save the data of supports 

- Choose "Close supports/ boundary conditions" command from "File" menu in Figure 6-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 6-26 appears with girders on the net. 
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Figure 6-26 "Loads" embedded program 

 

Although the user can define loads on both girder element and girder nodes in plane frame 

problem, in the truss problem we will define the loads at nodes only. 

 

To enter the concentrated load at nodes choose "Select nodes" command from "Graphically" 

menu in the window of Figure 6-26. When "Select nodes" command is chosen, the cursor is 

changed from an arrow to a cross hair. Choose nodes to be loaded as shown in Figure 6-27. Then 

choose "Add nodal loads" command from "Graphically" menu, the "Nodal loads" dialog box 

shown in Figure 6-28 appears. In this dialog box, type 60 in the "Load Pv" edit box to define the 

vertical nodal load then click "OK" button. 
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Figure 6-27 Selection of loaded nodes 

 

 
Figure 6-28 "Nodal loads" dialog box 

 

After you have completed the definition of the nodal loads, the screen should look like the 

following Figure 6-29. 
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Figure 6-29 Truss load on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 6-29 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 6-29 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

Creating the project of the grid is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 
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3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 6-30 appears.  

 

 
Figure 6-30 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation 

- Analysis of plane frame 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 6-31 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 6-31 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

6-32 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 6-32 Opening screen of the sub program ELPLA-Graphic 
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To view the results of girders, choose "Beam results" command and then "Distribution of 

internal forces (in plane)" command from "Graphic" menu of ELPLA-Graphic. The following 

option box in Figure 6-33 appears. 

 

In this option box 

 

- Select "Beam-Normal forces N" as an example for the results to be displayed 

- Click "OK" button 

 

 
Figure 6-33 "Distribution of internal forces (in plane)" option box 

 

The normal forces are now displayed for the truss as shown in Figure 6-34. 

 

 
Figure 6-34 Truss normal forces 
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1 Description of the problem 

 

An example for analyzing a plane frame is selected to illustrate some features of ELPLA for 

analyzing frames. 

 

1.1 Loads and dimensions 

 

The frame is shown in Figure 7-1. All frame members have cross section dimensions of 0.2 [m] 

* 0.5 [m]. Geometry of the frame and loads are shown in Figure 7-1. 

 

 

100 [kN]60 [kN/m]
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5 [m]
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Figure 7-1 Geometry of the frame and loads 

 

1.2 Frame material  

 

Material of the frame has the following parameter: 

 

Young's modulus Eb = 2 * 107  [kN/m2] 

 

1.3 Analysis of the frame 

 

It is required to analyze the plane frame. This Tutorial Manual will not present the theoretical 

background of modeling the problem. For more information concerning the method of analysis a 

complete reference for numerical calculation methods are well documented in the User’s Guide 

of ELPLA. 
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2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a plane frame example. 

The example will be processed step by step to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation methods" wizard appears, Figure 7-2. The wizard will 

guide you through the steps required to create the system data of the project. As shown in Figure 

7-2, the first form of the wizard is the "Analysis type" form.  

 

 
Figure 7-2 "Calculation method" wizard with "Analysis type" form 

 

In the "Analysis type" form in Figure 7-2, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a plane frame problem, select 

"Analysis of plane frame". Then click "Next" button to go to the next form. 

 

The next form is the "System symmetry" (Figure 7-3). In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

The last form of the wizard assistant contains the "Option" list, Figure 7-4. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. 
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In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 

 

 
Figure 7-3 "System symmetry" form 

 

 
Figure 7-4 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 7-5.  
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In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Frame". ELPLA will use automatically this file name in all reading and writing 

processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Frame] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 7-5 "Save as" dialog box 

 

2.2 Project identification  

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 7-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a plane frame" 

- Type the date of the project in the "Date" edit box 

- Type "Frame" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 7-6 "Project identification" dialog box 
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2.3 FE-Net data 

 

To enter the frame geometry, an imaginary net must be first defined with suitable dimensions 

and then the frame is entered lately by connecting the corresponding nodes on the net that define 

the frame shape. To define the net for the frame geometry, choose "FE-Net data" command from 

"Data" menu. The "FE-Net generation" wizard appears as shown in Figure 7-7. This wizard will 

guide you through the steps required to generate the FE-Net. The first form of the wizard is the 

"Slab type" form, which contains a group of templates of different shapes of nets (Figure 7-7). 

These net templates are used to generate standard nets that have constant size in both x- and y-

directions. 

 

To generate an imaginary net 

 

- In the "Slab type" options, choose the rectangular slab option to create an imaginary net 

of a rectangular area 

- Type 10 in the "Length of rectangular slab" edit box 

- Type 5 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 7-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 7-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 
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Figure 7-8 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 7-9 appears with default values of constant element size. 

 

In this "Grid definition" dialog box 

 

- Type 10 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 5 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 1 in the "Grid interval Dx" edit box 

- Type 1 in the "Grid interval Dy" edit box 

- Click "Finish" button 

 

ELPLA will generate an imaginary net for a rectangular area of 10 [m] length and 5 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 7-10 

appears with the generated imaginary net. 

 

 
Figure 7-9 "FE-Net generation" dialog box 
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Figure 7-10 Imaginary net of a rectangular area on the screen 

 

After finishing the generation of the imaginary net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 7-10 to save the data of the 

imaginary net 

- Choose "Close FE-Net" command from "File" menu in Figure 7-10 to close "FE-Net" 

embedded program and to return to the main window of ELPLA-Data 

 

2.4 Girders 

 

To define the frame members, choose "Girders" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 7-11 appears. 
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Figure 7-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In table" menu in Figure 7-11. 

The following option box in Figure 7-12 appears 

- In this option box, select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 7-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 7-13 appears. 

 

In this list box 

 

- Enter the material properties of the girder, cross-section dimensions and the girder weight 

as indicated in Figure 7-13. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" button 
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Figure 7-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will define girder locations on the net graphically. 

 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 7-14. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 7-14). Then, click on the end node. The "Girder 

elements" dialog box in Figure 7-15 appears 
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Figure 7-14 Add girder by mouse 

 

In this dialog box 

 

- Select the group No. 

- Click "OK" button 

 

 
Figure 7-15 "Girder elements" dialog box 

 

Now, the first girder is defined as shown in Figure 7-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 
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Figure 7-16 First girder on the screen 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 7-17. 

 

 
Figure 7-17 Girders on the screen 
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After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 7-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 7-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 7-18 appears. 

  

 
Figure 7-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data.  As shown in Figure 7-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. The "Plot parameters" dialog 

box in Figure 7-19 appears 

- In the "General plot parameters" tab, uncheck the "Draw thickness" check box in the 

"Girder systems" dialog box 

- Click "OK" button 
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Figure 7-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box, the girders are drawn as simple lines as 

shown in Figure 7-20.  

 

 
Figure 7-20 Girders are drawn as simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define the fixed support 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 7-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nods that have the fixed supports as shown in Figure 7-21 

-  Choose "Add boundaries" command from "Graphically" menu in Figure 7-21. 

"Supports/ Boundary conditions" dialog box in Figure 7-22 appears 

 

 
Figure 7-21 Selection of fixed support node 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Type 0 in the "Rotation Theta" edit box to define the moment supports 

- Click "OK" button 
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Figure 7-22 "Supports/ Boundary conditions" dialog box 

 

To define the hinged support, repeat the steps used to define the fixed support except that the 

support is free to rotate. To make the rotation of the hinged support is free, type "F" in the 

"Rotation Theta" instead of typing "0". 

 

After you have completed the definition of supports, the screen should look like the following 

Figure 7-23. 

 

 
Figure 7-23 Supports on the screen 
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Defining hinges for frame members 

 

Defining element hinges on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define element hinges on the net 

graphically. 

 

To define the element hinged, choose "Edit hinges" command from the "Graphically" menu in 

Figure 7-20. When "Edit hinges" command is chosen, the cursor will change from an arrow to a 

cross hair. Double click on the element that has hinges. "Edit hinges" dialog box in Figure 7-24 

appears. 

 

 
Figure 7-24 "Edit hinges" dialog box 

 

In this dialog box, choose "I and J Hinge" from the hinge types list to define both ends of the 

element as hinges. Then click "OK" button. 

 

After you have completed the definition of element hinges, the screen should look like the 

following Figure 7-25. 
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Figure 7-25 Supports and hinges on the screen 

 

After entering supports and hinges, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 7-23 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure 7-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 7-26 appears with girders on the net. 
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Figure 7-26 "Loads" embedded program 

 

To enter the concentrated load at nodes, choose "Select nodes" command from "Graphically" 

menu in the window of Figure 7-26. When "Select nodes" command is chosen, the cursor is 

changed from an arrow to a cross hair. Choose a node to be loaded as shown in Figure 7-27.  

 

 
Figure 7-27 Selection of loaded node 
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Then choose "Add nodal loads" command from "Graphically" menu, the "Nodal loads" dialog 

box shown in Figure 7-28 appears. In this dialog box, type 100 in the "Load Pv" edit box to 

define the vertical nodal load and then click "OK" button. The node should be loaded as shown 

in Figure 7-29. 

 

 
Figure 7-28 "Nodal loads" dialog box 

 

 
Figure 7-29 Vertical nodal load 

 

Another node to be loaded is chosen as shown in Figure 7-30. Choose "Add nodal loads" 

command from "Graphically" menu, the "Nodal loads" dialog box shown in Figure 7-31 appears.  
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Figure 7-30 Selection of loaded node 

 

 
Figure 7-31 "Nodal loads" dialog box 

 

In this dialog box, type -80 in the "Load Ph" edit box to define the horizontal nodal load then 

click "OK" button. The loaded node is shown in Figure 7-32. 
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Figure 7-32 Horizontal nodal load 

 

To input the uniform distributed load, choose "Edit member load" command from "Graphically" 

menu. When "Edit member load" command is chosen, the cursor will change from an arrow to a 

cross hair. Double click on the element that has the uniform distributed load. "Edit member load" 

dialog box in Figure 7-33 appears. The loaded member is shown in Figure 7-34. 

 

  
Figure 7-33 "Edit member load" dialog box 
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Figure 7-34 Loaded member 

 

Use the same steps to input the uniform distributed load on the inclined member. After you have 

completed the definition of the load data, the screen should look like the following Figure 7-35. 

 

 
Figure 7-35 Frame load on the screen 
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After finishing the definition of load data, do the following two steps: 

 

- Choose " Save loads" command from "File" menu in Figure 7-35 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 7-35 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

Creating the project of the frame is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 7-36 appears.  

 

 
Figure 7-36 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation 

- Analysis of plane frame 

 

These calculation items can be carried out individually or in one time.  



 

 

ELPLA-Tutorial 

 

 

   7-26 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 7-37 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 7-37 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

7-38 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 
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Figure 7-38 Opening screen of the sub program ELPLA-Graphic 

 

To view the results of girders, choose "Beam results" command and then "Distribution of 

internal forces (in plane)" command from "Graphic" menu of ELPLA-Graphic. The following 

option box in Figure 7-39 appears. 

 

In this option box 

 

- Select "Beam-Bending moments Mb" as an example for the results to be displayed 

- Click "OK" button 

 

 
Figure 7-39 Distribution of internal forces (in plane)" option box 

 

The bending moments are now displayed for the frame as shown in Figure 7-40. 
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Figure 7-40 Frame bending moments 

 

 

5 General remarks about two-dimensional frame problems 

5.1 Introduction 

 

This section describes directions of coordinate systems and singes of input actions such as 

element loads and nodal loads or sings of results such as reactions, displacements and internal 

forces, which are used when modeling two-dimensional frame problems by ELPLA. 

 

5.2 Coordinate systems 

 

There are two different coordinates for two-dimensional frame problems, global coordinate 

system and local coordinate system (Figure 7-41). Each of these coordinate systems is used to 

describe certain data such as the location of nodes or the direction of loads, displacements, 

internal forces and reactions. Understanding these different coordinate systems is essential to the 

user to being able to properly define the problem. 
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Figure 7-41 System Coordinates 

 

5.3 Element Loads 

 

As shown in Figure 7-42, ELPLA uses a different vertical direction for defining loads. The 

positive value of load means that it is a downward load. Nodal loads are applied on global 

coordinates where element loads are applied in three different cases as follows: 

 

Self weight 

A vertical uniform load distributed along the length of the element 

 

Snow load 

A vertical uniform load distributed along the horizontal projection of the element 

 

Wind load 

A uniform load distributed along the length of the element with a direction perpendicular to the 

element (local x´ axis) 
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b) Snow load c) Wind loada) Self weight
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Figure 7-42 Cases of element loads, nodal loads and nodal reactions with directions 

 

5.4 Graphical output 

 

Graphical outputs of results such as displacements, rotations and internal forces (bending 

moments, shear forces and normal forces) are drawn in locale coordinate. 
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1 Description of the problem 

 

An example for analyzing a beam is selected to illustrate some features of ELPLA for analyzing 

beams. 

 

1.1 Loads and dimensions 

 

The beam is shown in Figure 8-1. All beam members have cross section dimensions of 0.2 [m] * 

0.5 [m]. Geometry of the beam and loads are shown in Figure 8-1. 

 

 

100 [kN]

40 [kN/m]

3 [m]2 [m] 3 [m]

80 [kN/m]

2 [m] 1 [m]

60 [kN.m]

 
 

Figure 8-1 Geometry of the beam and loads 

 

1.2 Beam material  

 

Material of the beam is: 

 

Young's modulus Eb = 2 * 107  [kN/m2] 

 

1.3 Analysis of the beam 

 

To analyze the beam, the beam is divided in beam elements, each has a length of 1.0 [m]. This 

Tutorial Manual will not present the theoretical background of modeling the problem. For more 

information concerning the method of analysis, a complete reference for numerical calculation 

methods is well documented in the User’s Guide of ELPLA. 

 

 

2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a plane beam example. 

The example will be processed step by step to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose "New project" command from 

the "File" menu. The "Calculation methods" wizard appears, Figure 8-2. The wizard will guide 

you through the steps required to create the system data of the project. As shown in Figure 8-2, 

the first form of the wizard is the "Analysis type" form.  
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Figure 8-2 "Calculation method" wizard with "Analysis type" form 

 

In the "Analysis type" form in Figure 8-2, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a plane beam problem, select 

"Analysis of plane beam". Then click "Next" button to go to the next form. 

 

The next form is the "System symmetry" (Figure 8-3). In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

The last form of the wizard assistant contains the "Option" list, Figure 8-4. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other.  

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 
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Figure 8-3 "System symmetry" form 

 

 
Figure 8-4 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 8-5.  

 

In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Beam". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 
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ELPLA will activate the "Data" menu. Also the file name of the current project [Beam] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 8-5 "Save as" dialog box 

 

2.2 Project identification  

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 8-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a plane beam" 

- Type the date of the project in the "Date" edit box 

- Type "Beam" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 8-6 "Project identification" dialog box 

 

2.3 FE-Net data 

 

To enter the beam geometry, an imaginary net must be first defined with suitable dimensions and 

then the beam is entered lately by connecting the corresponding nodes on the net that define the 

beam shape. To define the net for the beam geometry, choose "FE-Net data" command from 

"Data" menu. The "FE-Net generation" wizard appears as shown in Figure 8-7. This wizard will 

guide you through the steps required to generate the FE-Net. The first form of the wizard is the 

"Slab type" form, which contains a group of templates of different shapes of nets. These net 

templates are used to generate standard nets that have constant size in both x- and y-directions.  
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To generate an imaginary net 

 

- In the "Slab type" options, choose the rectangular slab option to create an imaginary net 

of a rectangular area 

- Type 11 in the "Length of rectangular slab" edit box 

- Type 2 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 8-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 8-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 

 

 
Figure 8-8 "Generation type" form 
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After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 8-9 appears with default values of constant element size.  

 

In this dialog box 

 

- Type 11 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 2 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 1 in the "Grid interval Dx" edit box 

- Type 1 in the "Grid interval Dy" edit box 

- Click "Finish" button 

 

ELPLA will generate an imaginary net for a rectangular area of 11 [m] length and 2 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 8-10 

appears with the generated imaginary net. 

 

 
Figure 8-9 "FE-Net generation" dialog box 
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Figure 8-10 Imaginary net of a rectangular area on the screen 

 

After finishing the generation of the imaginary net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 8-10 to save the data of the 

imaginary net 

- Choose "Close FE-Net" command from "File" menu in Figure 8-10 to close "FE-Net" 

embedded program and to return to the main window of ELPLA-Data 

 

2.4 Girders 

 

To define the beam members, choose "Girders" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 8-11 appears. 
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Figure 8-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 8-11.  

The following option box in Figure 8-12 appears 

- In this option box, select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 8-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 8-13 appears. 

 

In this list box 

 

- Enter the material properties of the girder, cross-section dimensions and the girder weight 

as indicated in Figure 8-13. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" button 
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Figure 8-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will define girder locations on the net graphically. 

 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 8-14. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 8-14). Then, click on the end node. The "Girder 

elements" dialog box in Figure 8-15 appears 

 

In this dialog box 

 

- Select the group No. 

- Click "OK" button 
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Figure 8-14 Add girder by mouse 

 

 
Figure 8-15 "Girder elements" dialog box 

 

Now, the first girder is defined as shown in Figure 8-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

One note should be taken into consideration that girder ends are at exchanged nodes, for example 

supported nodes, hinged nodes and loaded nodes, so we should have five girders in this example. 
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Figure 8-16 First girder on the screen 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 8-17. 

 

 
Figure 8-17 Girders on the screen 
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After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 8-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 8-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 8-18 appears. 

 

 
Figure 8-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data.  As shown in Figure 8-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. 

The "Plot parameters" dialog box in Figure 8-19 appears 

- In the "General plot parameters" tab, uncheck the "Draw girder thickness" check box in 

the "Girder systems" dialog box 

- Click "OK" button 
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Figure 8-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box, the girders are drawn as simple lines as 

shown in Figure 8-20. 

 

 
Figure 8-20 Girders are drawn as simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define the fixed support 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 8-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have the fixed supports as shown in Figure 8-21 

- Choose "Add boundaries" command from "Graphically" menu in Figure 8-21 

- "Supports/   Boundary conditions" dialog box in Figure 8-22 appears 

 

 
Figure 8-21 Selection of fixed support node 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Type 0 in the "Rotation Theta" edit box to define the moment supports 

- Click "OK" button 
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Figure 8-22 "Supports/ Boundary conditions" dialog box 

 

To define the roller support, repeat the steps used to define the fixed support except that the 

support is free to rotate and the displacement in x-direction is free. To make the rotation of the 

roller support is free, type "F" in the "Rotation Theta" instead of typing "0". To make the 

displacement of the roller support is free in x-direction, type "F" in the "Displacement u" instead 

of typing "0". After you have completed the definition of supports, the screen should look like 

the following Figure 8-23. 

 

 
Figure 8-23 Supports on the screen 
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Defining hinges for beam members 

 

Defining element hinges on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define element hinges on the net 

graphically. 

 

To define the hinged node, the hinge is defined from two sides on both left and right elements 

that have a hinged end. Choose "Edit hinges" command from the "Graphically" menu in Figure 

8-20. When "Edit hinges" command is chosen, the cursor will change from an arrow to a cross 

hair. Double click on the element that has a hinged end. "Edit hinges" dialog box in Figure 8-24 

appears. 

 

 
Figure 8-24 "Edit hinges" dialog box 

 

In this dialog box, choose "I Hinge" from the hinge types list to define one end of the element as 

hinge. Then click "OK" button. The screen should look like Figure 8-25. 
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Figure 8-25 Hinged end of the element 

 

Double click on the other element that has the hinged end. "Edit hinges" dialog box in Figure 8-

24 appears. 

 

Choose "J Hinge" from the hinge types list to define one end of the element as hinge. Then click 

"OK" button. 

 

After you have completed the definition of element hinges, the screen should look like the 

following Figure 8-26. 
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Figure 8-26 Supports and hinges on the screen 

 

After entering supports and hinges, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 8-23 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure  8-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 8-27 appears with girders on the net. 
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Figure 8-27 "Loads" embedded program 

 

To enter the nodal loads, choose "Select nodes" command from "Graphically" menu in the 

window of Figure 8-27. When "Select nodes" command is chosen, the cursor is changed from an 

arrow to a cross hair. Choose a node to be loaded as shown in Figure 8-28.  

 

 
Figure 8-28 Selection of loaded node 
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Then choose "Add nodal loads" command from "Graphically" menu, the "Nodal loads" dialog 

box shown in Figure 8-29 appears. In this dialog box, type 100 in the "Load Pv" edit box to 

define the vertical nodal load, type also –60 in the "Moment M" edit box then click "OK" button. 

The node should be loaded as shown in Figure 8-30. 

 

 
Figure 8-29 "Nodal loads" dialog box 

 

 
Figure 8-30 Nodal loads 
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To input the uniform distributed loads, choose "Edit member load" command from "Graphically" 

menu. Then the cursor will change from an arrow to a cross hair. Double click on the element 

that has the uniform distributed load. "Edit member load" dialog box in Figure 8-31 appears. In 

this dialog box, type 80 in the "Member loads" edit box to define the member load then click 

"OK" button. The loaded member is shown in Figure 8-32. The distributed loads in this example 

are "Self weight" types. To more about distributed load types, see the ELPLA User’s Guide. 

 

 
Figure 8-31 "Edit member load" dialog box 

 

 
Figure 8-32 Loaded member 
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Use the same steps to input the uniform distributed load on the other loaded member. After you 

have completed the definition of the load data, the screen should look like the following Figure 

8-33. 

 

 
Figure 8-33 Beam loads on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 8-33 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 8-33 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

You can get the supports and the system of loading together on the screen. Choose "View 

grouping" command from "Options" list and the following dialog box in Figure 8-34 appears.  

 

 
Figure 8-34 View grouping dialog box 

 

Check the "Supports/Boundary conditions" check box then click the "OK" button. The screen 

should look like Figure 8-35.  
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Figure 8-35 Beam supports and system of loading on the screen 

 

Creating the project of the beam is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 8-36 appears. 
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Figure 8-36 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation      

- Analysis of plane beam 

 

These calculation items can be carried out individually or in one time.  

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 8-37 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 
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Figure 8-37 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

8-38 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 8-38 Opening screen of the sub program ELPLA-Graphic 

 

To view the results of girders, choose "Beam results" command and then "Distribution of 

internal forces (in plane)" command from "Graphic" menu of ELPLA-Graphic. The following 

option box in Figure 8-39 appears. 

 

In this option box 

 

- Select "Beam-Bending moments Mb" as an example for the results to be displayed 

- Click "OK" button 
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Figure 8-39 "Distribution of internal forces (in plane)" option box 

 

The bending moments are now displayed for the beam as shown in Figure 8-40. 

 

 
Figure 8-40 Beam bending moments 
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1 Description of the problem 

 

An example of two neighboring buildings is selected to illustrate some of the essential features 

of ELPLA for studying the influence of a new building on an existing old one. 

 

1.1 Loads and dimensions 

 

Figure 9-1 shows plan and section of a new building II beside a similar old one I. The building I 

was constructed for a long time, while the building II will be constructed close to the first one. 

The two buildings have the same construction geometry and loads. In addition, every building is 

symmetrical about both x- and y-axes. 

 

Each foundation has a side of 10.08 [m] and thickness of 1.0 [m]. Loading on each foundation 

consists of 9 column loads as shown in Figure 9-1 and in Table 9-1. In spite of the two buildings 

are closed to each other, a small distance of 20 [cm] is assumed between them to avoid 

overlapping their nodes. The origin coordinates for the building I in the global system are (10.28, 

0.0) while those for the building II are (0.0, 0.0). 

 

Table 9-1 Point loads P 
------------------------------------------------- 

Load No.        Load    X-coord.      Y-coord. 

               value                             

       I           P           x            y 

     [-]        [kN]          [m]          [m] 

------------------------------------------------- 

       1        500          0.72          0.72 

       2        500          0.72          9.36 

       3        500          9.36          9.36 

       4        500          9.36          0.72 

       5       1000          5.04          9.36 

       6       1000          5.04          0.72 

       7       1000          9.36          5.04 

       8       1000          0.72          5.04 

       9       2000          5.04          5.04 
------------------------------------------------- 
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Figure 9-1 Action of new building II on the old building I 
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1.2 Foundation material and thickness 

 

The foundation material and thickness are supposed to have the following parameters: 

 

Foundation thickness d  = 1.0   [m] 

Young's modulus Eb  = 2 * 107 [kN/m2] 

Unit weight b  = 0.0   [kN/m3] 

Poisson's ratio b  = 0.15   [-] 

 

Unit weight of the foundation material is assumed to be zero to neglect its own weight in the 

analysis. 

 

1.3 Soil properties 

 

The subsoil under the buildings consists of a layer of stiff plastic clay with 5.70 [m] thickness, 

overlying a rigid base (Figure 9-1a). The soil is supposed to have the following parameters: 

 

Modulus of compressibility for loading Es  = 5000  [kN/m2] 

Modulus of compressibility for reloading Ws  = 15000 [kN/m2] 

Unit weight s  = 18   [kN/m3] 

 

1.4 Mathematical model 

 

The influence of surrounding structures and external loads can be taken into consideration only 

for the Continuum model (methods 4 to 9). The Continuum model based on, the settlement at 

any node is affected by the forces at all the other nodes. In this example, the Modulus of 

compressibility method (method 7) is chosen to analyze both of the two buildings. 

 

This tutorial manual will not present the theoretical background of modeling the problem. For 

more information concerning the method of analysis, a complete reference for the soil models 

and numerical calculation methods are well documented in the User’s Guide of ELPLA.  

 

1.5 Analysis 

 

To analyze foundations, each foundation is subdivided into elements with 132 nodes as shown in 

Figure 9-1b. Two independent names define the data of the two buildings are chosen. The data 

are quite similar for the two buildings except the origin coordinates, which are chosen to be (xo, 

yo) = (10.28, 0.0) and (0.0, 0.0) for buildings I and II, respectively. In spite of the two buildings 

are closed to each other, a small distance of 20 [cm] is assumed between them to avoid 

overlapping their nodes. 

 

The analysis of the new building II is carried out first to obtain the contact pressures under it.  

Due to these contact pressures, settlements will occur not only under the building II but also 

outside under the building I. Then, under the assumption that left beside the old building a new 

building will be constructed, the contact pressures, settlements and internal forces of the old 

building are determined. 
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2 Creating the project of the new building II 

 

In this section, the user will learn how to create a project for analyzing system of two 

foundations. Thus is done by first entering the data of the two foundations individually in the 

same manner of the previous foundation example. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 9-2. This wizard will 

guide you through the steps required to create the project. As shown in Figure 9-2, the first form 

of the wizard is the "Analysis type" form. In this form, define the analysis type of the problem 

where ELPLA can deal with different structural systems. As the analysis type is a foundation 

problem, select "Analysis of slab foundation" then click "Next" button to go to the next page. 

 

 
Figure 9-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button, the "Calculation methods" form appears, Figure 9-3.  

 

To define the calculation method 

 

- Select the calculation method "7-Modulus of Compressibility (Elimination)" 

- Click "Next" button to go to the next form 
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Figure 9-3 "Calculation methods" form 

 

The next form is the "System symmetry" (Figure 9-4). In this form choose "Unsymmetrical 

system" and then click "Next" button. 

 

 
Figure 9-4 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 9-5. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. There isn’t any requested choices, so click the "Save" button. 
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Figure 9-5 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 9-6. 

 

In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example 

type "New Building II". ELPLA will use automatically this file name in all 

reading and writing processes 

- Click "Save" button 

 

 
Figure 9-6 "Save as" dialog box 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [New Building II] 

will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 9-7. 

 

In the "Data" menu, the user can enter the remaining data of the project using the same sequence 

of commands in this menu. The first command in the menu is "Calculation methods", which has 

been already entered. Therefore, ELPLA has put the sign "√" beside this command, Figure 9-7. 
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ELPLA puts this sign beside the commands those the user has entered so that the user can know 

which data were defined. 

 

 
Figure 9-7 ELPLA-Data after defining the calculation method 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 9-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Influence of a new neighboring building II on an old one I" 

- Type the date of the project in the "Date" edit box 

- Type "New Building II" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 9-8 "Project identification" dialog box 
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2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation" 

wizard appears as shown in Figure 9-9. This wizard will guide you through the steps required to 

generate the FE-Net. The first form of the wizard is the "Slab type" form which contains a group 

of templates of different shapes of nets. These net templates are used to generate standard nets 

that have regular shapes. For the given problem, the foundation has a square shape. 

 

To generate the FE-Net 

 

- In the "Slab type" options, choose the square slab option 

- Type 10.08 in the "Length/ width of square slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 9-9 "Slab type" form 

 

After clicking "Next" in "Slab type" form, the "Generation type" form appears, Figure 9-10. 

ELPLA can deal with various type of generations with rectangular elements. Choose the 

rectangular elements option as generation type. Then click "Next" button to go to the next form. 

 

 
Figure 9-10 "Generation type" form 
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The next form of the "FE-Net generation" wizard is the "Grid definition" dialogue box. In this 

dialogue box, the default values of constant element size appear, Figure 9-11. 

 

In this "Grid definition" dialog box 

 

- Type 14 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 14 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 0.72 in the "Grid interval Dx [m] " edit box for grids in x-direction 

- Type 0.72 in the "Grid interval Dy [m] " edit box for grids in y-direction 

- Click "Finish" button 

 

 
Figure 9-11 "Fe-Net generation" form 

 

Click "Finish" button in the "Generation parameters" form. ELPLA will generate a suitable FE-

Net for the square foundation of 10.08 [m] length with rectangular elements, which have equal 

areas. The following embedded program in Figure 9-12 appears with the generated net. 
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Figure 9-12 FE-Net on the screen 

 

Deleting nodes from the FE-Net 

 

To select the unnecessary nodes, that are required to be removed from the net, first choose 

"Select nodes" command from the "Graphically" menu in Figure 9-12. When "Select nodes" 

command is chosen, the cursor will change from an arrow to a cross hair. The command 

"Remove nodes" in the menu "Graphically" will be enabled, indicating the mode in which is 

being operated. Next, select the required nodes by clicking on each node individually or selecting 

a group of nodes as shown in Figure 9-13. A group of nodes can be selected by holding the left 

mouse button down at the corner of the region. Then, dragging the mouse until a rectangle 

encompasses the required group of nodes. When the left mouse button is released, all nodes in 

the rectangle are selected. 
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Figure 9-13  Generated FE-Net after selecting the unnecessary nodes 

 

To remove the selected nodes, choose "Remove nodes" command from "Graphically" menu. The 

action of this command is indicated in Figure 9-14. To leave the graphic mode, press "Esc" key.  

 

 
Figure 9-14 Final FE-Net after deleting the unnecessary nodes 
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After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 9-14 to save the 

data of the FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 9-14 to close "FE-Net" 

embedded program and to return to the main window of ELPLA-Data 

 

2.4 Soil properties 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data. The following sub program in Figure 9-15 appears with a default-boring log. 

  

 
Figure 9-15 ELPLA-Boring sub program with a default-boring log 
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Modifying data of boring log graphically 

 

In ELPLA, the boring log can be defined or modified graphically, which makes the definition of 

the boring log very easy. By double-clicking the left mouse button on a specified screen position, 

the user can define or modify the soil data and input parameters graphically.  

 

To enter the geotechnical data of the soil layer 

 

- Double-click on the geotechnical data of the soil layer. The corresponding dialog box 

appears allowing you to modify the geotechnical data of the soil layer, Figure 9-16 

- In the dialog group box "Geotechnical data of the layer" in Figure 9-16, define the 

geotechnical data of the soil layer as follows: 

  

Es   = 50000 [kN/m2] 

Ws   = 15000 [kN/m2] 

s  = 18   [kN/m3] 

 

The unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due to the 

removed soil, which is equal to γs * df. In the current example df = 1.5. The angle of internal 

friction φ and the cohesion c of the soil are not required because the selected type of the analysis 

is linear analysis. Therefore, the user can let the default values of the internal friction and the 

cohesion. Next, click "OK" button. 

 

 
Figure 9-16 "Geotechnical data of the soil layer" dialog box 

 

To define the soil type and color for the layer 

 

- Double-click on the soil symbol of the soil layer. The corresponding dialog box 

appears allowing you to modify the soil symbols of that layer, Figure 9-17 

- Select "T, Clay" as the soil type in the "Main soil type 1" combo box in the dialog 

group box "Soil and rock symbols" in Figure 9-17. The color of the clay and a 

short text "T" according to the German specification code DIN 4023 will be 

automatically created 

- Click "OK" button 

 



 

 

ELPLA-Tutorial 

 

 

   9-16 

 
Figure 9-17 "Soil and rock symbols" dialog box 

 

To modify the groundwater depth under the ground surface 

 

- Double-click on the groundwater level. The corresponding edit box appears allowing 

you to modify the groundwater depth under the ground surface, Figure 9-18. To 

neglect the uplift pressure on the foundation, groundwater level is chosen at 

anywhere under the foundation basement 

- Type 7.20 in the "Groundwater depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 9-18 "Groundwater depth under the ground surface" edit box 

 

To modify a layer depth 

 

- Double-click on the layer depth. The corresponding edit box appears allowing you 

to modify the layer depth under the ground surface, Figure 9-19 

- Type 7.20 in the "Layer depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 9-19 "Layer depth under the ground surface" edit box 
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To modify the label of a boring log 

 

- Double-click on the label of the boring log. The corresponding edit box appears 

allowing you to modify the label of the boring log, Figure 9-20 

- Type "BPN1" in the edit box of Figure 9-20 

- Press "Enter" key to consider the text 

 

 
Figure 9-20 "Label of the boring log" edit box 

 

To enter the main soil data for the layer 

 

- Choose "Main soil data" from "Data" menu in Figure 9-15. The following dialog 

group box in Figure 9-21 appears 

- In this dialog group box, enter the settlement reduction factor α and the 

groundwater depth under the ground surface Gw [m] as indicated in Figure 9-21. 

Note that the groundwater depth under the ground surface was typed in the 

corresponding edit box because this value has been already defined graphically 

- Click "OK" button in the "Main soil data" dialog group box in Figure 9-21 
 

 
Figure 9-21 "Main soil data" dialog group box 

 

After the user has completed the definition of all soil properties and parameters, the screen 

should look like the following Figure 9-22. 
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Figure 9-22 Boring log on the screen 

 

After entering all data and parameters of boring log, do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 9-22 to save the 

data of boring log 

- Choose "Close boring logs" command from "File" menu in Figure 9-22 to close 

the ELPLA-Boring sub program and to return to the main window of ELPLA-

Data 

 

2.5 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data. The following embedded program in Figure 9-23 appears with default 

foundation properties. The data of foundation properties for the current example, which are 

required to define, are foundation material, foundation thickness and foundation level. Any other 

data corresponding to foundation properties in the program menus are not required. Therefore, 

the user can take these data from the default foundation properties. 
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Figure 9-23 "Foundation properties" embedded program 

 

To enter the foundation material and thickness 

 

- Choose "Element groups" command from "In Table" menu in the window of      

Figure 9-23. The following list box in Figure 9-24 with default data appears. To 

enter or modify a value in this list box, type that value in the corresponding cell 

then press "Enter" key. In the list box of Figure 9-24, enter E-Modulus of the 

foundation, Poisson’s ratio of the foundation and foundation thickness 

- Click "OK" button 

 

 
Figure 9-24 "Defining element groups" list box 
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To enter the unit weight of the foundation 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" 

menu in the window of Figure 9-23. The following dialog box in Figure 9-25 with 

a default unit weight of 25 [kN/m3] appears. To neglect the self-weight of the 

foundation in the analysis, type 0 in the edit box "Unit weight of the foundation" 

- Click "OK" button 

 

 
Figure 9-25 "Unit weight of the foundation" dialog box 

 

To enter the foundation level 

 

- Choose "Foundation depth" command from "Foundation properties" menu in the 

window of Figure 9-23. The following dialog box in Figure 9-26 appears 

- Type 1.5 in the "Foundation depth under ground surface (a)/ (b)" edit box 

- Click "OK" button 

 

 
Figure 9-26 "Foundation depth" dialog box 
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After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 9-23 

to save the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 9-23 

to close the "Foundation properties" embedded program and to return to the main 

window of ELPLA-Data 

 

2.6 Loads 

 

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data. The 

following embedded program in Figure 9-27 appears. 

 

 
Figure 9-27 "Loads" embedded program 

 

To enter loads 

 

- Choose "Point loads" command from "In Table" menu in the window of Figure 9-27. 

The following list box in Figure 9-28 appears 

- Enter the external point loads P [kN] and their corresponding coordinates (x, y) in 

the list box of Figure 9-28. This is done by typing the value in the corresponding 

cell and then press "Enter" key. The coordinates of the point load are related to 

the lower-left corner of the foundation (local coordinates) 

- Click "OK" button 
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Figure 9-28 "Point loads P" list box 

 

After you have completed the definition of all load data, the screen should look like the 

following Figure 9-29. 

 

 
Figure 9-29 Loads on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 9-29 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 9-29 to close the 

"Loads" embedded program and return to the main window of ELPLA-Data 

 

The project creation of the New Building II is now completed. 
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3 Creating the project of the Old Building I 

 

The data of the two foundations are quite similar except the origin coordinates of the global 

system, which are chosen to be (0.0, 0.0) and (10.28, 0.0) for buildings I and II respectively. 

Project identification is entered so that you can distinguish between the two projects. The data of 

Old Building I are created by first saving the data of the New Building II under a new file name 

and then modifying the project identification and origin coordinates. 

 

To save the data under a new file name 

 

- Choose "Save project as" command from "File" menu of ELPLA-Data. The 

following "Save as" dialog box appears, Figure 9-30 

 

In this dialog box 

 

- Type a file name for the project of the Old Building I in the file name edit box. 

For example type "Old Building I" 

- Click "Save" button 

 

 
Figure 9-30 "Save as" dialog box 

 

3.1 Modifying the calculation methods options  

 

To add the option of neighboring foundations do the following steps: 

 

- Choose "Calculation methods" command from "Data" menu 

- The first form of the wizard "Calculation method" is the "Analysis type" form,   

Figure 9-2 

- In this form, click "Next" button to go to the next page 

- After clicking "Next" button, the "Calculation methods" form appears, Figure 9-3. 

Click "Next" button to go to the next form 

- The next form is the "System symmetry", Figure 9-4. In this form click "Next" button 

- The last form of the wizard assistant contains the "Option" list, Figure 9-31. In 

this list, check the option "Influence of neighboring foundations on the slab", then 

click the "Save" button 
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Figure 9-31 "Options" list 

 

3.2 Modifying the project identification  

 

To modify the project identification of building II, choose "Project identification" command 

from "Data" menu of ELPLA-Data. The dialog box in Figure 9-32 appears. In this dialog, type 

"Old building I" in the "Project" edit box then click "Save" button. 

 

 
Figure 9-32 "Project identification" dialog box 

 

3.3 Modifying origin coordinates 

 

To modify the origin coordinate of building II, choose "Foundation properties" command from 

"Data" menu of ELPLA-Data. The following embedded program in Figure 9-33 appears.  
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Figure 9-33 "Foundation properties" embedded program 

 

To enter the origin coordinates 

 

- Choose "Origin coordinates" command from "Foundation properties" menu in the 

window of Figure 9-23. The following dialog box in Figure 9-34 appears 

- In this dialog box type 10.28 in the "x-coordinate" edit box 

- Click "OK" button 

 

 
Figure 9-34 "Origin coordinate" dialog box 
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After modifying the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu to save the 

foundation properties 

- Choose "Close foundation properties" command from "File" menu to close the 

"Foundation properties" embedded program and return to ELPLA-Data 

 

3.4 Neighboring foundations 

 

To enter the neighboring foundations, do the following steps: 

 

- Choose "Neighboring foundations" command from "Data" menu from ELPLA-

Data (Figure 9-35) 

- Click "Add neighboring foundations" button in "Data" menu and open the project 

"New Building II" 

- Click "Save" button 

 

Creating the projects of the two foundations 1 and 2 is now complete. 

 

 
Figure 9-35 "Neighboring foundations" menu 

 

 

4 Carrying out the calculations 

 

The calculations of the New Building II should be first done to get the contact pressure under its 

foundation, then the calculation of the Old Building I with the influence of building II is carried 

out. 

 

4.1 Starting ELPLA-Solver 

 

To analyze the problem open the file "New Building II" from "File" menu from ELPLA-Data, 

then leave ELPLA-Data to ELPLA-Solver. This is done by clicking on "Solver" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver window 

appears, Figure 9-36. 
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Figure 9-36 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis.  

 

For the project of the New building II, the items, which are required to be calculated, are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations 

- Determining deformation, internal forces, contact pressures 

 

While for the project of the Old building I, the items, which are required to be calculated, are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix 

- Influence of neighboring foundations on settlements 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time.  
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4.2 Carrying out all computations 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Calculation" menu in ELPLA-

Solver Window 

 

Analysis progress 

 

Analysis progress menu in Figure 9-37 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 9-37 Analysis progress menu 

 

Check of the solution 

 

Once the analysis is complete, a check menu of the solution appears, Figure 9-38. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 9-38 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 

 

 

 

 

 

 

 



 

 

ELPLA-Tutorial 

 

 

   9-29 

5 Viewing data and results 

 

ELPLA can view the data and results for each foundation separately or for the two foundations 

together. Individual data or results can be viewed in a manner similar to that in the previous 

examples. Here, you will learn to view the results of the foundations together through the 

following two samples. 

 

5.1 Viewing result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Solver window. 

 

ELPLA-Graphic window appears, Figure 9-39. ELPLA-Graphic automatically opens the data file 

of the current example and displays the data file name in the title bar of ELPLA-Graphic 

window. 

 

 
Figure 9-39 Opening screen of the sub program ELPLA-Graphic 
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To view the results for the new foundation only as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The following option box in Figure 9-40 appears 

- In "Results as contour lines" option box, select "Settlements s" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The settlements are now displayed as contour lines for old foundation only as shown in 

Figure 9-41. 

 

 
Figure 9-40 "Results as contour lines" option box 

 

 
Figure 9-41 Settlements as contour lines for the old foundation only 
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To view the settlement results for the two foundations together as contour lines 

 

- Choose "Old Building I" file from "File" menu from ELPLA- Graphic 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The option box in Figure 9-40 appears 

- In "Results as contour lines" option box, select "Settlements s" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The settlements are now displayed as contour lines for the old foundation as shown in Figure 9-

42. 

 

 
Figure 9-42 Settlements as contour lines for the old foundation  

 

5.2 Plot a diagram of results 

 

To plot a diagram of results, leave ELPLA-Graphic to ELPLA-Section. This is done by clicking 

on "Section" in the menu bar of the sub programs at the upper-right corner of ELPLA-Graphic 

window. 
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Figure 9-43 Opening screen of the sub program ELPLA-Section 

 

To consider the results for the two foundations together 

 

- Choose "Combination from many projects" command from "File" menu of 

ELPLA-Section. The following list box in Figure 9-44 appears. ELPLA-Section 

automatically considers the project "Old Building I" in the list of projects to be 

combined 

- Click "Add project" button in "Combination from many projects" list box. Then 

open the project "New Building II" 

- Click "OK" button in the "Combination from many projects" list box 

 

 
Figure 9-44 "Combination from many projects" list box 
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To plot a section in x-direction 

 

- Choose "Section in x-direction" command from "Sections" menu. The following 

option box in Figure 9-45 appears 

- In "Section in x-direction" option box, select "Settlements s" as a sample for the 

results to be plotted in a diagram 

- Click "OK" button 

 

 
Figure 9-45 "Section in x-direction" option box 

 

The following option box in Figure 9-46 appears to specify the section in x-direction that is 

required to be plotted. 

 

In this dialog box 

 

- Type 5.04 in the "Section at y-coordinate" edit box to plot a diagram at the middle 

of the two foundations 

- Click "OK" button 

 

The settlements are now plotted in a diagram at the middle of the two foundations together as 

shown in Figure 9-47. 
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Figure 9-47 "Section in x-direction" dialog box 

 

 
Figure 9-48 Diagram of settlements in x-direction at the middle of the two foundations 
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1 Description of the problem 

 

An example of a raft with straight and curved borders is selected to illustrate some of the 

essential features of ELPLA. 

 

1.1 Loads and dimensions 

 

The raft is subjected to 12 concentrated loads, each is 500 [kN] as shown in Figure 10-1 and 

Table 10-1. 

 

Table 10-1 Point loads P 
-------------------------------------------------- 

  Load No.    Load value    X-coord.      Y-coord. 

  I           P             x             y 

  [-]         [kN]         [m]           [m] 

-------------------------------------------------- 

  1           500           5.42           9.5 

  2           500           3.25          4.96 

  3           500              7           0.5 

  4           500           8.02           9.5 

  5           500          11.12           9.5 

  6           500          11.14           0.5 

  7           500             15             2 

  8           500             15             8 

  9           500           0.75           0.5 

  10          500          16.25          4.98 

  11          500           3.84           0.5 

  12          500              8             5 

-------------------------------------------------- 
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Figure 10-1 Plan and section elevation with raft geometry [m] and acting loads [kN] 

 

1.2 Foundation material and thickness 

 

Raft material and thickness are supposed to have the following parameters: 

 

Raft thickness d  = 1.00   [m] 

Young's modulus Eb  = 2 * 107 [kN/m2] 

Unit weight b  = 25              [kN/m3] 

Poisson's ratio b  = 0.25   [-] 
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1.3 Soil properties 

 

The subsoil under the raft consists of a layer of silt, 12 [m] thick, the water table level is 2 [m] 

below the ground surface. Foundation level is also 2 [m] below the ground surface as shown in 

Figure 10-1. The soil is supposed to have the following parameters: 

 

Modulus of elasticity for loading Es  = 10000  [kN/m2] 

Modulus of elasticity for reloading Ws  = 10000 [kN/m2] 

Unit weight s  = 18   [kN/m3] 

Poisson's ratio s  = 0.3   [-] 

 

1.4 Mathematical model 

 

In this example, the Modulus of compressibility method (method 6) is chosen to analyze the raft. 

This Tutorial manual will not present the theoretical background of modeling the problem. For 

more information concerning the method of analysis, a complete reference for the soil models 

and numerical calculation methods are well documented in the User’s Guide of ELPLA.  

 

 

2 Creating the project 

 

In this section, the user will learn how to create a project for analyzing a raft foundation. The 

example will be processed step by step to show the possibilities and abilities of the program. To 

enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 10-2. This wizard will 

guide you through the steps required to create the project. As shown in Figure 10-2, the first 

form of the wizard is the "Analysis type" form. In this form, define the analysis type of the 

problem where ELPLA can deal with different structural systems. As the analysis type is a 

foundation problem, select "Analysis of slab foundation" then click "Next" button to go to the 

next form. 
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Figure 10-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button, the "Calculation methods" form appears, Figure 10-3.  

 

To define the calculation method 

 

- Select the calculation method "6-Modulus of Compressibility (Iteration)" 

- Click "Next" button to go to the next form 

 

 
Figure 10-3 "Calculation methods" form 

 

The next form is the "System symmetry" (Figure 10-4). In this form choose "Unsymmetrical 

system" then click "Next" button. 
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Figure 10-4 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 10-5. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. There isn’t any requested choices, so click the "Save" button.  

 

 
Figure 10-5 "Options" list 
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After clicking "Save" button, the "Save as" dialog box appears, Figure 10-6.  

 

In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example 

type "Curved Raft". ELPLA will use automatically this file name in all reading 

and writing processes 

- Click "Save" button 

 

 
Figure 10-6 "Save as" dialog box 

 

ELPLA will activate the "Data" menu. In addition, the file name of the current project                  

[Curved Raft] will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, 

Figure 10-7. In the "Data" menu, the user can enter the remaining data of the project using the 

same sequence of commands in this menu. The first command in the menu is "Calculation 

methods", which has been already entered. Therefore, ELPLA has put the sign "√" beside this 

command, Figure 10-7. ELPLA puts this sign beside the commands those the user has entered so 

that the user can know which data were defined. 
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Figure 10-7 ELPLA-Data after defining the calculation method 

 

2.2 Project identification  

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 10-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box: "Analysis of a 

raft with straight and curved borders" 

- Type the date of the project in the "Date" edit box 

- Type "Tutorial Manual" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 10-8 "Project identification" dialog box 
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2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation" 

wizard appears as shown in Figure 10-9. This wizard will guide you through the steps required to 

generate the FE-Net. As shown in Figure 10-9 the first form of the wizard is the "Slab type" form 

which contains a group of templates of different shapes of nets. These net templates are used to 

generate standard nets that have regular shapes. For the given problem, the foundation has an 

irregular shape. 

 

To generate the FE-Net 

 

- In the "Slab type" options, choose the irregular slab option 

- Click "Next" button to go to the next form 

 

 
Figure 10-9 "Slab type" form 

 

After clicking "Next" in "Slab type" form, the following "Generation type" form appears, Figure 

10-10. ELPLA can deal with various type of generations with rectangular/ triangular elements. 

Choose the triangular element which is the last option as the generation type. Then click "Next" 

button to go to the next form. 
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Figure 10-10 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "FE-Net Generation" 

dialog box in Figure 10-11 appears with the default generation parameters. In this dialog box, 

click "Finish" button. 

 

 
Figure 10-11 "Fe-Net generation" dialog box 

 

ELPLA will generate an imaginary net as shown in the following embedded program, Figure 10-

12. 
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Figure 10-12 Imaginary net of a rectangular area on the screen 

 

You can either draw the raft directly on this imaginary net or input the raft corner points in 

tabulated form. To input the FE-Net corner points, choose "Slab corners" command from "In 

Table" menu. The dialog box in Figure 10-13 appears.  

 

 
Figure 10-13 "Slab corners" dialog box 
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To define the first segment of the raft that connects the first two points on the raft of Figure 10-1 

 

- Do not change the default coordinates of the first point, which the program 

considers as (0.00, 0.00) 

- Type 12 in the "x2" edit box to define the x-coordinate of the second point 

- Type zero in the "y2" edit box to define the y-coordinate of the second point 

 

To define the second segment of the raft 

 

- Use the Scroll bar to define segment No. 2 

- Type 12 in the "x2 edit box to define the x-coordinate of the third point 

- Type 10 in the "y2" edit box to define the y-coordinate of the third point 

- Select the "Use arc data" option to convert the line segment to arc segment 

- Select the "Reverse rotation direction" option to reverse the direction of rotation 

- Select the "Reverse radius position" option to reverse the radius position 

- Type 5 in the "Arc radius" edit box to define the radius of the arc segment 

 

In the "Slab corners" dialog box, ELPLA assumed that there are at least three segments with 

three corner points. Since the raft drawing contains four segments, you can use the command 

"Segment insert" to insert the last segment of the raft. Use the corner points and arc information 

provided in Table 10-2 to complete the definition of the raft corner points. Repeat the steps used 

for defining the first two segments to define any segment. 

 

Table 10-2 Raft corner points 

Segment 

No. 

[-] 

Start position End position Arc Radius 

 

[m] 

x1 

[m] 

y1 

[m] 

x2 

[m] 

y2 

[m] 

1 0 0 12 0  

2 12 0 12 10 5 

3 12 10 5 10  

4 5 10 0 0  

 

After completing the definition of the raft corner points, the slab corner dialog box should be like 

this in Figure 10-14 where a small sketch of the raft appears in the dialog box picture. Click the 

"OK" button to see the drawing of the raft outlines as shown in Figure 10-15. 
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Figure 10-14 "Slab corners" dialog box after defining the raft corner points 

 

 
Figure 10-15 Raft outlines 

 

Raft openings 

 

To draw the openings in the raft, choose the command "Opening corners" from "In Table" menu, 

the dialog box in Figure 10-16 appears. 
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Figure 10-16 "Opening corners" dialog box 

 

In this dialog box, press on "Insert opening" button, then write the coordinates of the opening 

exactly as in slab corners. 

 

To define the first segment of the raft opening 

 

- Type 10 in the "x1" edit box to define the x-coordinate of the first point 

- Type 2 in the "y1" edit box to define the y-coordinate of the first point 

- Type 12 in the "x2" edit box to define the x-coordinate of the second point 

- Type 2 in the "y2" edit box to define the y-coordinate of the second point 

 

To define the second segment of the raft opening 

 

- Use the Scroll bar to define segment No. 2 

- Type 12 in the "x2" edit box to define the x-coordinate of the third point 

- Type 8 in the "y2" edit box to define the y-coordinate of the third point 

- Select the "Use arc data" option to convert the line segment to arc segment 

- Select the "Reverse rotation direction" option to reverse the direction of rotation 

- Select the "Reverse radius position" option to reverse the radius position 

- Type 4 in the "Arc radius" edit box to define the radius of the arc segment 

 

In the "Opening corners" dialog box, ELPLA assumed that there are at least three segments with 

three corner points. Since the raft opening drawing contains four segments, you can use the 

command "Segment insert" to insert the last segment of the raft opening. Use the corner points 

and arc information provided in Table 10-3 to complete the definition of the raft opening corner 

points. Repeat the steps used for defining the first two segments to define any segment. 
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Table 10-3 Raft opening corner points 

Segment 

No. 

[-] 

Start position End position Arc Radius 

 

[m] 

x1 

[m] 

y1 

[m] 

x2 

[m] 

y2 

[m] 

1 10 2 12 2  

2 12 2 12 8 4 

3 12 8 10 8  

4 10 8 10 2  

 

After completing the definition of the raft opening corner points, the opening corners dialog box 

should be like this in Figure 10-17 where a small sketch of the raft opening appears in the dialog 

box picture. Click the "OK" button to see the drawing of the opening outlines as shown in Figure 

10-18. 

 

 
Figure 10-17 "Opening corners" dialog box after defining the opening corner points 
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Figure 10-18 Raft opening outlines 

 

To complete the FE-Net generation of the problem, choose "Generating FE-Net" command from 

"FE-Generation" menu. The following "Generation of FE-Net" dialog box appears. 

 

 
Figure 10-19 "Generation of FE-Net" dialog box 
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To enter the generation data 

 

- Type 0.5 in the "Element circumradius" edit box to define the radius of circles 

containing elements 

- Type 0.25 in the "Min. element circumradius" edit box to define the minimum 

radius of circles containing elements 

- Check the "Smoothing mesh" option to optimize the dimension of FE-Net by making all 

elements having nearly the same area as possible as 

- Click "OK" button 

 

After clicking the "OK" button, FE-Net generation progress menu in Figure 10-20 appears in 

which various phases of the generation are progressively reported. After finishing the generation 

of the FE-Net and creating the raft FE-Net as shown in Figure 10-21, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 10-21 to save the data of 

the FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 10-21 to close the "FE-

Net" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

 
Figure 10-20 "FE-Net generation" progress menu 
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Figure 10-21 Final FE-Net of the raft 

 

2.4 Soil properties 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data. The following sub program in Figure 10-22 appears with a default-boring log. 
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Figure 10-22 ELPLA-Boring sub program with a default-boring log 

 

To enter the soil properties for the boring log of the current example 

 

- Choose "Soil data" command from "Data" menu in the window of Figure 10-22.  

The following dialog box in Figure 10-23 with default-boring log data appears 

 

 
Figure 10-23 "Soil data" dialog box with default-boring log data 
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In the "Geotechnical data of the layer" dialog group box in Figure 10-23, define the geotechnical 

data of the first soil layer of the boring log as follows: 

  

Es   = 10000  [kN/m2] 

Ws   = 10000 [kN/m2] 

γs = 18   [kN/m3] 

νs = 0.3   [-] 

 

In the current example, the angle of internal friction φ and the cohesion c of the soil are not 

required because the selected type of the analysis is linear analysis. Therefore, the user can let the 

default values of the internal friction and the cohesion.  

 

φs = 30   [˚] 

c = 0   [kN/m2] 

 

Due to the presence of the ground water, the soil above the ground water level has a deferential 

unit weight from the soil under that level. Therefore, the layer depth of the first layer is taken to 

be 2 [m], which is equal to the ground water level. Now, type this value in "Layer depth under 

the ground surface" edit box. 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 

4023, the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "U, Silt" as the soil type in "Main soil 

type 1" combo box in "Soil and rock symbols" dialog group box, Figure 10-23.  The color of the 

silt according to the German Standard DIN 4023 will be automatically created. The user can 

change this color. Also, a short text "U" will be automatically created for the silt. 

 

To enter the second layer 

 

- Click "Layer copy" button in 0. A layer that has the same properties of the first 

layer will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be typed 

automatically at the upper-left corner of the main dialog box of soil layers as a 

head title 

- Change the value of the unit weight of the soil for the second soil layer from 18 [kN/m3] 

to 9 [kN/m3] 

- Change the value of the layer depth under the ground surface from 2 [m] to [12 m] 

 

Note that the unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due 

to the removed soil, which is equal to γs * df. This means that the unit weight of the soil under the 

foundation depth df  is not required. However, the unit weight of the soil under the foundation depth 

for all soil layers is entered by the value 9 [kN/m3]. 

 

After editing the geotechnical data, the boring coordinates and labels which describe the boring 

will be entered. 
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To enter the boring coordinates and label 

 

- Type 0 for x-coordinate in "x-coordinate of boring log [m]" edit box 

- Type 0 for y-coordinate in "y-coordinate of boring log [m]" edit box 

- Type B1 as a label name for the first boring in "Label of boring log" edit box 

 

To enter the main soil data for all layers, choose "Main soil data" command from "Data" menu in 

Figure 10-22. The following dialog box in Figure 10-24 appears with default main soil data. The 

main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other 

data corresponding to main soil data are not required in this example. Therefore, the user can 

take these data from the default soil properties. 

 

In the dialog box of Figure 10-24, enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 

 

 
Figure 10-24 "Main soil data" dialog box 

 

Now all data and parameters for the boring log have been entered. After finishing the creation of 

the boring log, click "OK" button in "Soil data" dialog box in Figure 10-23 to see the defined 

boring log on the screen where the user can control or modify the input data and parameters, 

Figure 10-25.  
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Figure 10-25 Boring log on the screen 

 

After entering all data and parameters of boring logs, do the following two steps: 

 

- Choose "Save boring log" command from "File" menu in Figure 10-25 to save the 

data of the boring log 

- Choose "Close boring logs" command from "File" menu in Figure 10-25 to close 

the ELPLA-Boring sub program and to return to the main window of ELPLA-

Data 

 

Note that the sign "√" is typed automatically beside the "Soil Properties" command in the "Data" 

menu of ELPLA-Data. 

 

2.5 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data. The following embedded program in Figure 10-26 appears with default 

foundation properties. The data of foundation properties for the current example, which are 

required to define, are foundation material and foundation thickness. Any other data 

corresponding to foundation properties in the program menus are not required. Therefore, the 

user can take these data from the default foundation properties. 
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Figure 10-26 "Foundation properties" embedded program 

 

To enter the foundation material and thickness 

 

- Choose "Element groups" command from "In Table" menu in the window of 

Figure 10-26. The following list box in Figure 10-27 with default data appears. 

To enter or modify a value in this list box, type that value in the corresponding 

cell then press "Enter" key. In the list box of Figure 10-27, enter E-Modulus of the 

foundation, Poisson’s ratio of the foundation and foundation thickness 

- Click "OK" button 

 

 
Figure 10-27 "Defining element groups" list box 
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To enter the unit weight of the foundation 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" 

menu in the window of Figure 10-26. The following dialog box in Figure 10-28 

with a default unit weight of 25 [kN/m3] appears. Let the default value as written 

in the edit box "Unit weight of the foundation" 

- Click "OK" button 

 

 
Figure 10-28 "Unit weight of the foundation" dialog box 

 

To enter the foundation level 

 

- Choose "Foundation depth" command from "Foundation properties" menu in the 

window of Figure 10-26. The following dialog box in Figure 10-29 appears 

- In this dialog box type 2 in the "Foundation depth under ground surface (a)/ (b)" 

edit box 

- Click "OK" button 

 

 
Figure 10-29 "Foundation depth" dialog box 
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After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 10-26 

to save the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 10-26 

to close the "Foundation properties" embedded program and to return to the main 

window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Foundation Properties" command in the 

"Data" menu of ELPLA-Data. 

 

2.6 Loads 

 

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data. The 

following embedded program in Figure 10-30 appears. 

 

 
Figure 10-30 "Loads" embedded program 

 

To enter loads 

 

- Choose "Point loads" command from "In Table" menu in the window of Figure 

10-30. The following list box in Figure 10-31 appears 

- Enter the external point loads P [kN] and their corresponding coordinates (x, y) in 

the list box of Figure 10-31. This is done by typing the value in the corresponding 

cell and then press "Enter" key. The coordinates of the point load are related to 

the lower-left corner of the foundation (local coordinates) 

- Click "OK" button 
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Figure 10-31 "Point loads P" list box 

 

After you have completed the definition of all load data, the screen should look like the 

following Figure 10-32. 

 

 
Figure 10-32 Loads on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 10-32 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 10-32 to close the 

"Loads" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Loads" command in the "Data" menu of 

ELPLA-Data. 
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Creating the project of the raft is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem leave ELPLA-Data to ELPLA-Solver. This is done by clicking on 

"Solver" in the menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, 

ELPLA-Solver window appears, Figure 10-33.  

 

 
Figure 10-33 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis. 

For this project, the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix     

- Iteration process 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time. 
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3.2 Carrying out all computations 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Calculation" menu in ELPLA-

Solver Window, the "Iteration parameters" option box will appear (Figure 10-34) 

- Choose the suitable iteration option 

- Press the "OK" button 

 

 
Figure 10-34 "Iteration parameters" option box 

 

Analysis progress 

 

Analysis progress menu in Figure 10-35 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 10-35 Analysis progress menu 

 

Iteration process 

 

Information about the convergence progress of the computations is displayed in the "Iteration 

process" list box in Figure 10-36 during the iteration process. 
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Figure 10-36 "Iteration process" list box 

 

Check of the solution 

 

Once the analysis is complete, a check menu of the solution appears, Figure 10-37. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 10-37 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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4 Viewing data and results 

 

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the 

three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed 

again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data 

is used only to define and view the data of the problem. ELPLA-Graphic is used to print data 

graphically while ELPLA-List is used to print data numerically. 

 

4.1 Viewing result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic 

window appears, Figure 10-38. ELPLA-Graphic automatically opens the data file of the current 

example and displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 10-38 Opening screen of the sub program ELPLA-Graphic 

 

To view the results for the raft as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-

Graphic. The following option box in Figure 10-39 appears 

- In "Results as contour lines" option box, select "Settlements s" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The settlements are now displayed as contour lines for the raft as shown in Figure 10-40. 
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Figure 10-39 "Results as contour lines" option box 

 

 
Figure 10-40 Settlements as contour lines for the raft 

 

4.2 Plot a diagram of the results 

 

To plot a diagram of the results, leave ELPLA-Graphic to ELPLA-Section. This is done by 

clicking on "Section" in the menu bar of the sub programs at the upper-right corner of ELPLA-

Graphic window. ELPLA-Section automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Section window. 
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Figure 10-41 Opening screen of the sub program ELPLA-Section 

 

Only the first command of the "Sections" menu is explained here. In the same way, the user can 

carry out the remaining commands of the previous list. The commands of "Options", "Format" 

and "Window" menus, which are used to define the preferences of the drawing such as plot 

parameters, scale, font, etc., are discussed in detail in the User’s Guide of ELPLA.  

 

To plot a section in x-direction 

 

- Choose "Section in x-direction" command from "Sections" menu. The following 

option box in Figure 10-42 appears 

- In the "Section in x-direction" option box, select "Settlements s" as an example for the 

results to be plotted in a diagram 

- Click "OK" button 

 

 
Figure 10-42 "Section in x-direction" option box 
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The following option box in Figure 10-43 appears to specify the section in x-direction that is 

required to be plotted. 

 

In this dialog box 

 

- Type 5.00 in the "Section at y-coordinate" edit box to plot a diagram at the middle 

of the raft 

- Click "OK" button 

 

The settlements are now plotted in a diagram at the middle of the raft as shown in Figure 10-44. 

 

 
Figure 10-43 "Section in x-direction" dialog box 



 

 

ELPLA-Tutorial 

 

 

   10-35 

 
Figure 10-44 Diagram of settlements in x-direction at the middle of the raft 

 

4.3 Listing data and result in tables 

 

To list tables of data and results, switch to ELPLA-List. This is done by clicking on "List" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Section window. ELPLA-List 

window appears, Figure 10-45.  
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Figure 10-45 Opening screen of the sub program ELPLA-List 

 

The function of ELPLA-List is listing and printing data and results in tables. The data and results 

can be exported to other Windows applications to prepare reports or add further information. 

ELPLA-List automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-List window. 

 

Only one command of the "List" menu is explained here. In the same way, the user can carry out 

the remaining commands of the previous list. The commands of "Format" and "Window" menus, 

which are used to define the preferences of the tables such as page format, font, etc., are 

discussed in detail in the User’s Guide of ELPLA. 

 

To list results in a table 

 

- Choose "Display tables of results" command from "List" menu. The following option box 

in Figure 10-46 appears 

- Select "Settlements" as an example for the results to be listed in a table 

- Click "OK" button. The settlement results are now listed on the screen (Figure 10-47) 

- Choose "Send to Excel" from "File" menu if you wish to export the table to the MS Excel 

application, Figure 10-48 
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Figure 10-46 "Display tables of results" option box 

 

 
Figure 10-47 List of settlement results 
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Figure 10-48 Exported results in MS Excel 
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1 Description of the problem 

 

An example of pile groups is selected to illustrate some of the essential features of ELPLA for 

analyzing pile groups. 

 

1.1 Load and dimensions 

 

A pile cap on 24 vertical piles is considered as shown in Figure 11-1. All piles are equal in 

diameter and length where pile diameter is 0.5 [m] while pile length is 10 [m]. Spacing between 

piles is 1.6 [m]. It is required to analyze the pile cap as rigid free-standing raft due to a vertical 

load of P = 8000 [kN] acting on the pile cap with eccentricities ex = 1.4 [m] and ey = 1.8 [m] in 

both x- and y-directions. 

 
 

 

3.8  

P = 8000 [kN]

1.6*4 = 6.4 [m]

o

y

x

1.21.4

 
 

Figure 11-1 Plan with raft geometry [m], resultant force on the raft [kN] and pile locations 

 

1.2 Soil properties 

 

The subsoil under the raft consists of a layer of silt, 30 [m] thick. The raft lies directly on the 

ground surface. There is no effect of water table on the raft. The soil is supposed to have the 

following parameters: 

 

Modulus of elasticity for loading Es  = 10000  [kN/m2] 

Modulus of elasticity for reloading Ws  = 10000 [kN/m2] 

Poisson's ratio s  = 0.3   [-] 
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1.3 Mathematical model 

 

In this example, rigid free-standing raft (method 9) is chosen to analyze the raft. This Tutorial 

manual will not present the theoretical background of modeling the problem. For more 

information concerning the method of analysis, a complete reference for the soil models and 

numerical calculation methods are well documented in the User’s Guide of ELPLA. 

 

 

2 Creating the project 

 

In this section, the user will learn how to create a project for analyzing pile groups. The example 

will be processed step by step to show the possibilities and abilities of the program. To enter the 

data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 11-2. This wizard will 

guide you through the steps required to create the project. As shown in Figure 11-2, the first 

form the wizard is the "Analysis type" form. In this form, define the analysis type of the problem 

where ELPLA can deal with different structural systems. As the analysis type is pile groups, 

select "Analysis of piled raft" then click "Next" button to go to the next page. 

 

 
Figure 11-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button, the "Calculation methods" form appears, Figure 11-3. 
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To define the calculation method 

 

- Select the calculation method "9-Rigid free-standing raft" 

- Select the subsoil model "Layered soil model" 

- Click "Next" button to go to the next form 

 

 
Figure 11-3 "Calculation methods" form 

 

The next form is the "System symmetry" (Figure 11-4). 

 

 
Figure 11-4 "System symmetry" form 
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In this form choose "Unsymmetrical system" then click "Next" button. 

 

The last form of the wizard assistant contains the "Option" list, Figure 11-5. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. There isn’t any requested choices, so click the "Save" button.  

 

 
Figure 11-5 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 11-6. 

 

 
Figure 11-6 "Save as" dialog box 
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In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example 

type "Pile groups". ELPLA will use automatically this file name in all reading and 

writing processes 

- Click "Save" button 

 

ELPLA will activate the "Data" menu. In addition, the file name of the current project                  

[Pile groups] will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 

11-7. In the "Data" menu, the user can enter the remaining data of the project using the same 

sequence of commands in this menu. The first command in the menu is "Calculation methods", 

which has been already entered. Therefore, ELPLA has put the sign "√" beside this command, 

Figure 11-7. ELPLA puts this sign beside the commands those the user has entered so that the 

user can know which data were defined. 

 

 
Figure 11-7 ELPLA-Data after defining the calculation method 
 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 11-8 appears. 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box: 

"Analysis of pile groups" 

- Type the date of the project in the "Date" edit box 

- Type "Tutorial Manual" in the "Project" edit box 

- Click "Save" button 
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Figure 11-8 "Project identification" dialog box 

 

2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation" 

wizard appears as shown in Figure 11-9. This wizard will guide you through the steps required to 

generate the FE-Net. As shown in Figure 11-9 the first form of the wizard is the "Slab type" form 

which contains a group of templates of different shapes of nets. These net templates are used to 

generate standard nets that have regular shapes. For the given problem, the foundation has an 

irregular shape. 

 

In pile group problems, it is not required to generate a FE-Net for the entire dimension of the 

raft. Only a net containing pile location is enough. ELPLA has different procedures for defining 

the FE-Net. The easy procedure to define the FE-Net of these pile groups is generating a mesh 

for the entire area firstly, then removing the unnecessary nodes to get the foundation shape. 

 

 
Figure 11-9 "FE-Net generation" wizard with "Slab type" form 

 

To generate the FE-Net 

 

- In the "Slab type" options, choose the rectangular slab option 

- In the "Rectangular slab" frame, enter the total length and width of the raft in the 

corresponding edit boxes 

- Click "Next" button to go to the next form 
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After clicking "Next" in "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 11-10. ELPLA can deal with various type of generations with triangle and/ or 

rectangular elements. Choose the first type of rectangular elements. Then click "Next" button to 

go to the next form. 

 

 
Figure 11-10 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 11-11 appears with default values of constant element size. 

 

In this dialog box 

 

- In "Grid in x-direction" frame, type 4 in the "No. of  grid spaces" edit box 

- In "Grid in y-direction" frame, type 5 in the "No. of  grid spaces" edit box 

- Type 1.6 in the "Grid interval" edit box 

- Click "OK" button 

 

 
Figure 11-11 "Grid definition" form 

 

ELPLA will generate a FE-Net for a rectangular area of 6.4 [m] length and 8 [m] width with 

square elements of 1.6 [m] each side. The following embedded program in Figure 11-12 appears 

with the generated net. 
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Figure 11-12 FE-Net of a rectangular slab on the screen 

 

Deleting nodes from the FE-Net 

 

To select the unnecessary nodes that are required to be removed from the net, first choose "Select 

nodes" command from "Graphically" menu. When "Select nodes" command is chosen, the cursor 

will change from an arrow to a cross hair. The command "Remove nodes" in the menu 

"Graphically" will be enabled, indicating the mode in which is being operated. Next, select the 

required nodes by clicking on each node individually or selecting a group of nodes as shown in 

Figure 11-13. To remove the selected nodes, choose "Remove nodes" command from the 

"Graphically" menu. The action of this command is indicated in Figure 11-14. 
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Figure 11-13 Generated FE-Net after selecting the unnecessary nodes 

 

 
Figure 11-14 Final FE-Net after deleting the unnecessary nodes 
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After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 11-14 to save the data of  

the FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 11-14 to close the "FE-

Net" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

2.4 Element length of pile 

 

To define the element length of pile, choose "Preferences" command from "Main data" menu of 

ELPLA-Data. The "Preferences" dialog box in Figure 11-15 appears.  

 

In this dialog box 

 

- Type 0.5 in the "Element length of pile" edit box 

- Click "Save" button 

 

 
Figure 11-15 "Preferences" dialog box 

 

2.5 Piles 

 

To define piles, choose "Piles" command from "Data" menu of ELPLA-Data. The following 

embedded program in Figure 11-16 appears. 
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Figure 11-16 "Piles" embedded program 

 

Pile groups  

 

To define pile groups those have the same diameter and length, choose "Pile groups" command 

from "In Table" menu in Figure 11-16. When the "Pile groups" command is chosen, the 

following table in Figure 11-17 appears allowing you to define the pile diameter and length.  

 

 
Figure 11-17 Defining pile groups 
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Pile material 

 

To define pile material, choose "Pile material" command from "In Table" menu in Figure 11-16. 

When the "Pile material" command is chosen, the following dialog box in Figure 11-18 appears 

allowing you to define the pile material. Type 0 in the "Unit weight of the pile concrete" edit box 

to neglect the pile weight. 

 

 
Figure 11-18 "Defining element groups" dialog box 

 

Pile location 

 

To define pile locations on the net 

 

- Choose "Select nodes" command from "Graphically" menu in Figure 11-16  

- Select nodes that have piles as shown in Figure 11-19 

- Choose "Add piles" command from "Graphically" menu in Figure 11-19. The 

"Defining pile groups" dialog box in Figure 11-20 appears. In this dialog box 

click "OK" button 

 

 
Figure 11-19 Selection of nodes that have piles 
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Figure 11-20 "Defining pile groups" dialog box 

 

After you have completed the definition of the piles, the screen should look like the following 

Figure 11-21. 

 

 
Figure 11-21 Piles on the screen 

 

After entering all data of piles, do the following two steps: 

 

- Choose "Save piles" command from "File" menu in Figure 11-21 to save the data 

of piles 

- Choose "Close piles" command from "File" menu in Figure 11-21 to close the 

ELPLA-Piles sub program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Piles" command in the "Data" menu of 

ELPLA-Data. 
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2.6 Soil properties 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data. The following sub program in Figure 11-22 appears with a default-boring log. 

 

 
Figure 11-22 ELPLA-Boring sub program with a default-boring log 

 

Modifying data of boring log graphically 

 

In ELPLA, the boring log can be defined or modified graphically, which makes the definition of 

the boring log very easy. By double-clicking the left mouse button on a specified screen position, 

the user can define or modify the soil data and input parameters graphically.  

 

To enter the geotechnical data of the soil layer 

 

- Double-click on the geotechnical data of the soil layer. The corresponding dialog box 

appears allowing you to modify the geotechnical data of the soil layer, Figure 11-23 

- In the dialog group box "Geotechnical data of the layer" in Figure 11-23, define 

the geotechnical data of the soil layer as follows: 

  

Es   = 10 000 [kN/m2] 

Ws   = 10 000 [kN/m2] 

s   = 0.3  [-] 
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The values Es and Ws are the same because the effect of reloading on the soil is not required. 

The unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due to the 

removed soil, which is equal to γs * df. In the current example df = 0.0, which means the unit 

weight of the soil is not required. However, the unit weight of the soil is entered by the default 

value. Also, the angle of internal friction φ and the cohesion c of the soil are not required because 

the selected type of the analysis is linear analysis. Therefore, the user can let the default values of 

the internal friction and the cohesion. Next, click "OK" button. 

 

 
Figure 11-23 "Geotechnical data of the soil layer" dialog box 

 

To define the soil type and color for the layer 

 

- Double-click on the soil symbol of the soil layer. The corresponding dialog box 

appears allowing you to modify the soil symbols of that layer, Figure 11-24 

- Select "U, Silt" as the soil type in the "Main soil type 1" combo box in the dialog 

group box "Soil and rock symbols" in Figure 11-24. The color of the silt and a 

short text "U" according to the German specification code DIN 4023 will be 

automatically created 

- Click "OK" button 

 

 
Figure 11-24 "Soil and rock symbols" dialog box 
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To modify a layer depth 

 

- Double-click on the layer depth. The corresponding edit box appears allowing you 

to modify the layer depth under the ground surface, Figure 11-25 

- Type 30 in the "Layer depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 11-25 "Layer depth under the ground surface" edit box 

 

To modify the groundwater depth under the ground surface 

 

- Double-click on the groundwater level. The corresponding edit box appears 

allowing you to modify the groundwater depth under the ground surface, Figure 

11-26. To neglect the uplift pressure on the raft, groundwater level is chosen at 

anywhere under the raft basement 

- Type 30 in the "Groundwater depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 11-26 "Groundwater depth under the ground surface" edit box 

 

To modify the label of a boring log 

 

- Double-click on the label of the boring log. The corresponding edit box appears 

allowing you to modify the label of the boring log, Figure 11-27 

- Type B1 in the edit box of Figure 11-27  

- Press "Enter" key to consider the text 

 

 
Figure 11-27 "Label of the boring log" edit box 

 

After the user has completed the definition of all soil properties and parameters, the screen 

should look like the following Figure 11-28. 
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Figure 11-28 Boring log on the screen 

 

After entering all data and parameters of boring log, do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 11-28 to save 

the data of boring log 

- Choose "Close boring logs" command from "File" menu in Figure 11-28 to close 

the ELPLA-Boring sub program and to return to the main window of ELPLA-

Data 

 

Note that the sign "√" is typed automatically beside the "Soil Properties" command in the "Data" 

menu of ELPLA-Data. 

 

2.7 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data. The following embedded program in Figure 11-29 appears with default 

foundation properties. In the current example, it is required to define only the unit weight of the 

foundation. Any other data corresponding to foundation properties in the program menus are not 

required. Therefore, the user can take these data from the default foundation properties. 
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Figure 11-29 "Foundation properties" embedded program 

 

To enter the unit weight of the foundation 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" 

menu in the window of Figure 11-29. The following dialog box in Figure 11-30 

with a default unit weight of 25 [kN/m3] appears. Type 0 to neglect the 

foundation weight in the edit box "Unit weight of the foundation" 

- Click "OK" button 

 

 
Figure 11-30 "Unit weight of the foundation" dialog box 

 

After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 11-29 

to save the foundation properties 

- Choose "Close foundation properties" command to close the "Foundation properties" 

embedded program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Foundation Properties" command in the 

"Data" menu of ELPLA-Data. 
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2.8 Loads 

 

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data. The 

following embedded program in Figure 11-31 appears. 

 

 
Figure 11-31 "Loads" embedded program 

 

To enter the concentrated load choose "Point loads" command from "Graphically" menu in the 

window of Figure 11-31. When "Point loads" command is chosen, the cursor is changed from an 

arrow to a cross hair. Then, the load can be defined by clicking on the screen (grid). When the 

screen is clicked, the following dialog box in Figure 11-32 appears with the load value and 

coordinates. 

 

In this dialog box 

 

- Type 8000 in the "Load" edit box 

- Type 5.2 in the "x-position" edit box 

- Type 5.2 in the "y-position" edit box 

- Click "OK" button 
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Figure 11-32 "Point loads P" dialog box 

 

 
Figure 11-33 Loads on the screen 
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After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 11-33 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 11-33 to close the 

"Loads" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Loads" command in the "Data" menu of 

ELPLA-Data. 

 

Creating the project of the pile groups is now complete. It is time to analyze this project. In the 

next section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem leave ELPLA-Data to ELPLA-Solver. This is done by clicking on 

"Solver" in the menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, 

ELPLA-Solver window appears, Figure 11-34.  

 

 
Figure 11-34 Opening screen of the sub program ELPLA-Solver 
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ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis. 

For this project, the items that are required to be calculated are: 

 

- Assembling the load vector    

- Determining flexibility coefficients of the soil     

- Assembling the soil stiffness matrix       

- Analysis of rigid pile groups 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The analysis progress menu in Figure 11-35 

appears in which various phases of calculation are progressively reported as the program 

analyzes the problem. Also, a status bar on the screen down of the ELPLA-Solver window 

displays information about the progress of calculation. 

 

 
Figure 11-35 Analysis progress menu 

 

Once the analysis is complete, a check menu of the solution appears, Figure 11-36. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 11-36 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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4 Viewing data and results 

 

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the 

three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed 

again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data 

is used only to define and view the data of the problem. ELPLA-Graphic is used to print data 

graphically while ELPLA-List is used to print data numerically.   

 

4.1 Viewing result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic 

window appears, Figure 11-37. ELPLA-Graphic automatically opens the data file of the current 

example and displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 11-37 Opening screen of the sub program ELPLA-Graphic 

 

To view the results for pile groups as circular diagrams 

 

- Choose "Results as Circular Diagrams" command from "Graphic" menu of 

ELPLA-Graphic. The following option box in Figure 11-38 appears 

- In "Results as circular diagrams" option box, select "Settlements s" as a sample 

for the results to be displayed 

- Click "OK" button 

 

Settlements are now displayed as circular diagrams for piles as shown in Figure 11-39. 
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Figure 11-38 "Results as circular diagrams" option box 

 

 
Figure 11-39 Settlements as circular diagrams for piles 

 

4.2 Listing data and result in tables 

 

To list tables of data and results, switch to ELPLA-List. This is done by clicking on "List" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Section window. ELPLA-List 

window appears, Figure 11-40.  
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Figure 11-40 Opening screen of the sub program ELPLA-List 

 

The function of ELPLA-List is listing and printing data and results in tables. The data and results 

can be exported to other Windows applications to prepare reports or add further information. 

ELPLA-List automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-List window. 

 

Only one command of the "List" menu is explained here. In the same way, the user can carry out 

the remaining commands of the previous list. The commands of "Format" and "Window" menus, 

which are used to define the preferences of the tables such as page format, font, etc., are 

discussed in detail in the User’s Guide of ELPLA. 

 

To list results in a table 

 

- Choose "Display tables of results" command from "List" menu. The following option 

box in Figure 11-41 appears 

- In this option box, select "Pile results" as an example for the results to be listed in a table 

- Click "OK" button. The pile results are now listed on the screen (Figure 11-42) 

- Choose "Send to Word" from "File" menu if you wish to export the text to the MS Word 

application, Figure 11-43 
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Figure 11-41 "Display tables of results" option box 

 

 
Figure 11-42 List of settlement results 
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Figure 11-43 Exported results in MS Word 
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1 Description of the problem 

 

An example of piled raft is selected to illustrate some of the essential features of ELPLA for 

analyzing piled raft. 

 

1.1 Load and dimensions 

 

A raft on 42 bored piles is considered as shown in Figure 12-1. All piles are equal in diameter 

and length where pile diameter is 0.9 [m] while pile length is 20 [m]. Spacing between piles is 

3.5 [m]. It is required to analyze the raft with piles as piled raft foundation due to a uniform load 

of p = 150 [kN/m] acting on the raft. 
 

24.5 [m]

 
 

Figure 12-1 Plan with piled raft geometry 

 

1.2 Raft material and thickness 

 

Raft material and thickness are supposed to have the following parameters: 

 

Raft thickness d  = 1.5   [m] 

Young's modulus Eb  = 3.4 * 107 [kN/m2] 

Unit weight b  = 25              [kN/m3] 

Poisson's ratio b  = 0.2   [-] 

 

1.3 Pile material 

 

The pile material is supposed to have the following parameters: 

 

Young's modulus Eb  = 2.35 * 107 [kN/m2] 

Unit weight b  = 25              [kN/m3] 
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1.4 Soil properties 

 

The subsoil under the raft consists of a layer of silt with 50 [m] thickness, the water table level is 2 

[m] below the ground surface. Foundation level is also 2 [m] below the ground surface. The soil is 

supposed to have the following parameters: 

 

Modulus of elasticity for loading Es  = 10000  [kN/m2] 

Modulus of elasticity for reloading Ws  = 10000 [kN/m2] 

Unit weight s  = 18   [kN/m3] 

Poisson's ratio s  = 0.3   [-] 

 

1.5 Mathematical model 

 

In this example, the Modulus of compressibility method (method 7) is chosen to analyze the 

piled raft. This Tutorial manual will not present the theoretical background of modeling the 

problem. For more information concerning the method of analysis, a complete reference for the 

soil models and numerical calculation methods are well documented in the User’s Guide of 

ELPLA. 

 

 

2 Creating the project 

 

In this section, the user will learn how to create a project for analyzing a piled raft foundation. 

The example will be processed step by step to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 12-2. This wizard will 

guide you through the steps required to create the project. As shown in Figure 12-2, the first 

form of the wizard is the "Analysis type" form. In this form, define the analysis type of the 

problem where ELPLA can deal with different structural systems. As the analysis type is piled 

raft, select "Analysis of piled raft" then click "Next" button to go to the next page. 
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Figure 12-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button, the "Calculation methods" form appears, Figure 12-3.  

To define the calculation method 

 

- Select the calculation method "7-Modulus of compressibility (Elimination)" 

- Click "Next" button to go to the next form 

 

 
Figure 12-3 "Calculation methods" form 
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The next form is the "System symmetry" (Figure 12-4). In this form choose "Unsymmetrical 

system" then click "Next" button. 

 

 
Figure 12-4 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 12-5. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. There isn’t any requested choices, so click the "Save" button.  

 

 
Figure 12-5 "Options" list 
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After clicking "Save" button, the "Save as" dialog box appears, Figure 12-6.  

 

In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example 

type "Piled raft". ELPLA will use automatically this file name in all reading and 

writing processes 

- Click "Save" button 

 

 
Figure 12-6 "Save as" dialog box 

 

ELPLA will activate the "Data" menu. In addition, the file name of the current project                  

[Piled raft] will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 

12-7. In the "Data" menu, the user can enter the remaining data of the project using the same 

sequence of commands in this menu. The first command in the menu is "Calculation methods", 

which has been already entered. Therefore, ELPLA has put the sign "√" beside this command, 

Figure 12-7. ELPLA puts this sign beside the commands those the user has entered so that the 

user can know which data were defined. 

 



 

 

ELPLA-Tutorial 

 

 

   12-8 

 
Figure 12-7 ELPLA-Data after defining the calculation method 
 

2.2 Project identification  

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 12-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box: 

"Analysis of piled raft" 

- Type the date of the project in the "Date" edit box 

- Type "Tutorial Manual" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 12-8 "Project identification" dialog box 
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2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation" 

wizard appears as shown in Figure 12-9. This wizard will guide you through the steps required to 

generate the FE-Net. As shown in Figure 12-9 the first form of the wizard is the "Slab type" form 

which contains a group of templates of different shapes of nets. These net templates are used to 

generate standard nets that have regular shapes. For the given problem, the foundation has a 

rectangular shape. 

 

 
Figure 12-9 "FE-Net generation" wizard with "Slab type" form 

 

To generate the FE-Net 

 

- In the "Slab type" options, choose the rectangular slab option 

- In the "Rectangular slab" frame, enter the total length and width of the raft in the 

corresponding edit boxes 

- Click "Next" button to go to the next form 

 

After clicking "Next" in "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 12-10. ELPLA can deal with various type of generations with triangle and/ or 

rectangular elements. Choose the first type of rectangular elements. Then click "Next" button to 

go to the next form. 
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Figure 12-10 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 12-11 appears with default values of constant element size. 

 

In this dialog box 

 

- In "Grid in x-direction" frame, type 14 in the "No. of  grid spaces" edit box 

- In "Grid in y-direction" frame, type 12 in the "No. of  grid spaces" edit box 

- Type 1.75 in the "Grid interval" edit box 

- Click "OK" button 

 

 
Figure 12-11 "Grid definition" form 

 

ELPLA will generate a FE-Net for a rectangular area of 24.5 [m] length and 21 [m] width with 

square elements of 1.75 [m] each side. The following embedded program in Figure 12-12 

appears with the generated net. 
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Figure 12-12 FE-Net of a rectangular slab on the screen 

 

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 12-12 to save the data of  

the FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 12-12 to close the "FE-

Net" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

2.4 Element length of pile 

 

To define the element length of pile, choose "Preferences" command from "Main data" menu of 

ELPLA-Data. The "Preferences" dialog box in Figure 12-13 appears.  

 

In this dialog box 

 

- Type 2 in the "Element length of pile" edit box 

- Click "Save" button 
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Figure 12-13 "Preferences" dialog box 

 

2.5 Piles 

 

To define piles, choose "Piles" command from "Data" menu of ELPLA-Data. The following 

embedded program in Figure 12-14 appears. 

 

 
Figure 12-14 "Piles" embedded program 
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Pile groups 

 

To define pile groups that have the same diameter and length, choose "Pile groups" command 

from "In Table" menu in Figure 12-14. When the "Pile" groups" command is chosen, the 

following table in Figure 12-15 appears allowing you to define the pile diameter and length. 

 

 
Figure 12-15 Defining pile groups 

 

Pile material 

 

To define pile material, choose "Pile material" command from "In Table" menu in Figure 12-14. 

When the "Pile material" command is chosen, the following dialog box in Figure 12-16 appears.  

 

In this dialog box 

 

- Type 25 in the "Unit weight of the pile concrete" edit box 

- Type 2.35E+07 in the "Modulus of elasticity of pile" edit box 

- Click "OK" button 

 

 
Figure 12-16 "Defining element groups" dialog box 
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Pile location 

 

To define pile locations on the net 

 

- Choose "Select nodes" command from "Graphically" menu in Figure 12-14  

- Select nodes those have piles as shown in Figure 12-17 

- Choose "Add piles" command from "Graphically" menu in Figure 12-17.  The "Defining 

pile groups" dialog box in Figure 12-18 appears. In this dialog box click "OK" button 

 

 
Figure 12-17 Selection of nodes that have piles 

 

 
Figure 12-18 "Defining pile groups" dialog box 

 

After you have completed the definition of the piles, the screen should look like the following 

Figure 12-19. 
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Figure 12-19 Piles on the screen 

 

After entering all data of piles, do the following two steps: 

 

- Choose "Save piles" command from "File" menu in Figure 12-19 to save the data 

of piles 

- Choose "Close piles" command from "File" menu in Figure 12-19 to close the 

ELPLA-Piles sub program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Piles" command in the "Data" menu of 

ELPLA-Data. 

 

2.6 Soil properties 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data. The following sub program in Figure 12-20 appears with a default-boring log. 
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Figure 12-20 ELPLA-Boring sub program with a default-boring log 

 

To enter the soil properties for the boring log of the current example 

 

- Choose "Soil data" command from "Data" menu in the window of Figure 12-20.  

The following dialog box in Figure 12-21 appears with default-boring log data. 

 

 
Figure 12-21 "Soil data" dialog box with default-boring log data 
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In the "Geotechnical data of the layer" dialog group box in Figure 12-21, define the geotechnical 

data of the first soil layer of the boring log as follows: 

 

Es   = 10000  [kN/m2] 

Ws   = 10000 [kN/m2] 

γs = 18   [kN/m3] 

νs = 0.3   [-] 

 

In the current example, the angle of internal friction φ and the cohesion c of the soil are not 

required because the selected type of the analysis is linear analysis. Therefore, the user can let the 

default values of the internal friction and the cohesion.  

 

φs = 30   [˚] 

c = 0   [kN/m2] 

 

Due to the presence of the ground water, the soil above the ground water level has a deferential 

unit weight from the soil under that level. Therefore, the layer depth of the first layer is taken to 

be 2 [m], which is equal to the ground water level. Now, type this value in "Layer depth under 

the ground surface" edit box. 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 

4023, the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "U, Silt" as the soil type in "Main soil 

type 1" combo box in "Soil and rock symbols" dialog group box, Figure 12-21.  The color of the 

silt according to the German Standard DIN 4023 will be automatically created. The user can 

change this color. Also, a short text "U" will be automatically created for the silt. 

 

To enter the second layer 

 

- Click "Layer copy" button in Figure 12-21. A layer that has the same properties of 

the first layer will be copied 

- Use the vertical scrollbar to move to the second soil layer.  

Layer No. will be typed automatically at the upper-left corner of the main dialog box of 

soil layers as a head title 

- Change the value of the unit weight of the soil for the second soil layer from 18 [kN/m3] 

to 9 [kN/m3] 

- Change the value of the layer depth under the ground surface from 2 [m] to 50 [m] 

 

Note that the unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due 

to the removed soil, which is equal to γs * df. This means that the unit weight of the soil under the 

foundation depth df  is not required. However, the unit weight of the soil under the foundation depth 

for all soil layers is entered by the value 9 [kN/m3]. 

 

After editing the geotechnical data, the boring coordinates and labels which describe the boring 

will be entered. 
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To enter the boring coordinates and label 

 

- Type 0 for x-coordinate in "x-coordinate of boring log [m]" edit box 

- Type 0 for y-coordinate in "y-coordinate of boring log [m]" edit box 

- Type B1 as a label name for the first boring in "Label of boring log" edit box 

 

To enter the main soil data for all layers, choose "Main soil data" command from "Data" menu in 

Figure 12-20. The following dialog box in Figure 12-22 appears with default main soil data. The 

main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other 

data corresponding to main soil data are not required in this example. Therefore, the user can 

take these data from the default soil properties. 

 

In the dialog box of Figure 12-22, enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 

 

 
Figure 12-22 "Main soil data" dialog box 

 

Now all data and parameters for the boring log have been entered. After finishing the creation of 

the boring log, click "OK" button in "Soil data" dialog box in Figure 12-21 to see the defined 

boring log on the screen where the user can control or modify the input data and parameters, 

Figure 12-23.  
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Figure 12-23 Boring log on the screen 

 

After entering all data and parameters of the boring log, do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 12-23 to save 

the data of boring log 

- Choose "Close boring logs" command from "File" menu in Figure 12-23 to close the 

ELPLA-Boring sub program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Soil properties" command in the "Data" 

menu of ELPLA-Data. 

 

2.7 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data. The following embedded program in Figure 12-24 appears with default 

foundation properties. The data of foundation properties for the current example, which are 

required to define, are foundation material and foundation thickness. Any other data 

corresponding to foundation properties in the program menus are not required. Therefore, the 

user can take these data from the default foundation properties. 
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Figure 12-24 "Foundation properties" embedded program 

 

To enter the foundation material and thickness 

 

- Choose "Element groups" command from "In Table" menu in the window of      

Figure 12-24. The following list box in Figure 12-25 with default data appears. 

To enter or modify a value in this list box, type that value in the corresponding 

cell then press "Enter" key. In the list box of Figure 12-25, enter E-Modulus of the 

foundation, Poisson’s ratio of the foundation and foundation thickness 

- Click "OK" button 

 

 
Figure 12-25 "Defining element groups" list box 
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To enter the unit weight of the foundation 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" 

menu in the window of Figure 12-24. The following dialog box in Figure 12-26 

with a default unit weight of 25 [kN/m3] appears. Let the default value as written 

in the edit box "Unit weight of the foundation" 

- Click "OK" button 

 

 
Figure 12-26 "Unit weight of the foundation" dialog box 

 

To enter the foundation level 

 

- Choose "Foundation depth" command from "Foundation properties" menu in the 

window of Figure 12-24. The following dialog box in Figure 12-27 appears 

- In this dialog box type 2 in the "Foundation depth under ground surface (a)/ (b)" edit box 

- Click "OK" button 

 

 
Figure 12-27 "Foundation depth" dialog box 

 

 

 

 

 

 



 

 

ELPLA-Tutorial 

 

 

   12-22 

After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 12-24 

to save the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 12-24 

to close the "Foundation properties" embedded program and to return to the main 

window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Foundation properties" command in the 

"Data" menu of ELPLA-Data. 

 

2.8 Loads 

 

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data. The 

following embedded program in Figure 12-28 appears. 

 

 
Figure 12-28 "Loads" embedded program 

 

To enter loads 

 

- Choose "Distributed load (rectangular)" command from "Graphically" menu in 

the window of Figure 12-28. When "Distributed loads (rectangular)" command is 

chosen, the cursor is changed from an arrow to a cross hair. Then, the load can be 

defined by holding the left mouse button down at the starting point of the 

distributed load. As the mouse is dragged, a box appears, indicating a distributed 

load is being defined. When the left mouse button is released, the following 

dialog box in Figure 12-29 appears with the load value and coordinates 
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In this dialog box 

 

- Type 150 in the "Load value" edit box 

- Modify the load coordinate 

- Click "OK" button 

 

 
Figure 12-29 "Distributed loads p" list box 

 

After you have completed the definition of all load data, the screen should look like the 

following Figure 12-30. 
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Figure 12-30 Loads on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 12-30 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 12-30 to close the 

"Loads" embedded program and return to the main window of ELPLA-Data.  

 

Note that the sign "√" is typed automatically beside the "Loads" command in the "Data" menu of 

ELPLA-Data. 

 

Creating the project of the raft is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, leave ELPLA-Data to ELPLA-Solver. This is done by clicking on 

"Solver" in the menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, 

ELPLA-Solver window appears, Figure 12-31.  
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Figure 12-31 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis. 

For this project, the items that are required to be calculated are: 

 

- Assembling the load vector    

- Determining flexibility coefficients of the soil     

- Assembling the soil stiffness matrix       

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (unsymmetrical matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The analysis progress menu in Figure 12-32 

appears in which various phases of calculation are progressively reported as the program 

analyzes the problem. Also, a status bar on the screen down of the ELPLA-Solver window 

displays information about the progress of calculation. 
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Figure 12-32 Analysis progress menu 

 

Once the analysis is complete, a check menu of the solution appears, Figure 12-33. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 12-33 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 

 

 

4 Viewing data and results 

 

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the 

three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed 

again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data 

is used only to define and view the data of the problem. ELPLA-Graphic is used to print data 

graphically while ELPLA-List is used to print data numerically. 

 

4.1 Viewing result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Solver window. 

 

ELPLA-Graphic window appears, Figure 12-34. ELPLA-Graphic automatically opens the data 

file of the current example and displays the data file name in the title bar of ELPLA-Graphic 

window. 
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Figure 12-34 Opening screen of the sub program ELPLA-Graphic 

 

To view the results for the raft as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The following option box in Figure 12-35 appears 

- In "Results as contour lines" option box, select "Settlements s" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The settlements are now displayed as contour lines for the raft as shown in Figure 12-36. 

 

 
Figure 12-35 "Results as contour lines" option box 
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Figure 12-36 Settlements as contour lines for the raft 

 

4.2 Plot a diagram of the results 

 

To plot a diagram of the results, leave ELPLA-Graphic to ELPLA-Section. This is done by 

clicking on "Section" in the menu bar of the sub programs at the upper-right corner of ELPLA-

Graphic window. ELPLA-Section automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Section window. 
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Figure 12-37 Opening screen of the sub program ELPLA-Section 

 

Only the first command of the "Sections" menu is explained here. In the same way, the user can 

carry out the remaining commands of the previous list. The commands of "Options", "Format" 

and "Window" menus, which are used to define the preferences of the drawing such as plot 

parameters, scale, font, etc., are discussed in detail in the User’s Guide of ELPLA.  

 

To plot a section in x-direction 

 

- Choose "Section in x-direction" command from "Sections" menu. 

The following option box in Figure 12-38 appears 

- In the "Section in x-direction" option box, select "Settlements s" as an example for the 

results to be plotted in a diagram 

- Click "OK" button 

 

 
Figure 12-38 "Section in x-direction" option box 
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The following option box in Figure 12-39 appears to specify the section in x-direction that is 

required to be plotted. 

 

In this dialog box 

 

- Type 10.5 in the "Section at y-coordinate" edit box to plot a diagram at the middle 

of the raft 

- Click "OK" button 

 

The settlements are now plotted in a diagram at the middle of the raft as shown in Figure 12-40. 

 

 
Figure 12-39 "Section in x-direction" dialog box 
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Figure 12-40 Diagram of settlements in x-direction at the middle of the raft 

 

4.3 Listing data and result in tables 

 

To list tables of data and results, switch to ELPLA-List. This is done by clicking on "List" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Section window. ELPLA-List 

window appears, Figure 12-41. 
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Figure 12-41 Opening screen of the sub program ELPLA-List 

 

The function of ELPLA-List is listing and printing data and results in tables. The data and results 

can be exported to other Windows applications to prepare reports or add further information. 

ELPLA-List automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-List window. 

 

Only one command of the "List" menu is explained here. In the same way, the user can carry out 

the remaining commands of the previous list. The commands of "Format" and "Window" menus, 

which are used to define the preferences of the tables such as page format, font, etc., are 

discussed in detail in the User’s Guide of ELPLA. 

 

To list results in tables 

 

- Choose "Display tables of results" command from "List" menu. 

The following option box in Figure 12-42 appears 

- In this option box, select "Pile results" as an example for the results to be listed in a table 

- Click "OK" button. The pile results are now listed on the screen (Figure 12-43) 

- Choose "Send to Word" from "File" menu if you wish to export the text to the MS Word 

application, Figure 12-44  
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Figure 12-42 "Display tables of results" option box 

 

 
Figure 12-43 List of pile results 
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Figure 12-44 Exported results in MS Word 
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1 Description of the problem 

 

An example of lowering the foundation of a building with an underground tunnel is selected to 

illustrate some of the essential features of ELPLA for studying the influence of an underground 

tunnel on a building foundation. 

 

1.1 Loads and dimensions 

 

The building has the outlines shown in Figure 13-1. It consists of two combined rectangles, their 

corners are not connected. The raft foundation is 50 [cm] thick and lies at a depth 2.50 [m] 

below the ground surface. The planned tunnel runs diagonally to the building axis. The tunnel is 

represented as a settling mould of 10 [m] width with maximum settlement of 3 [cm] caused by 

the tunnel. The settling mould which is shown in Figure 13-1 is marked by lines; each line 

represents a settlement value running symmetrically to the tunnel axis. This settlement values are 

taken in the calculation as secondary effects. 

 

The foundation loads consist of two concentrated loads of P = 18 [MN] and line load of p = 300 

[kN/m] on the external walls. The soil was explored through three borings from BPN1 to BPN3 

to 14 [m] depth under the raft. 
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Figure 13-1 a) Plan of the raft with settlement lines through the underground tunnel and           

boring points 

b) Boring logs BPN1 to BPN3 
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1.2 Foundation material and thickness 

 

Foundation material and thickness are supposed to have the following parameters: 

 

Foundation thickness d  = 0.5   [m] 

Young's modulus Ec  = 3 * 107 [kN/m2] 

Unit weight c  = 25   [kN/m3] 

Poisson's ratio c  = 0.2   [-] 

 

1.3 External wall properties and dimensions 

 

The wall properties and dimensions are supposed to have the following parameters: 

 

Breadth b = 0.3  [m] 

Depth d  = 3             [m] 

Moment of Inertia I  = 0.675  [m4] 

Shear modulus of the wall G  = 1.25 * 107  [kN/m2] 

Torsional moment of inertia J  = 0.0252 [m4] 

Walls own weight pb  = 22.50 [kN/m] 

 

1.4 Soil properties 

 

The subsoil under the building consists of a layer of clay, overlying a layer of stony sand. 

The clay layer is supposed to have the following parameters: 

 

Modulus of compressibility for loading Es  = 10000          [kN/m2] 

Modulus of compressibility for reloading Ws  = 30000          [kN/m2] 

Unit weight s  = 18                [kN/m3] 

 

The stony sand layer is supposed to have the following parameters: 

 

Modulus of compressibility for loading Es  = 160000        [kN/m2] 

Modulus of compressibility for reloading Ws  = 400000        [kN/m2] 

Unit weight s  = 21                [kN/m3] 

 

1.5 Mathematical model 

 

The influence of surrounding structures and external loads can be taken into consideration only 

for the Continuum model (methods 4 to 9). The Continuum model based on, the settlement at 

any node is affected by the forces at all the other nodes. In this example, the Modulus of 

compressibility method (method 7) is chosen to analyze our problem. 

 

This Tutorial manual will not present the theoretical background of modeling the problem. For 

more information concerning the method of analysis, a complete reference for the soil models 

and numerical calculation methods are well documented in the User’s Guide of ELPLA.  
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1.6 Analysis 

 

To analyze the foundation, it's subdivided into 112 quadratic elements with side length equals 

1.5 [m] as shown in Figure 13-1. Two independent names define the data of the two models 

which are chosen. The data are quite similar for the two models except the underground tunnel 

effect in the second model. 

 

The analysis of the first model is carried out first to obtain the internal forces in the first case 

(without consideration of the underground tunnel).Then, the second model is carried out to 

obtain the internal forces in the second case (with considering the underground tunnel effect). 

After that, the user should compare the results of the two cases to find out the influence of 

constructing the tunnel under a raft foundation. 

 

 

2 Creating the project 

 

In this section, the user will learn how to create a project for analyzing a raft foundation lowered 

with an underground tunnel. Thus is done by first entering the data of the foundation in the same 

manner of the previous foundation examples. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 13-2. This wizard will 

guide you through the steps required to create the project. As shown in Figure 13-2, the first 

form of the wizard is the "Analysis type" form. In this form, define the analysis type of the 

problem where ELPLA can deal with different structural systems. As the analysis type is a 

foundation problem, select "Analysis of slab foundation" then click "Next" button to go to the 

next page. 
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Figure 13-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button, the "Calculation methods" form appears, Figure 13-3.  

 

To define the calculation method 

 

- Select the calculation method "6-Modulus of Compressibility (Iteration)" 

- For the subsoil model select the option "Layered soil model" 

- Click "Next" button to go to the next form 

 

 
Figure 13-3 "Calculation methods" form 



 

 

      ELPLA-Tutorial 

 

 

   13-8 

The next form is the "System symmetry" (Figure 13-4). In this form choose "Unsymmetrical 

system" then click "Next" button. 

 

 
Figure 13-4 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 13-5. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. Check the option "Slab with girders", then click the "Save" button. 

 

 
Figure 13-5 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 13-6.  
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In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example 

type "TU1". ELPLA will use automatically this file name in all reading and 

writing processes 

- Click "Save" button 

 

 
Figure 13-6 "Save as" dialog box 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [TU1] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 13-7. 

 

In the "Data" menu, the user can enter the remaining data of the project using the same sequence 

of commands in this menu. The first command in the menu is "Calculation methods", which has 

been already entered. Therefore, ELPLA has put the sign "√" beside this command, Figure 13-7. 

ELPLA puts this sign beside the commands those the user has entered so that the user can know 

which data were defined. 
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Figure 13-7 ELPLA-Data after defining the calculation method 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 13-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Influence of ground lowering due to a tunnel on a building" 

- Type the date of the project in the "Date" edit box 

- Type "Without tunnel" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 13-8 "Project identification" dialog box 
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2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation" 

wizard appears as shown in Figure 13-9. This wizard will guide you through the steps required 

to generate the FE-Net. As shown in Figure 13-9 the first form of the wizard is the "Slab type" 

form which contains a group of templates of different shapes of nets. These net templates are 

used to generate standard nets that have regular shapes. For the given problem, the foundation 

has nearly a rectangular shape. 

 

To generate the FE-Net 

 

- In the "Slab type" options, choose the rectangle slab option 

- Type 21 in the "Length of rectangular slab" edit box 

- Type 13.5 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 13-9 "Slab type" form 

 

After clicking "Next" in the "Slab type" form, the following "Generation type" form appears, 

Figure 13-10. ELPLA can deal with various types of generations with rectangular elements. 

Choose the rectangular elements option as the generation type. Then click "Next" button to go to 

the next form. 
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Figure 13-10 "Generation type" form 

 

The next form of the "FE-Net generation" wizard is the "Grid definition" dialogue box. In this 

dialogue box, the default values of constant element size appear, Figure 13-11. 

 

In this "Grid definition" dialog box 

 

- Type 14 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 1.5 in the "Grid interval Dx [m]" edit box for grids in x-direction 

- Type 9 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 1.5 in the "Grid interval Dy [m]" edit box for grids in y-direction 

- Click "Finish" 

 

 
Figure 13-11 "Fe-Net generation" form 

 

Click "Finish" button in the "Generation parameters" form. ELPLA will generate a suitable FE-

Net for a rectangular foundation of 21 [m] length and 13.5 [m] width with rectangular elements, 

which have equal areas. The following embedded program in Figure 13-12 appears with the 

generated net. 
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Figure 13-12 FE-Net on the screen 

 

Deleting nodes from the FE-Net 

 

To select the unnecessary nodes, that are required to be removed from the net, first choose 

"Select nodes" command from the "Graphically" menu in Figure 13-12. When "Select nodes" 

command is chosen, the cursor will change from an arrow to a cross hair. The command 

"Remove nodes" in the menu "Graphically" will be enabled, indicating the mode in which is 

being operated. Next, select the required nodes by clicking on each node individually or 

selecting a group of nodes as shown in Figure 13-13. A group of nodes can be selected by 

holding the left mouse button down at the corner of the region. Then, dragging the mouse until a 

rectangle encompasses the required group of nodes. When the left mouse button is released, all 

nodes in the rectangle are selected. 
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Figure 13-13 Generated FE-Net after selecting the unnecessary nodes 

 

To remove the selected nodes, choose "Remove nodes" command from the "Graphically" menu. 

The action of this command is indicated in Figure 13-14. To leave the graphic mode, press "Esc" 

key. 

 

 
Figure 13-14 Final FE-Net after deleting the unnecessary nodes 
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After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 13-14 to save the 

data of the FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 13-14 to close the 

"FE-Net" embedded program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net" command in the "Data" menu 

of ELPLA-Data. 

 

2.4 External wall properties 

 

To define the external walls, choose "Girders" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 13-15 appears. 

 

 
Figure 13-15 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 13-15. 

The following option box in Figure 13-16 appears 

- In this option box, select "Rectangular cross section" 

- Click "OK" button 
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Figure 13-16 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 13-17 appears. 

 

In this list box 

 

- Enter the material properties of the walls, cross section dimensions and the wall weight 

as indicated in Figure 13-17. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" button 

 

 
Figure 13-17 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define girder locations on the net 

graphically. 

 

To define the walls location on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 13-15. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross 

hair 

- Click the left mouse button on the start node of the first girder and drag the mouse 

until the end node of that girder (Figure 13-18). Then, click on the end node. The 

"Girder elements" dialog box in Figure 13-19 appears 
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Figure 13-18 Add girder by mouse 

 

In this dialog box 

 

- Select the group No. 

- Click "OK" button 

 

 
Figure 13-19 "Girder elements" dialog box 

 

Now, the first wall is defined as shown in Figure 13-20. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

Repeat the previous steps to add the remaining walls on the net. After you have completed the 

definition of all walls, the screen should look like the following Figure 13-20. 
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Figure 13-20 First wall on the screen 

 

 
Figure 13-21 Walls on the screen 
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After entering all data and parameters of walls, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 13-21 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 13-21 to close the 

"Girders" embedded program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Girders" command in the "Data" menu 

of ELPLA-Data. 

 

2.5 Soil properties 

 

In ELPLA, there are three different soil models with several calculation methods. Therefore, the 

soil properties for each method are required to be defined according to the used soil model. In 

the current example, the soil model, which is used in the analysis, is Layered Soil Model. This 

model requires that the subsoil has to be defined by boring logs. In the example, three boring 

logs at different locations define the soil under the raft. Each boring log has two layers with 

different soil materials. The geotechnical data for each layer are unit weight of the soil γs and 

modulus of Elasticity for loading Es and reloading Ws. 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data. The following sub program in Figure 13-22 appears with a default-boring log. 

 

 
Figure 13-22 ELPLA-Boring sub program with a default-boring log 
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In Figure 13-22, soil properties are defined through the "Data" menu which contains the 

following two commands: 

 

- "Soil data" command. This command is used to define the individual boring logs 

- "Main soil data" command. This command is used to define the general data for all soil 

layers 

 

To define the soil properties for the three boring logs of the current example 

 

- Choose "Soil data" command from "Data" menu in the window of Figure 13-22.  

The following dialog box in Figure 13-23 with default-boring log data appears 

 

 
Figure 13-23 "Soil data" dialog box with default-boring log data 

 

In the "Geotechnical data of the layer" dialog group box in Figure 13-23 define the geotechnical 

data of the first soil layer of the three boring logs as follows: 

 

Es   = 10000  [kN/m2] 

Ws   = 30000 [kN/m2] 

γs = 18   [kN/m3] 

νs = 0.3   [-] 

 

In the current example, the angle of internal friction φ and the cohesion c of the soil are not 

required. Therefore, the user can enter zero values of the internal friction and the cohesion.  

 

φs = 0   [˚] 

c = 0   [kN/m2] 

 

The layer depth under the ground surface of the first layer is taken to be 5.5 [m]. Now, type this 

value in "Layer depth under the ground surface" edit box. 
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In order to draw the soil layers by different symbols according to the German Standard DIN 

4023, the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "T, Clay" as the soil type in "Main soil 

type 1" combo box in "Soil and rock symbols" dialog group box, Figure 13-23.  The color of the 

clay according to the German Standard DIN 4023 will be automatically created as violet. The 

user can change this color. Also, a short text "T" will be automatically created for the clay. 

 

To define the second layer 

 

- Click "Layer copy" button in Figure 13-23. A layer that has the same properties 

of the first layer will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be 

typed automatically at the upper-left corner of the main dialog box of soil layers 

as a head title 

- Select "Sst, Sandstone" as the soil type in "Main soil type 1" combo box in "Soil 

and rock symbols" dialog group box, Figure 13-23.  The color of the sandstone 

according to the German Standard DIN 4023 will be automatically created as 

orange. The user can change this color. Also, a short text "Sst" will be 

automatically created for the sandstone 

- Change the geotechnical data of the second soil layer of the three boring logs 

from the values of the first layer to the values as follows: 

 

Es   = 160000  [kN/m2] 

Ws   = 400000 [kN/m2] 

γs = 21   [kN/m3] 

νs = 0.3   [-] 

φs = 0   [˚] 

c = 0   [kN/m2] 

 

- Change the value of the layer depth under the ground surface from 5.5 [m] to 14 [m] 

 

After editing the geotechnical data for the first boring log, the boring coordinates and labels 

which describe the boring will be entered. 

 

To enter the boring coordinates and label 

 

- Type 2 for x-coordinate in "x-coordinate of boring log [m]" edit box 

- Type 3.5 for y-coordinate in "y-coordinate of boring log [m]" edit box 

- Type BPN1 as a label name for the first boring in "Label of boring log" edit box 

 

Now all data and parameters for the first boring log have been entered. The next step is to enter 

the data of the other two boring logs. As the three boring logs contain the same soil layers, data 

of the other two boring logs are created by first copying the data of the first boring log and then 

modifying boring logs individually. Only boring coordinates and labels are required to be 

modified. 
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To create the other two boring logs, click twice "Boring log copy" button in the                        

Figure 13-23. Two boring logs with the same data and parameters of the first boring log will be 

copied. 

 

Modifying data of boring logs 

 

Modifying boring coordinates is carried out only numerically while modifying the other data of 

boring logs may be carried out either numerically or graphically. In this example all data will be 

modified numerically. 

 

To modify the boring coordinates and labels 

 

- Use the horizontal scrollbar to switch to the second boring log. Boring log No. will be 

typed automatically at the upper-left corner of the main dialog box of boring logs as a 

head title 

- Type 20.5 as x-coordinate in "x-coordinate of boring log [m]" edit box in Figure 13-23 

- Type 2.5 as y-coordinate in "y-coordinate of boring log [m]" edit box in Figure 13-23 

- Type BPN2 as a label name for the second boring in "Label of boring log" dialog box 

in Figure 13-23 

- In "Layer depth under the ground surface" edit box in Figure 13-23, type the value 

6.3 [m] for the first layer depth under the ground surface  

 

Repeat the previous steps to modify the boring data for the third boring log. The data, which are 

required to be modified for the third boring log, are: 

 

x-coordinate of boring log [m]    = 17 

y-coordinate of boring log [m]    = 13.5  

Label of boring log      = BPN3 

Layer depth under the ground surface (1st layer) [m] = 7 

 

Now, after finishing the creation of boring logs, click "OK" button in "Soil data" dialog box in 

Figure 13-23 to see the defined boring logs on the screen where the user can control or modify 

the input data and parameters. As a default plot parameter, ELPLA displays only the first boring 

log on the screen, Figure 13-24. 
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Figure 13-24 First boring log on the screen 

 

To display all boring logs or specified boring logs on the screen, choose "Boring logs" command 

from "Graphically" menu in Figure 13-24, the following list box in Figure 13-25 appears. 

 

 
Figure 13-25 "List of boring logs" list box 
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To select the boring logs you want to display 

 

- Select the boring log that is required to be displayed from the list of the available boring 

logs in Figure 13-25 

- Click "Boring insert" button. Double clicking on the required boring log in the list of the 

available boring logs gives the same action. Removing a boring log from the drawing list 

is carried out by double clicking on that boring log in the list of the selected boring logs 

to draw or by clicking the "Boring insert" button 

- Click "OK" button in Figure 13-25. The selected boring logs appear on the screen to 

control or modify the boring data graphically, Figure 13-26 

 

 
Figure 13-26 Boring logs on the screen 

 

To enter the main soil data for all layers, choose "Main soil data" command from "Data" menu 

in Figure 13-26. The following dialog box in Figure 13-27 appears with default main soil data. 

The main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other 

data corresponding to main soil data are not required in this example. Therefore, the user can 

take these data from the default soil properties. 

 

In the dialog box of Figure 13-27, enter the settlement reduction factor α = 1 [-] and the 

groundwater depth under the ground surface Gw = 12 [m]. Then click "OK" button. 
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Figure 13-27 "Main soil data" dialog box 

 

After entering all data and parameters of boring logs, do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 13-26 to save 

the data of boring logs 

- Choose "Close boring logs" command from "File" menu in Figure 13-26 to close the 

ELPLA-Boring sub program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Soil properties" command in the "Data" 

menu of ELPLA-Data. 

 

2.6 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data. The following embedded program in Figure 13-28 appears with default 

foundation properties. The data of foundation properties for the current example, which are 

required to define, are foundation material, foundation thickness and foundation level. Any other 

data corresponding to foundation properties in the program menus are not required. Therefore, 

the user can take these data from the default foundation properties. 
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Figure 13-28 "Foundation properties" embedded program 

 

To enter the foundation material and thickness 

 

- Choose "Element groups" command from "In Table" menu in the window of      

Figure 13-28. The following list box in Figure 13-29 with default data appears. To 

enter or modify a value in this list box, type that value in the corresponding cell 

then press "Enter" key. In the list box of Figure 13-29, enter E-Modulus of the 

foundation Ec = 3E + 07 [kN/m2], Poisson’s ratio of the foundation νc = 0.2 [-] and 

foundation thickness dc = 0.5 [m] 

- Click "OK" button 

 

 
Figure 13-29 "Defining element groups" list box 
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To enter the unit weight of the foundation 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" 

menu in the window of Figure 13-28. The following dialog box in Figure 13-30 

with a default unit weight of 25 [kN/m3] appears; let this value as given to take 

the own weight of the foundation in consideration in the analysis 

- Click "OK" button 

 

 
Figure 13-30 "Unit weight of the foundation" dialog box 

 

To enter the foundation level 

 

- Choose "Foundation depth command from "Foundation properties" menu in the 

window of Figure 13-28. The following dialog box in Figure 13-31 appears 

- In this dialog box type 2.5 in the "Foundation depth under ground surface (a)/ (b)" edit 

box 

- Click "OK" button 

 

 
Figure 13-31 "Foundation depth" dialog box 
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After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 13-28 

to save the foundation properties 

- Choose "Close foundation properties" command from "File" menu in Figure 13-28 

to close the "Foundation properties" embedded program and to return to the main 

window of ELPLA-Data 

 

2.7 Boring fields 

 

If the subsoil under the raft is defined by two boring logs or more such as in the current example, 

the irregularity of the subsoil must be taken into account. "Boring fields" command let the user 

define which method is to be used to consider the irregularity of the subsoil. In the current 

example, the Interpolation Method will be used. 

 

To consider the Interpolation Method in the analysis, choose "Boring fields" command from 

"Data" menu. The following embedded program in Figure 13-32 appears with a default method. 

ELPLA considers that the Interpolation Method is the default one, which takes into account the 

irregularity of the subsoil. In most cases ELPLA defines the interpolation zone types I, II, III 

automatically such as in this example. But in the case of extreme boring arrangements, the user 

must define these zones. 

 

 
Figure 13-32 "Boring fields" embedded program 
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You do not need to change anything. Now, do the following two steps: 

 

- Choose "Save boring fields" command from "File" menu in Figure 13-32 to save the data 

of boring fields 

- Choose "Close boring fields" command from "File" menu in Figure 13-32 to close the 

"Boring fields" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Boring fields" command in "Data" menu of 

ELPLA-Data. 

 

2.8 Loads 

 

In ELPLA, loads on the raft such as point loads, line loads, uniform loads or moments may be 

applied to the net of the finite elements at any position independently on the node position. The 

coordinates of the loads are related to the lower-left corner of the raft (local coordinates). 

 

To define the loads, choose "Loads" command from "Data" menu. The following embedded 

program in Figure 13-33 appears. 

 

 
Figure 13-33 "Loads" embedded program 

 

In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using 

the commands of "Graphically" menu in Figure 13-33. In this example the user will learn the 

definition of loads numerically. 

 

The foundation loads consist of two concentrated loads of P = 18 [MN] and line load of p = 300 

[kN/m] on the external walls. 
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To neglect the dimensions of columns at foundation level 

 

- Choose "Column types" command from "In Table" menu in the window of 

Figure 13-33. The following list box in Figure 13-35 appears with default 

dimensions a = 0.5 [m] and b = 0.5 [m] 

- To neglect the dimensions of the columns in the analysis, type 0 in the column 

side a and column side b cells 

- Click "OK" button 

 

 
Figure 13-34 "Column types" list box 

 

To enter concentrated loads 

 

- Choose "Point loads" command from "In Table" menu in the window of Figure 13-33. 

The following list box in Figure 13-35 appears 

- Enter the external point loads P [KN] and their corresponding coordinates (x, y) in 

the list box of Figure 13-35. This is done by typing the value in the corresponding 

cell and then press "Enter" key. The coordinates of the point load are related to 

the lower-left corner of the foundation (local coordinates) 

- Click "OK" button 

 

 
Figure 13-35 "Point loads P" list box 
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Repeat the previous steps for line loads using "Line loads" command from "In Table" menu. 

After you have completed the definition of all load data, the screen should look like the 

following Figure 13-36. 

 

 
Figure 13-36 Loads on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 13-36 to save the load 

data 

- Choose "Close loads" command from "File" menu in Figure 13-36 to close the 

"Loads" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Loads" command in "Data" menu of 

ELPLA-Data. 

 

The project creation of the first case without the underground tunnel is now completed. 
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3 Creating the project of the second case (including the underground tunnel) 

 

The data of the two projects are quite similar except the effect of the tunnel. Project 

identification is entered so that you can distinguish between the two projects. The data of the 

second case are created by first saving the data of the first case under a new file name and then 

modifying the project identification. 

 

To save the data under a new file name 

 

- Choose "Save project as" command from "File" menu of ELPLA-Data. The 

following "Save as" dialog box appears, Figure 13-37 

 

In this dialog box 

 

- Type a file name for the project of the second case in the file name edit box. For 

example type "TU2" 

- Click "Save" button 

 

 
Figure 13-37 "Save as" dialog box 

 

3.1 Modifying the calculation methods options  

 

To add the option of influence of additional settlements on the raft do the following steps: 

 

- Choose "Calculation methods" command from "Data" menu 

- The first form of the wizard "Calculation method" is the "Analysis type" form,   

Figure 13-2. In this form, click "Next" button to go to the next page 

- After clicking "Next" button, the "Calculation methods" form appears, Figure 13-3. 

Click "Next" button to go to the next form 

- The next form is the "System symmetry" (Figure 13-4). In this form click "Next" 

button 

- The last form of the wizard assistant contains the "Option" list, Figure 13-38. In 

this list, check the option "Influence of additional settlements on raft", then click 

the "Save" button 
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Figure 13-38 "Options" list 

 

3.2 Modifying the project identification  

 

To modify the project identification, choose "Project identification" command from "Data" 

menu of ELPLA-Data. The dialog box in Figure 13-39 appears. In this dialog box, type "With 

tunnel" in the "Project" edit box then click "Save" button. 

 

 
Figure 13-39 "Project identification" dialog box 

 

3.3 Additional settlements 

 

To define the settlements caused by the tunnel, choose "Additional settlements" command from 

"Data" menu of ELPLA-Data. The following embedded program in Figure 13-40 appears.  
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Figure 13-40 "Additional settlements" embedded program 

 

To define the settlement values 

 

- Choose "Additional settlements" command from "In Table" menu in the window 

of Figure 13-28. The following list box in Figure 13-41 appears 

- In this list box type the node number and the corresponding settlement value 

- Click "OK" button 

 

 
Figure 13-41 "Additional settlements" list box 

 

After you have completed the definition of the additional settlements, the screen should look like 

the following Figure 13-42 
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Figure 13-42 Additional settlements on the screen 

 

After defining the additional settlements, do the following two steps: 

 

- Choose "Save additional settlements" command from "File" menu in Figure 13-42 

to save the additional settlements 

- Choose "Close additional settlements" command from "File" menu in Figure 13-42 to 

close the "Additional settlements" embedded program and return to ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Additional settlements" command in "Data" 

menu of ELPLA-Data. 

 

 

4 Carrying out the calculations 

 

The calculations of the first case should be first done, and then the calculations of the second 

case are carried out. 

 

4.1 Starting ELPLA-Solver 

 

To analyze the problem, open the file "TU1" from "File" menu from ELPLA-Data, Then, leave 

ELPLA-Data to ELPLA-Solver. This is done by clicking on "Solver" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver window appears, 

Figure 13-43. 
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Figure 13-43 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis.  

 

For the project of the first case, the items, which are required to be calculated, are: 

 

- Assembling the load vector        

- Determining flexibility coefficients of the soil     

- Assembling the soil stiffness matrix 

- Assembling girder stiffness matrix       

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (Unsymmetrical matrix) 

- Determining deformation, internal forces, contact pressures 

 

While that for the project of the second case, the items, which are required to be calculated, are: 

 

- Assembling the load vector        

- Determining flexibility coefficients of the soil     

- Assembling the soil stiffness matrix 

- Influence of additional settlements on raft 

- Assembling girder stiffness matrix       

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (Unsymmetrical matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time.  
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4.2 Carrying out all computations 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Calculation" menu in ELPLA-Solver 

window. The following "Iteration parameters" option box in Figure 13-44 appears 

- In "Iteration parameters" option box, select which option is ending the iteration process.  

For this example, choose an accuracy of 0.0001 [m] to end the iteration process 

- Click "OK" button 

 

 
Figure 13-44 "Iteration parameters" option box 

 

The progress of all computations according to the defined method will be carried out 

automatically with displaying information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 13-45 appears in which various phases of the calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 13-45 Analysis progress menu 

 

Iteration process 

 

Information about the convergence progress of the computations is displayed in the "Iteration 

process" list box in Figure 13-46 during the iteration process.  
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Figure 13-46 "Iteration process" list box 

 

Check of the solution 

 

Once the analysis is complete, a check menu of the solution appears, Figure 13-47. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 13-47 Menu "Check of the solution" in the first case 

 

To finish analyzing the first case of the problem, click "OK" button. 

  

Now the analysis of the first case without the tunnel has ended, after that we should analysis the 

second case. 

 

To analyze the second case of the example, open the file "TU2" from "File" menu in ELPLA-

Solver and choose "Computation of all" command from "Calculation" menu in ELPLA-Solver 

window. After the analysis is complete, the "Check of the solution" menu appears (Figure 13-

48). Click the "OK" button to finish the analysis of the second case of the problem. 
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Figure 13-48 Menu "Check of the solution" in the second case 

 

 

5 Viewing data and results 

 

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the 

three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed 

again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data 

is used only to define and view the data of the problem. ELPLA-Graphic is used to print data 

graphically while ELPLA-List is used to print data numerically. 

 

5.1 Viewing result graphics 

 

To view the data and results of the first case of the problem that has already been defined and 

analyzed graphically, open the file "TU1" from "File" menu from ELPLA-Solver. Then, leave 

ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the 

sub programs at the upper-right corner of ELPLA-Solver window. 

 

ELPLA-Graphic window appears, Figure 13-49. ELPLA-Graphic automatically opens the data 

file of the current example and displays the data file name in the title bar of ELPLA-Graphic 

window. 
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Figure 13-49 Opening screen of the sub program ELPLA-Graphic 

 

To view the results for the raft without the effect of the underground tunnel as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-

Graphic. The following option box in Figure 13-50 appears 

- In "Results as contour lines" option box, select "Settlements" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The settlements are now displayed as contour lines for the raft only before constructing 

the tunnel as shown in Figure 13-51. 

 

 
Figure 13-50 "Results as contour lines" option box 
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Figure 13-51 Settlements as contour lines (first case) 

 

To view the settlement results for the raft with the effect of the underground tunnel as contour 

lines 

 

- Choose "TU2" file from "File" menu from ELPLA- Graphic 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The option box in Figure 13-50 appears 

- In "Results as contour lines" option box, select "Settlements" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The settlements are now displayed as contour lines for the second case of the analysis as shown 

in Figure 13-52. 

 



 

 

      ELPLA-Tutorial 

 

 

   13-42 

 
Figure 13-52 Settlements as contour lines for the raft (second case) 

 

5.2 Plot a diagram of results 

 

To plot a diagram of results, leave ELPLA-Graphic to ELPLA-Section. This is done by clicking 

on "Section" in the menu bar of the sub programs at the upper-right corner of ELPLA-Graphic 

window. ELPLA-Section window appears, Figure 13-53. 

 

ELPLA-Section automatically opens the data file of the current example and displays the data 

file name in the title bar of ELPLA-Section window. 
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Figure 13-53 Opening screen of the sub program ELPLA-Section 

 

To consider the results for the two cases together 

 

- Choose "Combination from many projects" command from "File" menu of 

ELPLA-Section. The following list box in Figure 13-54 appears. Select the project 

"TU1" in the list of projects to be combined 

- Click "Add project" button in "Combination from many projects" list box. Then 

open the project "TU2"  

- Click "OK" button in the "Combination from many projects" list box 

 

 
Figure 13-54 "Combination from many projects" list box 
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To plot a section in x-direction 

 

- Choose "Section in x-direction" command from "Sections" menu. The following 

option box in Figure 13-55 appears 

- In "Section in x-direction" option box, select "Settlements" as a sample for the 

results to be plotted in a diagram 

- Click "OK" button 

 

 
Figure 13-55 "Section in x-direction" option box 

 

The following dialog box in Figure 13-56 appears to specify the section in x-direction that is 

required to be plotted. 

 

In this dialog box 

 

- Type 7.5 in the "Section at y-coordinate" edit box to plot a diagram at the 

horizontal axis of the columns 

- Click "OK" button 

 

The settlements are now plotted in a diagram at a section across the columns of the raft in the 

two cases together as shown in Figure 13-57. 

 

The user can repeat the following steps to display the critical results of contact pressure as 

shown in Figure 13-58 or displaying the critical results of bending moment in x-direction as 

shown in Figure 13-59. The critical results which are shown located at y =7.5 [m]. 
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Figure 13-56 "Section in x-direction" dialog box 

 

  
Figure 13-57 Diagram of settlements in x-direction at y = 7.5 [m] for the two cases 
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Figure 13-58 Diagram of contact pressure in x-direction at y = 7.5 [m] of the two cases 

 

 
Figure 13-59 Diagram of bending moment Mx in x-direction at y = 7.5 [m] of the two cases 
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