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1 Description of the problem 

 

An example of pile groups is selected to illustrate some of the essential features of ELPLA for 

analyzing pile groups. 

 

1.1 Load and dimensions 

 

A pile cap on 24 vertical piles is considered as shown in Figure 11-1. All piles are equal in 

diameter and length where pile diameter is 0.5 [m] while pile length is 10 [m]. Spacing between 

piles is 1.6 [m]. It is required to analyze the pile cap as rigid free-standing raft due to a vertical 

load of P = 8000 [kN] acting on the pile cap with eccentricities ex = 1.4 [m] and ey = 1.8 [m] in 

both x- and y-directions. 

 
 

 

3.8  
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Figure 11-1 Plan with raft geometry [m], resultant force on the raft [kN] and pile locations 

 

1.2 Soil properties 

 

The subsoil under the raft consists of a layer of silt, 30 [m] thick. The raft lies directly on the 

ground surface. There is no effect of water table on the raft. The soil is supposed to have the 

following parameters: 

 

Modulus of elasticity for loading Es  = 10000  [kN/m2] 

Modulus of elasticity for reloading Ws  = 10000 [kN/m2] 

Poisson's ratio s  = 0.3   [-] 
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1.3 Mathematical model 

 

In this example, rigid free-standing raft (method 9) is chosen to analyze the raft. This Tutorial 

manual will not present the theoretical background of modeling the problem. For more 

information concerning the method of analysis, a complete reference for the soil models and 

numerical calculation methods are well documented in the User’s Guide of ELPLA. 

 

 

2 Creating the project 

 

In this section, the user will learn how to create a project for analyzing pile groups. The example 

will be processed step by step to show the possibilities and abilities of the program. To enter the 

data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation method" wizard appears, Figure 11-2. This wizard will 

guide you through the steps required to create the project. As shown in Figure 11-2, the first 

form the wizard is the "Analysis type" form. In this form, define the analysis type of the problem 

where ELPLA can deal with different structural systems. As the analysis type is pile groups, 

select "Analysis of piled raft" then click "Next" button to go to the next page. 

 

 
Figure 11-2 "Calculation method" wizard with "Analysis type" form 

 

After clicking "Next" button, the "Calculation methods" form appears, Figure 11-3. 
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To define the calculation method 

 

- Select the calculation method "9-Rigid free-standing raft" 

- Select the subsoil model "Layered soil model" 

- Click "Next" button to go to the next form 

 

 
Figure 11-3 "Calculation methods" form 

 

The next form is the "System symmetry" (Figure 11-4). 

 

 
Figure 11-4 "System symmetry" form 
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In this form choose "Unsymmetrical system" then click "Next" button. 

 

The last form of the wizard assistant contains the "Option" list, Figure 11-5. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. There isn’t any requested choices, so click the "Save" button.  

 

 
Figure 11-5 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 11-6. 

 

 
Figure 11-6 "Save as" dialog box 
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In this dialog box 

 

- Type a file name for the current project in the "File name" edit box. For example 

type "Pile groups". ELPLA will use automatically this file name in all reading and 

writing processes 

- Click "Save" button 

 

ELPLA will activate the "Data" menu. In addition, the file name of the current project                  

[Pile groups] will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 

11-7. In the "Data" menu, the user can enter the remaining data of the project using the same 

sequence of commands in this menu. The first command in the menu is "Calculation methods", 

which has been already entered. Therefore, ELPLA has put the sign "√" beside this command, 

Figure 11-7. ELPLA puts this sign beside the commands those the user has entered so that the 

user can know which data were defined. 

 

 
Figure 11-7 ELPLA-Data after defining the calculation method 
 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 11-8 appears. 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box: 

"Analysis of pile groups" 

- Type the date of the project in the "Date" edit box 

- Type "Tutorial Manual" in the "Project" edit box 

- Click "Save" button 
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Figure 11-8 "Project identification" dialog box 

 

2.3 FE-Net data 

 

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation" 

wizard appears as shown in Figure 11-9. This wizard will guide you through the steps required to 

generate the FE-Net. As shown in Figure 11-9 the first form of the wizard is the "Slab type" form 

which contains a group of templates of different shapes of nets. These net templates are used to 

generate standard nets that have regular shapes. For the given problem, the foundation has an 

irregular shape. 

 

In pile group problems, it is not required to generate a FE-Net for the entire dimension of the 

raft. Only a net containing pile location is enough. ELPLA has different procedures for defining 

the FE-Net. The easy procedure to define the FE-Net of these pile groups is generating a mesh 

for the entire area firstly, then removing the unnecessary nodes to get the foundation shape. 

 

 
Figure 11-9 "FE-Net generation" wizard with "Slab type" form 

 

To generate the FE-Net 

 

- In the "Slab type" options, choose the rectangular slab option 

- In the "Rectangular slab" frame, enter the total length and width of the raft in the 

corresponding edit boxes 

- Click "Next" button to go to the next form 
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After clicking "Next" in "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 11-10. ELPLA can deal with various type of generations with triangle and/ or 

rectangular elements. Choose the first type of rectangular elements. Then click "Next" button to 

go to the next form. 

 

 
Figure 11-10 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 11-11 appears with default values of constant element size. 

 

In this dialog box 

 

- In "Grid in x-direction" frame, type 4 in the "No. of  grid spaces" edit box 

- In "Grid in y-direction" frame, type 5 in the "No. of  grid spaces" edit box 

- Type 1.6 in the "Grid interval" edit box 

- Click "OK" button 

 

 
Figure 11-11 "Grid definition" form 

 

ELPLA will generate a FE-Net for a rectangular area of 6.4 [m] length and 8 [m] width with 

square elements of 1.6 [m] each side. The following embedded program in Figure 11-12 appears 

with the generated net. 
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Figure 11-12 FE-Net of a rectangular slab on the screen 

 

Deleting nodes from the FE-Net 

 

To select the unnecessary nodes that are required to be removed from the net, first choose "Select 

nodes" command from "Graphically" menu. When "Select nodes" command is chosen, the cursor 

will change from an arrow to a cross hair. The command "Remove nodes" in the menu 

"Graphically" will be enabled, indicating the mode in which is being operated. Next, select the 

required nodes by clicking on each node individually or selecting a group of nodes as shown in 

Figure 11-13. To remove the selected nodes, choose "Remove nodes" command from the 

"Graphically" menu. The action of this command is indicated in Figure 11-14. 
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Figure 11-13 Generated FE-Net after selecting the unnecessary nodes 

 

 
Figure 11-14 Final FE-Net after deleting the unnecessary nodes 
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After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 11-14 to save the data of  

the FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 11-14 to close the "FE-

Net" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

2.4 Element length of pile 

 

To define the element length of pile, choose "Preferences" command from "Main data" menu of 

ELPLA-Data. The "Preferences" dialog box in Figure 11-15 appears.  

 

In this dialog box 

 

- Type 0.5 in the "Element length of pile" edit box 

- Click "Save" button 

 

 
Figure 11-15 "Preferences" dialog box 

 

2.5 Piles 

 

To define piles, choose "Piles" command from "Data" menu of ELPLA-Data. The following 

embedded program in Figure 11-16 appears. 
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Figure 11-16 "Piles" embedded program 

 

Pile groups  

 

To define pile groups those have the same diameter and length, choose "Pile groups" command 

from "In Table" menu in Figure 11-16. When the "Pile groups" command is chosen, the 

following table in Figure 11-17 appears allowing you to define the pile diameter and length.  

 

 
Figure 11-17 Defining pile groups 
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Pile material 

 

To define pile material, choose "Pile material" command from "In Table" menu in Figure 11-16. 

When the "Pile material" command is chosen, the following dialog box in Figure 11-18 appears 

allowing you to define the pile material. Type 0 in the "Unit weight of the pile concrete" edit box 

to neglect the pile weight. 

 

 
Figure 11-18 "Defining element groups" dialog box 

 

Pile location 

 

To define pile locations on the net 

 

- Choose "Select nodes" command from "Graphically" menu in Figure 11-16  

- Select nodes that have piles as shown in Figure 11-19 

- Choose "Add piles" command from "Graphically" menu in Figure 11-19. The 

"Defining pile groups" dialog box in Figure 11-20 appears. In this dialog box 

click "OK" button 

 

 
Figure 11-19 Selection of nodes that have piles 
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Figure 11-20 "Defining pile groups" dialog box 

 

After you have completed the definition of the piles, the screen should look like the following 

Figure 11-21. 

 

 
Figure 11-21 Piles on the screen 

 

After entering all data of piles, do the following two steps: 

 

- Choose "Save piles" command from "File" menu in Figure 11-21 to save the data 

of piles 

- Choose "Close piles" command from "File" menu in Figure 11-21 to close the 

ELPLA-Piles sub program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Piles" command in the "Data" menu of 

ELPLA-Data. 
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2.6 Soil properties 

 

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLA-

Data. The following sub program in Figure 11-22 appears with a default-boring log. 

 

 
Figure 11-22 ELPLA-Boring sub program with a default-boring log 

 

Modifying data of boring log graphically 

 

In ELPLA, the boring log can be defined or modified graphically, which makes the definition of 

the boring log very easy. By double-clicking the left mouse button on a specified screen position, 

the user can define or modify the soil data and input parameters graphically.  

 

To enter the geotechnical data of the soil layer 

 

- Double-click on the geotechnical data of the soil layer. The corresponding dialog box 

appears allowing you to modify the geotechnical data of the soil layer, Figure 11-23 

- In the dialog group box "Geotechnical data of the layer" in Figure 11-23, define 

the geotechnical data of the soil layer as follows: 

  

Es   = 10 000 [kN/m2] 

Ws   = 10 000 [kN/m2] 

s   = 0.3  [-] 
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The values Es and Ws are the same because the effect of reloading on the soil is not required. 

The unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due to the 

removed soil, which is equal to γs * df. In the current example df = 0.0, which means the unit 

weight of the soil is not required. However, the unit weight of the soil is entered by the default 

value. Also, the angle of internal friction φ and the cohesion c of the soil are not required because 

the selected type of the analysis is linear analysis. Therefore, the user can let the default values of 

the internal friction and the cohesion. Next, click "OK" button. 

 

 
Figure 11-23 "Geotechnical data of the soil layer" dialog box 

 

To define the soil type and color for the layer 

 

- Double-click on the soil symbol of the soil layer. The corresponding dialog box 

appears allowing you to modify the soil symbols of that layer, Figure 11-24 

- Select "U, Silt" as the soil type in the "Main soil type 1" combo box in the dialog 

group box "Soil and rock symbols" in Figure 11-24. The color of the silt and a 

short text "U" according to the German specification code DIN 4023 will be 

automatically created 

- Click "OK" button 

 

 
Figure 11-24 "Soil and rock symbols" dialog box 

 



 

 

ELPLA-Tutorial 

 

 

   11-18 

To modify a layer depth 

 

- Double-click on the layer depth. The corresponding edit box appears allowing you 

to modify the layer depth under the ground surface, Figure 11-25 

- Type 30 in the "Layer depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 11-25 "Layer depth under the ground surface" edit box 

 

To modify the groundwater depth under the ground surface 

 

- Double-click on the groundwater level. The corresponding edit box appears 

allowing you to modify the groundwater depth under the ground surface, Figure 

11-26. To neglect the uplift pressure on the raft, groundwater level is chosen at 

anywhere under the raft basement 

- Type 30 in the "Groundwater depth under the ground surface" edit box 

- Click "OK" button 

 

 
Figure 11-26 "Groundwater depth under the ground surface" edit box 

 

To modify the label of a boring log 

 

- Double-click on the label of the boring log. The corresponding edit box appears 

allowing you to modify the label of the boring log, Figure 11-27 

- Type B1 in the edit box of Figure 11-27  

- Press "Enter" key to consider the text 

 

 
Figure 11-27 "Label of the boring log" edit box 

 

After the user has completed the definition of all soil properties and parameters, the screen 

should look like the following Figure 11-28. 
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Figure 11-28 Boring log on the screen 

 

After entering all data and parameters of boring log, do the following two steps: 

 

- Choose "Save boring logs" command from "File" menu in Figure 11-28 to save 

the data of boring log 

- Choose "Close boring logs" command from "File" menu in Figure 11-28 to close 

the ELPLA-Boring sub program and to return to the main window of ELPLA-

Data 

 

Note that the sign "√" is typed automatically beside the "Soil Properties" command in the "Data" 

menu of ELPLA-Data. 

 

2.7 Foundation properties 

 

To define the foundation properties, choose "Foundation properties" command from "Data" 

menu of ELPLA-Data. The following embedded program in Figure 11-29 appears with default 

foundation properties. In the current example, it is required to define only the unit weight of the 

foundation. Any other data corresponding to foundation properties in the program menus are not 

required. Therefore, the user can take these data from the default foundation properties. 
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Figure 11-29 "Foundation properties" embedded program 

 

To enter the unit weight of the foundation 

 

- Choose "Unit weight of the foundation" command from "Foundation properties" 

menu in the window of Figure 11-29. The following dialog box in Figure 11-30 

with a default unit weight of 25 [kN/m3] appears. Type 0 to neglect the 

foundation weight in the edit box "Unit weight of the foundation" 

- Click "OK" button 

 

 
Figure 11-30 "Unit weight of the foundation" dialog box 

 

After entering the foundation properties, do the following two steps: 

 

- Choose "Save foundation properties" command from "File" menu in Figure 11-29 

to save the foundation properties 

- Choose "Close foundation properties" command to close the "Foundation properties" 

embedded program and to return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Foundation Properties" command in the 

"Data" menu of ELPLA-Data. 
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2.8 Loads 

 

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data. The 

following embedded program in Figure 11-31 appears. 

 

 
Figure 11-31 "Loads" embedded program 

 

To enter the concentrated load choose "Point loads" command from "Graphically" menu in the 

window of Figure 11-31. When "Point loads" command is chosen, the cursor is changed from an 

arrow to a cross hair. Then, the load can be defined by clicking on the screen (grid). When the 

screen is clicked, the following dialog box in Figure 11-32 appears with the load value and 

coordinates. 

 

In this dialog box 

 

- Type 8000 in the "Load" edit box 

- Type 5.2 in the "x-position" edit box 

- Type 5.2 in the "y-position" edit box 

- Click "OK" button 
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Figure 11-32 "Point loads P" dialog box 

 

 
Figure 11-33 Loads on the screen 
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After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 11-33 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 11-33 to close the 

"Loads" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "Loads" command in the "Data" menu of 

ELPLA-Data. 

 

Creating the project of the pile groups is now complete. It is time to analyze this project. In the 

next section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem leave ELPLA-Data to ELPLA-Solver. This is done by clicking on 

"Solver" in the menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, 

ELPLA-Solver window appears, Figure 11-34.  

 

 
Figure 11-34 Opening screen of the sub program ELPLA-Solver 
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ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of 

all calculations. Commands of calculation depend on the used calculation method in the analysis. 

For this project, the items that are required to be calculated are: 

 

- Assembling the load vector    

- Determining flexibility coefficients of the soil     

- Assembling the soil stiffness matrix       

- Analysis of rigid pile groups 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The analysis progress menu in Figure 11-35 

appears in which various phases of calculation are progressively reported as the program 

analyzes the problem. Also, a status bar on the screen down of the ELPLA-Solver window 

displays information about the progress of calculation. 

 

 
Figure 11-35 Analysis progress menu 

 

Once the analysis is complete, a check menu of the solution appears, Figure 11-36. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 11-36 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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4 Viewing data and results 

 

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the 

three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed 

again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data 

is used only to define and view the data of the problem. ELPLA-Graphic is used to print data 

graphically while ELPLA-List is used to print data numerically.   

 

4.1 Viewing result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar 

of the sub programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic 

window appears, Figure 11-37. ELPLA-Graphic automatically opens the data file of the current 

example and displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 11-37 Opening screen of the sub program ELPLA-Graphic 

 

To view the results for pile groups as circular diagrams 

 

- Choose "Results as Circular Diagrams" command from "Graphic" menu of 

ELPLA-Graphic. The following option box in Figure 11-38 appears 

- In "Results as circular diagrams" option box, select "Settlements s" as a sample 

for the results to be displayed 

- Click "OK" button 

 

Settlements are now displayed as circular diagrams for piles as shown in Figure 11-39. 
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Figure 11-38 "Results as circular diagrams" option box 

 

 
Figure 11-39 Settlements as circular diagrams for piles 

 

4.2 Listing data and result in tables 

 

To list tables of data and results, switch to ELPLA-List. This is done by clicking on "List" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Section window. ELPLA-List 

window appears, Figure 11-40.  
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Figure 11-40 Opening screen of the sub program ELPLA-List 

 

The function of ELPLA-List is listing and printing data and results in tables. The data and results 

can be exported to other Windows applications to prepare reports or add further information. 

ELPLA-List automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-List window. 

 

Only one command of the "List" menu is explained here. In the same way, the user can carry out 

the remaining commands of the previous list. The commands of "Format" and "Window" menus, 

which are used to define the preferences of the tables such as page format, font, etc., are 

discussed in detail in the User’s Guide of ELPLA. 

 

To list results in a table 

 

- Choose "Display tables of results" command from "List" menu. The following option 

box in Figure 11-41 appears 

- In this option box, select "Pile results" as an example for the results to be listed in a table 

- Click "OK" button. The pile results are now listed on the screen (Figure 11-42) 

- Choose "Send to Word" from "File" menu if you wish to export the text to the MS Word 

application, Figure 11-43 
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Figure 11-41 "Display tables of results" option box 

 

 
Figure 11-42 List of settlement results 
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Figure 11-43 Exported results in MS Word 
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