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Analysis of piled raft
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1

Description of the problem

An example of piled raft is selected to illustrate some of the essential features of ELPLA for
analyzing piled raft.
1.1

Load and dimensions

A raft on 42 bored piles is considered as shown in Figure 12-1. All piles are equal in diameter
and length where pile diameter is 0.9 [m] while pile length is 20 [m]. Spacing between piles is
3.5 [m]. It is required to analyze the raft with piles as piled raft foundation due to a uniform load
of p = 150 [kN/m] acting on the raft.

24.5 [m]

Figure 12-1
1.2

Plan with piled raft geometry

Raft material and thickness

Raft material and thickness are supposed to have the following parameters:
Raft thickness
Young's modulus
Unit weight
Poisson's ratio
1.3

d
Eb
b
b

= 1.5
= 3.4 * 107
= 25
= 0.2

[m]
[kN/m2]
[kN/m3]
[-]

Pile material

The pile material is supposed to have the following parameters:
Young's modulus
Unit weight

Eb
b

= 2.35 * 107 [kN/m2]
= 25
[kN/m3]
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1.4

Soil properties

The subsoil under the raft consists of a layer of silt with 50 [m] thickness, the water table level is 2
[m] below the ground surface. Foundation level is also 2 [m] below the ground surface. The soil is
supposed to have the following parameters:
Modulus of elasticity for loading
Modulus of elasticity for reloading
Unit weight
Poisson's ratio
1.5

Es
Ws
s
s

= 10000
= 10000
= 18
= 0.3

[kN/m2]
[kN/m2]
[kN/m3]
[-]

Mathematical model

In this example, the Modulus of compressibility method (method 7) is chosen to analyze the
piled raft. This Tutorial manual will not present the theoretical background of modeling the
problem. For more information concerning the method of analysis, a complete reference for the
soil models and numerical calculation methods are well documented in the User’s Guide of
ELPLA.

2

Creating the project

In this section, the user will learn how to create a project for analyzing a piled raft foundation.
The example will be processed step by step to show the possibilities and abilities of the program.
To enter the data of the example, follow the instructions and steps in the next paragraphs.
2.1

Calculation method

To create the project, start the sub program ELPLA-Data. Choose the "New project" command
from the "File" menu. The "Calculation method" wizard appears, Figure 12-2. This wizard will
guide you through the steps required to create the project. As shown in Figure 12-2, the first
form of the wizard is the "Analysis type" form. In this form, define the analysis type of the
problem where ELPLA can deal with different structural systems. As the analysis type is piled
raft, select "Analysis of piled raft" then click "Next" button to go to the next page.
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Figure 12-2

"Calculation method" wizard with "Analysis type" form

After clicking "Next" button, the "Calculation methods" form appears, Figure 12-3.
To define the calculation method
-

Select the calculation method "7-Modulus of compressibility (Elimination)"
Click "Next" button to go to the next form

Figure 12-3

"Calculation methods" form
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The next form is the "System symmetry" (Figure 12-4). In this form choose "Unsymmetrical
system" then click "Next" button.

Figure 12-4

"System symmetry" form

The last form of the wizard assistant contains the "Option" list, Figure 12-5. In this list, ELPLA
displays some of the available options corresponding to the used numerical model, which differ
from model to other. There isn’t any requested choices, so click the "Save" button.

Figure 12-5

"Options" list
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After clicking "Save" button, the "Save as" dialog box appears, Figure 12-6.
In this dialog box
-

-

Type a file name for the current project in the "File name" edit box. For example
type "Piled raft". ELPLA will use automatically this file name in all reading and
writing processes
Click "Save" button

Figure 12-6

"Save as" dialog box

ELPLA will activate the "Data" menu. In addition, the file name of the current project
[Piled raft] will be displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure
12-7. In the "Data" menu, the user can enter the remaining data of the project using the same
sequence of commands in this menu. The first command in the menu is "Calculation methods",
which has been already entered. Therefore, ELPLA has put the sign "√" beside this command,
Figure 12-7. ELPLA puts this sign beside the commands those the user has entered so that the
user can know which data were defined.
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Figure 12-7
2.2

ELPLA-Data after defining the calculation method

Project identification

To identify the project, choose "Project identification" command from "Data" menu of ELPLAData. The dialog box in Figure 12-8 appears.
In this dialog box
-

-

Type the following line to describe the problem in the "Title" edit box:
"Analysis of piled raft"
Type the date of the project in the "Date" edit box
Type "Tutorial Manual" in the "Project" edit box
Click "Save" button

Figure 12-8

"Project identification" dialog box
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2.3

FE-Net data

Choose "FE-Net data" command from "Data" menu of ELPLA-Data. The "FE-Net generation"
wizard appears as shown in Figure 12-9. This wizard will guide you through the steps required to
generate the FE-Net. As shown in Figure 12-9 the first form of the wizard is the "Slab type" form
which contains a group of templates of different shapes of nets. These net templates are used to
generate standard nets that have regular shapes. For the given problem, the foundation has a
rectangular shape.

Figure 12-9

"FE-Net generation" wizard with "Slab type" form

To generate the FE-Net
-

-

In the "Slab type" options, choose the rectangular slab option
In the "Rectangular slab" frame, enter the total length and width of the raft in the
corresponding edit boxes
Click "Next" button to go to the next form

After clicking "Next" in "FE-Net generation" wizard, the following "Generation type" form
appears, Figure 12-10. ELPLA can deal with various type of generations with triangle and/ or
rectangular elements. Choose the first type of rectangular elements. Then click "Next" button to
go to the next form.
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Figure 12-10 "Generation type" form
After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog
box in Figure 12-11 appears with default values of constant element size.
In this dialog box
-

In "Grid in x-direction" frame, type 14 in the "No. of grid spaces" edit box
In "Grid in y-direction" frame, type 12 in the "No. of grid spaces" edit box
Type 1.75 in the "Grid interval" edit box
Click "OK" button

Figure 12-11 "Grid definition" form
ELPLA will generate a FE-Net for a rectangular area of 24.5 [m] length and 21 [m] width with
square elements of 1.75 [m] each side. The following embedded program in Figure 12-12
appears with the generated net.
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Figure 12-12 FE-Net of a rectangular slab on the screen
After finishing the generation of the FE-Net, do the following two steps:
-

-

Choose "Save FE-Net" command from "File" menu in Figure 12-12 to save the data of
the FE-Net
Choose "Close FE-Net" command from "File" menu in Figure 12-12 to close the "FENet" embedded program and return to the main window of ELPLA-Data

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data"
menu of ELPLA-Data.
2.4

Element length of pile

To define the element length of pile, choose "Preferences" command from "Main data" menu of
ELPLA-Data. The "Preferences" dialog box in Figure 12-13 appears.
In this dialog box
-

Type 2 in the "Element length of pile" edit box
Click "Save" button
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Figure 12-13 "Preferences" dialog box
2.5

Piles

To define piles, choose "Piles" command from "Data" menu of ELPLA-Data. The following
embedded program in Figure 12-14 appears.

Figure 12-14 "Piles" embedded program
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Pile groups
To define pile groups that have the same diameter and length, choose "Pile groups" command
from "In Table" menu in Figure 12-14. When the "Pile" groups" command is chosen, the
following table in Figure 12-15 appears allowing you to define the pile diameter and length.

Figure 12-15 Defining pile groups
Pile material
To define pile material, choose "Pile material" command from "In Table" menu in Figure 12-14.
When the "Pile material" command is chosen, the following dialog box in Figure 12-16 appears.
In this dialog box
-

Type 25 in the "Unit weight of the pile concrete" edit box
Type 2.35E+07 in the "Modulus of elasticity of pile" edit box
Click "OK" button

Figure 12-16 "Defining element groups" dialog box
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Pile location
To define pile locations on the net
-

Choose "Select nodes" command from "Graphically" menu in Figure 12-14
Select nodes those have piles as shown in Figure 12-17
Choose "Add piles" command from "Graphically" menu in Figure 12-17. The "Defining
pile groups" dialog box in Figure 12-18 appears. In this dialog box click "OK" button

Figure 12-17 Selection of nodes that have piles

Figure 12-18 "Defining pile groups" dialog box
After you have completed the definition of the piles, the screen should look like the following
Figure 12-19.
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Figure 12-19 Piles on the screen
After entering all data of piles, do the following two steps:
-

-

Choose "Save piles" command from "File" menu in Figure 12-19 to save the data
of piles
Choose "Close piles" command from "File" menu in Figure 12-19 to close the
ELPLA-Piles sub program and to return to the main window of ELPLA-Data

Note that the sign "√" is typed automatically beside the "Piles" command in the "Data" menu of
ELPLA-Data.
2.6

Soil properties

To define the soil properties, choose "Soil properties" command from "Data" menu of ELPLAData. The following sub program in Figure 12-20 appears with a default-boring log.
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Figure 12-20 ELPLA-Boring sub program with a default-boring log
To enter the soil properties for the boring log of the current example
-

Choose "Soil data" command from "Data" menu in the window of Figure 12-20.
The following dialog box in Figure 12-21 appears with default-boring log data.

Figure 12-21 "Soil data" dialog box with default-boring log data
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In the "Geotechnical data of the layer" dialog group box in Figure 12-21, define the geotechnical
data of the first soil layer of the boring log as follows:
Es
Ws
γs
νs

= 10000
= 10000
= 18
= 0.3

[kN/m2]
[kN/m2]
[kN/m3]
[-]

In the current example, the angle of internal friction φ and the cohesion c of the soil are not
required because the selected type of the analysis is linear analysis. Therefore, the user can let the
default values of the internal friction and the cohesion.
φs
c

= 30
=0

[˚]
[kN/m2]

Due to the presence of the ground water, the soil above the ground water level has a deferential
unit weight from the soil under that level. Therefore, the layer depth of the first layer is taken to
be 2 [m], which is equal to the ground water level. Now, type this value in "Layer depth under
the ground surface" edit box.
In order to draw the soil layers by different symbols according to the German Standard DIN
4023, the soil type and color for each layer must be defined.
To define the soil type and color for the first layer, select "U, Silt" as the soil type in "Main soil
type 1" combo box in "Soil and rock symbols" dialog group box, Figure 12-21. The color of the
silt according to the German Standard DIN 4023 will be automatically created. The user can
change this color. Also, a short text "U" will be automatically created for the silt.
To enter the second layer
-

-

-

-

Click "Layer copy" button in Figure 12-21. A layer that has the same properties of
the first layer will be copied
Use the vertical scrollbar to move to the second soil layer.
Layer No. will be typed automatically at the upper-left corner of the main dialog box of
soil layers as a head title
Change the value of the unit weight of the soil for the second soil layer from 18 [kN/m3]
to 9 [kN/m3]
Change the value of the layer depth under the ground surface from 2 [m] to 50 [m]

Note that the unit weight of the soil is used to determine the overburden pressure qv [kN/m2] due
to the removed soil, which is equal to γs * df. This means that the unit weight of the soil under the
foundation depth df is not required. However, the unit weight of the soil under the foundation depth
for all soil layers is entered by the value 9 [kN/m3].
After editing the geotechnical data, the boring coordinates and labels which describe the boring
will be entered.
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To enter the boring coordinates and label
-

Type 0 for x-coordinate in "x-coordinate of boring log [m]" edit box
Type 0 for y-coordinate in "y-coordinate of boring log [m]" edit box
Type B1 as a label name for the first boring in "Label of boring log" edit box

To enter the main soil data for all layers, choose "Main soil data" command from "Data" menu in
Figure 12-20. The following dialog box in Figure 12-22 appears with default main soil data. The
main soil data for the current example, which are required to be defined, are the settlement
reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other
data corresponding to main soil data are not required in this example. Therefore, the user can
take these data from the default soil properties.
In the dialog box of Figure 12-22, enter the settlement reduction factor α [-] and the groundwater
depth under the ground surface Gw [m]. Then click "OK" button.

Figure 12-22 "Main soil data" dialog box
Now all data and parameters for the boring log have been entered. After finishing the creation of
the boring log, click "OK" button in "Soil data" dialog box in Figure 12-21 to see the defined
boring log on the screen where the user can control or modify the input data and parameters,
Figure 12-23.
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Figure 12-23 Boring log on the screen
After entering all data and parameters of the boring log, do the following two steps:
-

-

Choose "Save boring logs" command from "File" menu in Figure 12-23 to save
the data of boring log
Choose "Close boring logs" command from "File" menu in Figure 12-23 to close the
ELPLA-Boring sub program and to return to the main window of ELPLA-Data

Note that the sign "√" is typed automatically beside the "Soil properties" command in the "Data"
menu of ELPLA-Data.
2.7

Foundation properties

To define the foundation properties, choose "Foundation properties" command from "Data"
menu of ELPLA-Data. The following embedded program in Figure 12-24 appears with default
foundation properties. The data of foundation properties for the current example, which are
required to define, are foundation material and foundation thickness. Any other data
corresponding to foundation properties in the program menus are not required. Therefore, the
user can take these data from the default foundation properties.
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Figure 12-24 "Foundation properties" embedded program
To enter the foundation material and thickness
-

-

Choose "Element groups" command from "In Table" menu in the window of
Figure 12-24. The following list box in Figure 12-25 with default data appears.
To enter or modify a value in this list box, type that value in the corresponding
cell then press "Enter" key. In the list box of Figure 12-25, enter E-Modulus of the
foundation, Poisson’s ratio of the foundation and foundation thickness
Click "OK" button

Figure 12-25 "Defining element groups" list box
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To enter the unit weight of the foundation
-

-

Choose "Unit weight of the foundation" command from "Foundation properties"
menu in the window of Figure 12-24. The following dialog box in Figure 12-26
with a default unit weight of 25 [kN/m3] appears. Let the default value as written
in the edit box "Unit weight of the foundation"
Click "OK" button

Figure 12-26 "Unit weight of the foundation" dialog box
To enter the foundation level
-

-

Choose "Foundation depth" command from "Foundation properties" menu in the
window of Figure 12-24. The following dialog box in Figure 12-27 appears
In this dialog box type 2 in the "Foundation depth under ground surface (a)/ (b)" edit box
Click "OK" button

Figure 12-27 "Foundation depth" dialog box
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After entering the foundation properties, do the following two steps:
-

-

Choose "Save foundation properties" command from "File" menu in Figure 12-24
to save the foundation properties
Choose "Close foundation properties" command from "File" menu in Figure 12-24
to close the "Foundation properties" embedded program and to return to the main
window of ELPLA-Data

Note that the sign "√" is typed automatically beside the "Foundation properties" command in the
"Data" menu of ELPLA-Data.
2.8

Loads

To define the loads, choose "Loads" command from "Data" menu of ELPLA-Data. The
following embedded program in Figure 12-28 appears.

Figure 12-28 "Loads" embedded program
To enter loads
-

Choose "Distributed load (rectangular)" command from "Graphically" menu in
the window of Figure 12-28. When "Distributed loads (rectangular)" command is
chosen, the cursor is changed from an arrow to a cross hair. Then, the load can be
defined by holding the left mouse button down at the starting point of the
distributed load. As the mouse is dragged, a box appears, indicating a distributed
load is being defined. When the left mouse button is released, the following
dialog box in Figure 12-29 appears with the load value and coordinates
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In this dialog box
-

Type 150 in the "Load value" edit box
Modify the load coordinate
Click "OK" button

Figure 12-29 "Distributed loads p" list box
After you have completed the definition of all load data, the screen should look like the
following Figure 12-30.
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Figure 12-30 Loads on the screen
After finishing the definition of load data, do the following two steps:
-

Choose "Save loads" command from "File" menu in Figure 12-30 to save the load data
Choose "Close loads" command from "File" menu in Figure 12-30 to close the
"Loads" embedded program and return to the main window of ELPLA-Data.

Note that the sign "√" is typed automatically beside the "Loads" command in the "Data" menu of
ELPLA-Data.
Creating the project of the raft is now complete. It is time to analyze this project. In the next
section you will learn how to use ELPLA for analyzing projects.

3
3.1

Carrying out the calculations
Starting ELPLA-Solver

To analyze the problem, leave ELPLA-Data to ELPLA-Solver. This is done by clicking on
"Solver" in the menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then,
ELPLA-Solver window appears, Figure 12-31.
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Figure 12-31 Opening screen of the sub program ELPLA-Solver
ELPLA-Solver automatically opens the data file of the current example and displays the data file
name in the title bar of ELPLA-Solver window. The "Calculation" menu contains commands of
all calculations. Commands of calculation depend on the used calculation method in the analysis.
For this project, the items that are required to be calculated are:
-

Assembling the load vector
Determining flexibility coefficients of the soil
Assembling the soil stiffness matrix
Assembling the slab stiffness matrix
Solving the system of linear equations (unsymmetrical matrix)
Determining deformation, internal forces, contact pressures

These calculation items can be carried out individually or in one time.
3.2

Carrying out all computations

To carry out all computations in one time, choose "Computation of all" command from
"Calculation" menu in ELPLA-Solver window. The analysis progress menu in Figure 12-32
appears in which various phases of calculation are progressively reported as the program
analyzes the problem. Also, a status bar on the screen down of the ELPLA-Solver window
displays information about the progress of calculation.
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Figure 12-32 Analysis progress menu
Once the analysis is complete, a check menu of the solution appears, Figure 12-33. This menu
compares between the values of actions and reactions. Through this comparative examination,
the user can assess the calculation accuracy.

Figure 12-33 Menu "Check of the solution"
To finish analyzing the problem, click "OK" button.

4

Viewing data and results

ELPLA can view and print a wide variety of results in graphics, diagrams or tables through the
three sub programs ELPLA-Graphic, ELPLA-Section and ELPLA-List. Data can also be viewed
again and printed by the sub programs ELPLA-Graphic and ELPLA-List. Note that ELPLA-Data
is used only to define and view the data of the problem. ELPLA-Graphic is used to print data
graphically while ELPLA-List is used to print data numerically.
4.1

Viewing result graphics

To view the data and results of a problem that has already been defined and analyzed graphically,
leave ELPLA-Solver to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar
of the sub programs at the upper-right corner of ELPLA-Solver window.
ELPLA-Graphic window appears, Figure 12-34. ELPLA-Graphic automatically opens the data
file of the current example and displays the data file name in the title bar of ELPLA-Graphic
window.
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Figure 12-34 Opening screen of the sub program ELPLA-Graphic
To view the results for the raft as contour lines
-

-

-

Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic.
The following option box in Figure 12-35 appears
In "Results as contour lines" option box, select "Settlements s" as a sample for the
results to be displayed
Click "OK" button

The settlements are now displayed as contour lines for the raft as shown in Figure 12-36.

Figure 12-35 "Results as contour lines" option box
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Figure 12-36 Settlements as contour lines for the raft
4.2

Plot a diagram of the results

To plot a diagram of the results, leave ELPLA-Graphic to ELPLA-Section. This is done by
clicking on "Section" in the menu bar of the sub programs at the upper-right corner of ELPLAGraphic window. ELPLA-Section automatically opens the data file of the current example and
displays the data file name in the title bar of ELPLA-Section window.
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Figure 12-37 Opening screen of the sub program ELPLA-Section
Only the first command of the "Sections" menu is explained here. In the same way, the user can
carry out the remaining commands of the previous list. The commands of "Options", "Format"
and "Window" menus, which are used to define the preferences of the drawing such as plot
parameters, scale, font, etc., are discussed in detail in the User’s Guide of ELPLA.
To plot a section in x-direction
-

-

-

Choose "Section in x-direction" command from "Sections" menu.
The following option box in Figure 12-38 appears
In the "Section in x-direction" option box, select "Settlements s" as an example for the
results to be plotted in a diagram
Click "OK" button

Figure 12-38 "Section in x-direction" option box
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The following option box in Figure 12-39 appears to specify the section in x-direction that is
required to be plotted.
In this dialog box
-

-

Type 10.5 in the "Section at y-coordinate" edit box to plot a diagram at the middle
of the raft
Click "OK" button

The settlements are now plotted in a diagram at the middle of the raft as shown in Figure 12-40.

Figure 12-39 "Section in x-direction" dialog box
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Figure 12-40 Diagram of settlements in x-direction at the middle of the raft
4.3

Listing data and result in tables

To list tables of data and results, switch to ELPLA-List. This is done by clicking on "List" in the
menu bar of the sub programs at the upper-right corner of ELPLA-Section window. ELPLA-List
window appears, Figure 12-41.

12-31

ELPLA-Tutorial

Figure 12-41 Opening screen of the sub program ELPLA-List
The function of ELPLA-List is listing and printing data and results in tables. The data and results
can be exported to other Windows applications to prepare reports or add further information.
ELPLA-List automatically opens the data file of the current example and displays the data file
name in the title bar of ELPLA-List window.
Only one command of the "List" menu is explained here. In the same way, the user can carry out
the remaining commands of the previous list. The commands of "Format" and "Window" menus,
which are used to define the preferences of the tables such as page format, font, etc., are
discussed in detail in the User’s Guide of ELPLA.
To list results in tables
-

-

Choose "Display tables of results" command from "List" menu.
The following option box in Figure 12-42 appears
In this option box, select "Pile results" as an example for the results to be listed in a table
Click "OK" button. The pile results are now listed on the screen (Figure 12-43)
Choose "Send to Word" from "File" menu if you wish to export the text to the MS Word
application, Figure 12-44

12-32

ELPLA-Tutorial

Figure 12-42 "Display tables of results" option box

Figure 12-43 List of pile results
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Figure 12-44 Exported results in MS Word
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