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Analysis of a slab floor

ELPLA-Tutorial

Contents

Page

1

Description of the problem
1.1
Loads and dimensions
1.2
Slab material
1.3
Analysis and concrete design

3
3
3
4

2

Creating the project
2.1
Calculation method
2.2
Project identification
2.3
FE-Net data
2.4
Girders
2.5
Supports/ Boundary conditions
2.6
Slab properties
2.7
Reinforcement data
2.8
Loads

4
4
7
8
12
16
20
21
23

3

Carrying out the calculations
3.1
Starting ELPLA-Solver
3.2
Carrying out all computations

25
25
26

4

Viewing data and result graphics

27

5

Index

30

2-2

ELPLA-Tutorial

1

Description of the problem

An example of a slab floor with girders is selected to illustrate some features of ELPLA for
analyzing slab floors.
1.1

Loads and dimensions

The slab floor has a thickness of 10 [cm] and carries uniform loads with different intensities as
shown in Figure 2-1. All girders have the same dimensions of 15 [cm] * 60 [cm]. Own weight of
the girder may be taken as 1.875 [kN/m].
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Figure 2-1
1.2
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3

Dimensions of the slab with loads

Slab material

Material of the slab is concrete (C 30/37) that has the following parameters:
Young's modulus of concrete
Poisson's ratio of concrete
Unit weight of concrete
Shear modulus of concrete

Eb
vb
γb
Gb = 0.5 Eb (1+ vb)

= 3.2 * 107
= 0.20
= 25
= 1.3 * 107

[kN/m2]
[-]
[kN/m3]
[kN/m2]
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1.3

Analysis and concrete design

The concrete sections are designed according to EC2 code for the following parameters:
Concrete grade
C 30/37
Steel grade
BSt 500
Characteristic compressive cylinder strength of concrete fck
Characteristic tensile yield strength of reinforcement fyk
Partial safety factor for concrete strength γc
Design concrete compressive strength fcd = fck/ γc
Partial safety factor for steel strength γs
Design tensile yield strength of reinforcing steel fyd = fyk/ γs

= 30
= 500
= 1.5
= 30/1.5 = 20
= 1.15
= 500/1.15 = 435

[MN/m2]
[MN/m2]
[-]
[MN/m2]
[-]
[MN/m2]

This Tutorial Manual will not present the theoretical background of modeling the problem. For
more information concerning the method of analysis, a complete reference for numerical
calculation methods is well documented in the User’s Guide of ELPLA.

2

Creating the project

In this section the user will learn how to create a project for analyzing a slab floor. The example
will be processed step by step to show the possibilities and abilities of the program. To enter the
data of the example, follow the instructions and steps in the next paragraphs.
2.1

Calculation method

To create the project start the sub program ELPLA-Data and choose "New project" command
from "File" menu. The "Calculation method" wizard appears, Figure 2-2. As shown in this
Figure, the first form of the wizard is the "Analysis type" form.

Figure 2-2

"Calculation method" wizard with "Analysis type" form
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In the "Analysis type" form in Figure 2-2, define the analysis type of the problem where ELPLA
can deal with different structural systems. As the analysis type is a slab floor problem, select
"Analysis of slab floor" then click "Next" button to go to the next form. The next form is the
"System symmetry", Figure 2-3.
In this form
-

Choose "Unsymmetrical system"
Click "Next" button

Figure 2-3

"System symmetry" form

The last form of the wizard assistant contains the "Option" list, Figure 2-4. In this list, ELPLA
displays some of the available options corresponding to the used numerical model, which differ
from model to other.
In this list
-

Check "Supports/ Boundary conditions" check box
Check "Slab with girders" check box
Check "Concrete design" check box
Click "Save" button
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Figure 2-4

"Options" list

After clicking "Save" button, the "Save as" dialog box in Figure 2-5 appears. In this dialog box
-

-

Type a file name for the current project in the file name edit box. For example type
"Floor". ELPLA will use automatically this file name in all reading and writing processes
Click "Save" button to complete the definition of the calculation method and the file
name of the project

Figure 2-5

"Save as" dialog box

ELPLA will activate the "Data" menu. Also the file name of the current project [Floor] will be
displayed instead of the word [Untitled] in the ELPLA-Data title bar, Figure 2-6.
In the "Data" menu, the user can enter the remaining data of the project using the same sequence
of commands in this menu. The first command in the menu is "Calculation methods", which has
been already entered. Therefore, ELPLA has put the sign "√" beside this command, Figure 2-6.
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ELPLA puts this sign beside the commands those the user has entered so that the user can know
which data were defined.

Figure 2-6
2.2

ELPLA-Data after defining the calculation method

Project identification

To identify the project choose "Project identification" command from "Data" menu of ELPLAData. The dialog box in Figure 2-7 appears.
In this dialog box
-

-

To describe the problem type the following line in the "Title" edit box:
"Analysis of a slab floor"
Type the date of the project in the "Date" edit box
Type "Slab floor" in the "Project" edit box
Click "Save" button

Figure 2-7

"Project identification" dialog box
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2.3

FE-Net data

For the given problem, the slab has irregular shape and is divided into 7 * 6 elements. Element
size in both x- and y-directions is 1.0 [m] as shown in Figure 2-1. ELPLA has different
procedures for defining the same problem. The easy procedure to define the FE-Net of this slab
is generating a mesh for the entire area first and then removing the unnecessary nodes to get the
slab shape.
To define the FE-Net for this slab, choose "FE-Net data" command from "Data" menu. The "FENet generation" wizard appears as shown in Figure 2-8. This wizard will guide you through the
steps required to generate the FE-Net. As shown in Figure 2-8, the first form of the wizard is the
"Slab type" form which contains a group of templates of different shapes of nets. These net
templates are used to generate standard nets that have constant size in both x- and y-directions.
To generate the FE-Net
-

Choose the rectangular slab option in the "Slab type" options
Type 7 in the "Length of rectangular slab" edit box
Type 6 in the "Width of rectangular slab" edit box
Click "Next" button to go to the next form

Figure 2-8

"FE-Net generation" wizard with "Slab type" form

After clicking "Next" in the "Slab type" form, the following "Generation type" form appears,
Figure 2-9. ELPLA can deal with various types of generation with triangle and/ or rectangular
elements.
In the "Generation type" form
-

Choose rectangular elements
Click "Next"
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Figure 2-9

"Generation type" form

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog
box in Figure 2-10 appears with default values of constant element size.
In this dialog box
-

In "Grid in x-direction" frame, type 7 in the "No. of grid spaces" edit box
In "Grid in y-direction" frame, type 6 in the "No. of grid spaces" edit box
Click "Finish" button

ELPLA will generate a FE-Net for a rectangular slab of 7 [m] length and 6 [m] width with square
elements of 1.0 [m] each side. The following embedded program in Figure 2-11 appears with the
generated net.

Figure 2-10

"FE-Net generation" dialog box
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Figure 2-11

FE-Net of a rectangular slab on the screen

Deleting nodes from the FE-Net
To select the unnecessary nodes, that are required to be removed from the net, first choose
"Select nodes" command from the "Graphically" menu in Figure 2-12. When "Select nodes"
command is chosen, the cursor will change from an arrow to a cross hair. The command
"Remove nodes" in the menu "Graphically" will be enabled, indicating the mode in which is
being operated. Next, select the required nodes by clicking on each node individually or selecting
a group of nodes as shown in Figure 2-12. A group of nodes can be selected by holding the left
mouse button down at the corner of the region. Then, drag the mouse until a rectangle
encompasses the required group of nodes. When the left mouse button is released, all nodes in
the rectangle are selected.

2-10

ELPLA-Tutorial

Figure 2-12

Generated FE-Net after selecting the unnecessary nodes

To remove the selected nodes, choose "Remove nodes" command from the "Graphically" menu.
The action of this command is indicated in Figure 2-13. To leave the graphic mode, press "Esc"
key.

Figure 2-13

Final FE-Net after deleting the unnecessary nodes
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After finishing the generation of the FE-Net, do the following two steps:
-

-

2.4

Choose "Save FE-Net" command from "File" menu in Figure 2-13 to save the data of the
FE-Net
Choose "Close FE-Net" command from "File" menu in Figure 2-13 to close "FE-Net"
embedded program and to return to the main window of ELPLA-Data
Girders

To define the girders choose "Girders" command from "Data" menu of ELPLA-Data. The
following embedded program in Figure 2-14 appears.

Figure 2-14

"Girders" embedded program

To enter the cross section of the girders
-

-

-

Choose "Girder groups" command from "In Table" menu in Figure 2-14. The following
option box in Figure 2-15 appears
In this option box, select the option of cross section definition. Although the cross section
of the girder must be defined whether it is T or L girder type, but for simplicity a
rectangular cross section is chosen in this example to define the girder cross section
Click "OK" button
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Figure 2-15

"Cross section definition" option box

After clicking "OK" button in the "Cross section definition" option box, the following list box in
Figure 2-16 appears.
In this list box
-

-

Enter the material properties of the girder, cross section dimensions and the girder weight
as indicated in Figure 2-16. This is done by entering the value in the corresponding cell
and press "Enter" button
Click "OK" button

Figure 2-16

"Defining girder groups" list box

Defining the girder locations on the net
Defining girder locations on the net may be carried out either graphically or numerically (in a
table). In the current example the user will learn how to define girder locations on the net
graphically.
To define the girder locations on the net graphically
-

-

Choose "Add girders" command from the "Graphically" menu in Figure 2-14. When
"Add girders" command is chosen, the cursor will change from an arrow to a cross hair
Click the left mouse button on the start node of the first girder. Then drag the mouse until
the end node of that girder (Figure 2-17) and click on the end node. The "Girder
elements" dialog box in Figure 2-18 appears
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Figure 2-17

Add girder by mouse

In this dialog box click "OK" button.

Figure 2-18

"Girder elements" dialog box

Now, the first girder is defined as shown in Figure 2-19. Note that ELPLA has already typed 1 on
the girder indicating the No. of girder group.
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Figure 2-19

First girder on the screen

Repeat the previous steps to add the remaining girders on the net. After you have completed the
definition of all girders, the screen should look like the following Figure 2-20.

Figure 2-20

Girders on the screen
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After entering all data and parameters of girders, do the following two steps:
-

-

2.5

Choose "Save girders" command from "File" menu in Figure 2-20 to save the data of
girders
Choose "Close girders" command from "File" menu in Figure 2-20 to close the "Girders"
embedded program and to return to the main window of ELPLA-Data
Supports/ Boundary conditions

In general, columns under the slab are considered as rigid supports. These supports are defined
by the "Supports/ Boundary conditions" command. To define supports choose "Supports/
Boundary conditions" command from "Data" menu of ELPLA-Data. The following embedded
program in Figure 2-21 appears.

Figure 2-21

"Supports/ Boundary conditions" embedded program

ELPLA can display girders, supports, loads, etc. in one view together. The advantage of this
option is that the user can control easily locations of supports or loads on the net when entering
the rest of the data.
To view the girder on the FE-Net when defining the other data
-

-

Choose "View grouping" command from "Option" Menu in Figure 2-21. The "View
grouping" check group box in Figure 2-22 appears
In this check group box, check "Girders" check box
Click "OK" button
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Figure 2-22

"View grouping" check group box

After clicking "OK" in the "View grouping" check group box, the screen should look like the
following Figure 2-23.

Figure 2-23

Girders in the window of the "Supports/ Boundary conditions" embedded program

Defining supports on the net
Defining supports or boundary conditions on the net may be carried out either graphically or
numerically (in a table). In the current example the user will learn how to define supports on the
net graphically.
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To define supports on the net
-

-

Choose "Select nodes" command from the "Graphically" menu in Figure 2-23. When
"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair
Click the left mouse button on nodes that have supports as shown in Figure 2-23
After selecting nodes of supports, choose "Add boundaries" command from
"Graphically" menu (Figure 2-23). The "Supports/ Boundary conditions" dialog box in
Figure 2-25 appears

In this dialog box
-

Type 0 in the "Displacement w" edit box to define a rigid support
Click "OK" button

ELPLA can calculate the punching stresses due to reactions of column supports. In this example,
data corresponding to column dimensions are not required. Therefore, the user can take these
data from the default column dimensions and consider all supports have column type 1.

Figure 2-24

Selection of nodes that have supports
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Figure 2-25

"Supports/ Boundary conditions" dialog box

After you have completed the definition of the supports, the screen should look like the
following Figure 2-26.

Figure 2-26

Supports on the screen
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After entering supports, do the following two steps:
-

-

2.6

Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 2-26
to save the data of supports
Choose "Close supports/ Boundary conditions" command from "File" menu in Figure
2-26 to close the "Supports/ Boundary conditions" embedded program and to return to
the main window of ELPLA-Data
Slab properties

To define the slab properties choose "Slab properties" command from "Data" menu of ELPLAData. The following embedded program in Figure 2-27 appears with default slab properties. The
data of slab properties for the current example, which are required to define, are raft material and
slab thickness.

Figure 2-27

"Slab properties" embedded program

To enter the slab material and thickness
-

-

Choose "Element groups" command from "In Table" menu in the window of Figure 2-27.
The following list box in Figure 2-28 with default data appears. To enter or modify a
value in this list box, type that value in the corresponding cell and then press "Enter" key.
In the list box of Figure 2-28, enter E-Modulus of the slab, Poisson’s ratio of the slab and
slab thickness
Click "OK" button
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Figure 2-28

"Defining element groups" list box

To enter the unit weight of the slab
-

-

Choose "Unit weight of the slab" command from "Slab properties" menu in the
window of Figure 2-27. The following dialog box in Figure 2-29 with a default unit
weight of 25 [kN/m3] appears
Click "OK" button

Figure 2-29

"Unit weight of the slab" dialog box

After entering the slab properties, do the following two steps:
-

-

2.7

Choose "Save slab properties" command from "File" menu in Figure 2-27 to save the slab
properties
Choose "Close slab properties" command from "File" menu in Figure 2-27 to close the
"Slab properties" embedded program and to return to the main window of ELPLA-Data
Reinforcement data

The reinforcement of the slab can be carried out according to the design codes EC 2, DIN 1045,
ACI and ECP (working stress and limit state design methods). In the current example, the
concrete sections of the slab are designed according to EC 2 for Concrete grade C 30/37 and
Steel grade BSt 500. The concrete cover for the slab may be taken as (Figure 2-30):
Top concrete cover +1/2 bar diameter in x-direction
Bottom concrete cover +1/2 bar diameter in x-direction
Top concrete cover +1/2 bar diameter in y-direction
Bottom concrete cover +1/2 bar diameter in y-direction

d1x = 1.5
d2x = 1.5
d1y = 2
d2y = 2

[cm]
[cm]
[cm]
[cm]
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As,topx
d1x

d1y
As,topy

d
d2x

As,boty
d2y
As,botx

Figure 2-30

Section geometry and reinforcement parallel to x-direction

It is important to say that the design code parameters such as partial safety factors for concrete
strength, steel strength and internal forces are defined by choosing the "Design code parameters"
command from "Main data" menu in ELPLA-Data, while reinforcement data such as design
code, concrete grade, steel grade and concrete covers are defined by choosing the
"Reinforcement" command from "Data" menu in ELPLA-Data. Design code parameters are
standard data for all projects while reinforcement data may be varied from one project to another.
To define the reinforcement data choose "Reinforcement" command from "Data" menu of
ELPLA-Data. The dialog box in Figure 2-31 appears with default reinforcement data.

Figure 2-31

"Reinforcement" dialog box

In this dialog box
-

Select design code "EC 2" in the "Design code" combo box
Select steel grade "BSt 500" in the "Steel grade" option box
Select concrete grade "C 30/37" in the "Concrete grade" option box
Select the default concrete covers as indicted in the "Concrete cover" dialog group box
Click "Save" button
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2.8

Loads

To define the loads choose "Loads" command from "Data" menu of ELPLA-Data. The following
embedded program in Figure 2-32 appears with girders on the net.

Figure 2-32

"Loads" embedded program

Defining loads on the net may be carried out either graphically or numerically (in a table). In the
current example the user will learn how to define loads on the net graphically.
To enter the first distributed loads
-

Choose "Distributed loads" command from "Graphically" menu in the window of Figure
2-32. When "Distributed loads" command is chosen, the cursor is changed from an arrow
to a cross hair. Then the load can be defined by holding the left mouse button down at the
starting point of the distributed load. As the mouse is dragged, a box appears, indicating a
distributed load is being defined. When the left mouse button is released, the following
dialog box in Figure 2-33 appears with the load value and coordinates

In this dialog box
-

Type 3.5 in the "Load value" edit box
Click "OK" button
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Figure 2-33

"Loading" dialog box

After you have completed the definition of the first distributed load, the screen should look like
the following Figure 2-34.

Figure 2-34

First distributed load on the screen
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Repeat the previous steps to enter the remaining distributed loads on the net. After you have
completed the definition of all loads on the net, the screen should look like the following Figure
2-35.

Figure 2-35

Loads on the FE-Net

After finishing the definition of load data, do the following two steps:
-

Choose "Save loads" command from "File" menu in Figure 2-35 to save the load data
Choose "Close loads" command from "File" menu in Figure 2-35 to close the "Loads"
embedded program and to return to the main window of ELPLA-Data

Creating the project of the slab floor is now complete. It is time to analyze this project. In the
next section you will learn how to use ELPLA for analyzing projects.
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3
3.1

Carrying out the calculations
Starting ELPLA-Solver

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the
menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver
window in Figure 2-36 appears.

Figure 2-36

Opening screen of the sub program ELPLA-Solver

ELPLA-Solver automatically opens the data file of the current example and displays the data file
name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu.
This menu contains commands of all calculations. Commands of the calculation depend on the
analysis type. For the current example, the items, which are required to be calculated, are:
-

Assembling the load vector
Assembling the girder stiffness matrix
Assembling the slab stiffness matrix
Solving system of linear equations (band matrix)
Determining deformation, internal forces
Design of the slab

These calculation items can be carried out individually or in one time.
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3.2

Carrying out all computations

To carry out all computations in one time choose "Computation of all" command from
"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the
defined analysis will be carried out automatically with displaying information through menus
and messages.
Analysis progress
Analysis progress menu in Figure 2-37 appears in which various phases of calculation are
progressively reported as the program analyzes the problem. Also, a status bar on the screen
down of the ELPLA-Solver window displays information about the progress of calculation.

Figure 2-37

Analysis progress menu

Check of the solution
Once the analysis is carried out, a check menu of the solution in Figure 2-38 appears. This menu
compares between the values of actions and reactions. Through this comparative examination,
the user can assess the calculation accuracy.

Figure 2-38

Menu "Check of the solution"

To finish analyzing the problem, click "OK" button.
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4

Viewing data and result graphics

ELPLA can view the data and results for the slab and girders either separately or together.
Individual data or results for the slab can be viewed in a manner similar to that in the previous
example. Here, the user will learn to view the results of the girders through the following sample.
To view the data and results of a problem that has already been defined and analyzed graphically,
switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub
programs at the upper-right corner of ELPLA-Solver window.
ELPLA-Graphic window in Figure 2-39 appears. ELPLA-Graphic automatically opens the data
file of the current example and displays the data file name in the title bar of ELPLA-Graphic
window.

Figure 2-39

Opening screen of the sub program ELPLA-Graphic

To view the results of girders choose "Girders" command and then the "Distribution of internal
forces in the plan" command from "Graphic" menu of ELPLA-Graphic. The following option
box in Figure 2-40 appears.
In this option box
-

Select "Beam-Bending moments Mb" as a sample for the results to be displayed
Click "OK" button

The moments are now displayed for the girders as shown in Figure 2-41.
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Figure 2-41

"Distribution of internal forces in the plan" option box

Figure 2-41

Beam-Bending moments Mb

2-29

ELPLA-Tutorial

5

Index

A

I

Analysis type ............................................................... 4, 5

Internal forces ......................................................... 22, 26

B

L

Boundary conditions ............................................... 16, 18

Load vector ................................................................... 26
Loads ........................................................................ 3, 23

C
Calculation method ......................................................... 4
Check of the solution .................................................... 27
Computation of all......................................................... 27
Concrete design ............................................................... 4

M
Material properties ........................................................ 13

N
D

New project ..................................................................... 4

Deformation .................................................................. 26
Design codes ........................................................... 21, 22

P

E

Project identification ....................................................... 7

Element groups.............................................................. 21

R

F

Reinforcement ............................................................... 21
Remove nodes ......................................................... 10, 11

FE-Net ......................................................................... 8, 9

S
G
Generation type ............................................................... 8
Girder locations ............................................................. 13
Girders..................................................................... 12, 15

Select nodes .................................................................. 10
Slab properties .............................................................. 20
Supports ........................................................ 5, 16, 18, 20
System symmetry ............................................................ 5

U
Unit weight of the slab .................................................. 21

2-30

