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1 Description of the problem 

 

An example of a grid resting on 8 supports is selected to illustrate some features of ELPLA for 

analyzing grids. 

 

1.1 Loads and dimensions 

 

The grid consists of equal girders that have dimensions of 0.15 [cm] * 0.60 [cm]. Geometry of 

the grid and loads on it including the own weight are shown in Figure 4-1. 

 

 

P1 = 10 [kN/m]
P2 = 15 [kN/m]

4.0 [m]

3.0 [m]

2.0 [m]

1.0 [m]

3.0 [m]

P1

P1

P1

P1
P

1

P1

P1

P1

P2

P2

50 [kN]

 
 

 

Figure 4-1 Geometry of the grid and loads 

 

1.2 Grid material 

 

Material of the grid has the following parameters: 

 

Young's modulus Eb = 3.2 * 107  [kN/m2] 

Shear modulus Gb = 1.3 * 107  [kN/m2] 

 

1.3 Analysis of the grid 

 

It is required to analyze the grid using 1.0 [m] beam element in both x- and y-directions and 

considering the supports to be rigid in z-direction only. This Tutorial Manual will not present the 

theoretical background of modeling the problem. For more information concerning the method 

of analysis a complete reference for numerical calculation methods are well documented in the 

User’s Guide of ELPLA. 
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2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a grid. The example will 

be processed step by step to show the possibilities and abilities of the program. To enter the data 

of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose "New project" command from 

the "File" menu. The "Calculation methods" wizard appears, Figure 4-2. The wizard will guide 

you through the steps required to create the system data of the project. As shown in Figure 4-2, 

the first form of the wizard is the "Analysis type" form.  

 

 
Figure 4-2 "Calculation method" wizard with "Analysis type" form 

 

In Figure 4-2 define the analysis type of the problem where ELPLA can deal with different 

structural systems. As the analysis type is a grid problem, select "Analysis of grid". Then click 

"Next" button to go to the next form. 

 

The next form is the "System symmetry" (Figure 4-3). In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 
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Figure 4-3 "System symmetry" form 

 

The last form of the wizard assistant contains the "Option" list, Figure 4-4. In this list ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other. 

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 

 

 
Figure 4-4 "Options" list 
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After clicking "Save" button the "Save as" dialog box appears (Figure 4-5). 

 

In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Grid". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Grid] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 4-5 "Save as" dialog box 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data window. The dialog box in Figure 4-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title edit" box:  

"Analysis of a grid" 

- Type the date of the project in the "Date" edit box 

- Type "Grid" in the "Project edit" box 

- Click "Save" button 

 

 
Figure 4-6 "Project identification" dialog box 
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2.3 FE-Net data 

 

To enter the grid geometry, an imaginary net must be first defined with suitable dimensions and 

then the grid is entered lately by connecting the corresponding nodes on the net that defines the 

grid shape. To define the net for the grid geometry, choose "FE-Net data" command from "Data" 

menu. The "FE-Net generation" wizard appears as shown in Figure 4-7. This wizard will guide 

you through the steps required to generate the FE-Net. The first form of the wizard is the "Slab 

type" form which contains a group of templates of different shapes of nets. These net templates 

are used to generate standard nets that have constant size in both x- and y-directions. 

 

To generate an imaginary net 

 

- Choose the rectangular slab option to create an imaginary net of a rectangular area 

- Type 7 in the "Length of rectangular slab" edit box 

- Type 6 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 4-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard the following "Generation type" form 

appears, Figure 4-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 
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Figure 4-8 "Generation type" form 

 

After clicking "Next" button in "Generation type" form the following "Grid definition" dialog 

box in Figure 4-9 appears with default values of constant element size. 

 

 
Figure 4-9 "FE-Net generation" dialog box 

 

In this dialog box 

 

- In "Grid in x-direction" frame type 7 in the "No. of  grid spaces" edit box 

- In "Grid in y-direction" frame type 6 in the "No. of  grid spaces" edit box 

- Click "Finish" button 

 

ELPLA will generate an imaginary net for a rectangular area of 7 [m] length and 6 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 4-10 

appears with the generated imaginary net. 
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Figure 4-10 Imaginary net of a rectangular area on the screen 

 

After finishing generation of the imaginary net do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu to save the data of the imaginary net 

- Choose "Close FE-Net" command from "File" menu to close "FE-Net" embedded 

program and to return to the main window of ELPLA-Data 

 

2.4 Girders 

 

To define the girders, choose "Girders" command from "Data" menu of ELPLA-Data window. 

The following embedded program in Figure 4-11 appears. 
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Figure 4-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 4-11. The following 

option box in Figure 4-12 appears 

- In this option box select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 4-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box the following list box in 

Figure 4-13 appears. In this list box 

 

- Enter the material properties of the girder, cross section dimensions and the girder weight 

as indicated in Figure 4-13. This is done by entering the value in the corresponding cell 

and press "Enter" key. For simplicity, the line loads, which include the own weight of the 

girder, are entered in the cell "Girder weight". Here two groups of girders are defined, the 

first group for girders that have a line load of 10 [kN/m] while the second group for 

girders that have a line load of 15 [kN/m] 

- Click "OK" button 



 

 

ELPLA-Tutorial 

 

 

 4-11 

 
Figure 4-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

This may be carried out either graphically or numerically (in a table). In the current example the 

user will learn how to define girder locations on the net graphically. 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 4-11. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 4-14). Then click on the end node. The "Girder 

elements" dialog box in Figure 4-15 appears 

 

 
Figure 4-14 Add girder by mouse  
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In this dialog box 

 

- Select the group No 

- Click "OK" button 

 

 
Figure 4-15 "Girder elements" dialog box 

 

Now the first girder is defined as shown in Figure 4-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

 
Figure 4-16 First girder on the screen 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 4-17. 
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Figure 4-17 Girders on the screen 

 

After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 4-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 4-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data window. The following embedded program in Figure 4-18 appears. 
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Figure 4-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data.  As shown in Figure 4-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. 

The "Plot parameters" dialog box in Figure 4-19 appears 

- In the "General plot parameters" tab uncheck the "Draw thickness" check box in the 

"Girder systems" dialog box 

- Click  "OK" button 
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Figure 4-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box the girders are drawn as simple lines as 

shown in Figure 4-20. 

 

 
Figure 4-20 Girders are drawn in simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define supports on the net 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 4-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have supports as shown in Figure 4-21 

-  After selecting nodes of supports choose "Add boundaries" command from 

"Graphically" menu in Figure 4-21. "Supports/ Boundary conditions" dialog box in 

Figure 4-22 appears 

 

 
Figure 4-21 Selection of nodes that have supports 

 

In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define a rigid support 

- Click "OK" button 
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Figure 4-22 "Supports/ Boundary conditions" dialog box 

 

ELPLA can calculate the punching stresses due to column reactions. In this example data 

corresponding to column dimensions are not required. Therefore the user can take these data 

from the default column dimensions and consider all supports have column type 1. After you 

have completed the definition of supports, the screen should look like the following Figure 4-23. 

 

 
Figure 4-23 Supports on the screen 
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After entering supports, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 4-23 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure 4-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data 

window. The following embedded program in Figure 4-24 appears with girders on the net. 

 

 
Figure 4-24 "Loads" embedded program 

 

The vertical concentrated loads on the grid can be defined at any position (x, y) on the grid. The 

position of the load is independent on nodes of the net. 

 

To enter the concentrated load choose "Point loads" command from "Graphically" menu in the 

window of Figure 4-24. When "Point loads" command is chosen, the cursor is changed from an 

arrow to a cross hair. Then the load can be defined by clicking on the screen (grid). The 

following dialog box in Figure 4-25 appears with the load value and coordinates. 

 

In this dialog box 

 

- Type 50 in the "Load value" edit box 

- Click "OK" button 
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Figure 4-25 "Point loads P" dialog box 

 

After you have completed the definition of the concentrated load, the screen should look like the 

following Figure 4-26. 

 

 
Figure 4-26 Concentrated load on the screen 
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After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 4-26 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 4-26 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

Creating the project of the grid is now complete. See how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver by clicking on "Solver" in the menu bar of the 

sub programs at the upper-right corner of ELPLA-Data window (Figure 4-27). 

 

 
Figure 4-27 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also ELPLA will activate the "Calculation" 

menu. This menu contains commands of all calculations, which depend on the analysis type. For 

the current example the items, which are required to be calculated, are: 

 

- Assembling the load vector 

- Assembling the girder stiffness matrix 

- Assembling the slab stiffness matrix 

- Solving system of linear equations (band matrix) 

- Determining deformation, internal forces 
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These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 4-28 appears, in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 4-28 Analysis progress menu 

 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution in Figure 4-29 appears. This menu 

compares between the values of actions and reactions. Through this comparative examination, 

the user can assess the calculation accuracy. 

 

 
Figure 4-29 Menu "Check of the solution" 

 

To finish analyzing the problem, click "OK" button. 
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4 Viewing data and result graphics 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

4-30 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 4-30 Opening screen of the sub program ELPLA-Graphic 

 

To view the results of girders, choose "Girders" command and then "Internal forces in isometric 

view" command from "Graphic" menu of ELPLA-Graphic. The following option box in Figure 

4-31 appears. 

 

In this option box 

 

- Select "Beam-Bending moments Mb" as an example for the results to be displayed 

- Click "OK" button 

 

 
Figure 4-31 "Internal forces in isometric view" option box 

 

The moments are now displayed for the girders as shown in Figure 4-32. 
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Figure 4-32 Beam-Bending moments Mb 
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