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Plane stress analysis of a wrench  
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1 Description of the problem 

 

An example for analyzing stresses and deformations of a wrench is selected to illustrate some 

features of ELPLA for analyzing plane stress problems. 

 

1.1 Loads and dimensions 

 

The wrench shown in Figure 5-1 is 10 [mm] thick and about 200 [mm] in length. The wrench 

end is loaded with a pressure of 2 [N/mm] along 100 [mm] of its handle as shown.  

 

a

100 [mm]

2 [N/mm]

b

c

R = 10 [mm] 20 [mm]25 [mm]35 [mm]

45 [mm]

22.5 [mm]

45 [mm]

2.5 [mm]

32.5 [mm]

R =10 [ mm]

Thickness =10 [mm]

 

 

 

 

195 [mm]

R =30 [ mm]

 
 

Figure 5-1 Wrench dimensions and loads 

 

1.2 Wrench material 

 

Material of the wrench has the following parameters: 

 

Young's modulus Eb = 200000  [N/mm2] 

Poisson's ratio  νb = 0.3   [-] 

 

1.3 Analysis of the wrench 

 

It is required to analyze the stresses and deformations of the wrench when it is being used to 

tighten a bolt. Consider that there is no horizontal or vertical displacement along the lines where 

the wrench contacts the bolt. This Tutorial Manual will not present the theoretical background of 

modeling the problem. For more information concerning the method of analysis a complete 

reference for numerical calculation methods are well documented in the User’s Guide of ELPLA.  

 

1.4 System units 

 

Since the wrench dimensions are relatively small compared with those of foundations, it is 

preferred to use small units for measurement. To change the system units, choose "System of 

units" command from "Main data" menu of ELPLA-Data. The dialog box in Figure 5-2 appears. 

In this dialog box change the units for lengths and forces to [mm] and [N] respectively and then 

click "Save" button. 
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Figure 5-2 "System of units" dialog box 

 

Also ELPLA checks the element size when a mesh is generated. Since the element size of slab 

foundation is relatively large compared with those of a wrench, it is required to disable the 

element size check. To uncheck the element size when generating FE-Net, choose the 

"Preferences" command from "Main data" menu of ELPLA-Data. The dialog box in Figure 5-3 

appears. In this dialog box uncheck the "Check element size" option then click "Save" button. 

 

 
Figure 5-3 "Preferences" dialog box 

 

 

2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a plane stress problem. 

The example will be processed step by step to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation methods" wizard appears, Figure 5-4. The wizard will 

guide you through the steps required to create the system data of the project. As shown in this 

Figure, the first form of the wizard is the "Analysis type" form.  
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Figure 5-4 "Calculation method" wizard with "Analysis type" form  

 

In the "Analysis type" form in Figure 5-4, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a plane stress problem, select 

"Analysis of plane stress" option then click "Next" button to go to the next form.  

 

The next form is the "System symmetry" (Figure 5-5). In this form choose "Unsymmetrical 

system" and click "Next" button. 

 

The last form of the wizard assistant contains the "Option" list, Figure 5-6. In this list ELPLA 

displays some of the available options corresponding to the used numerical models, which differ 

from model to other. 

 

In this list check "Supports/ Boundary conditions" check box then click "Save" button. 

 



  

 

  ELPLA-Tutorial 

 

 

5-6 

 
Figure 5-5 "System symmetry" form 

 

 
Figure 5-6 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 5-7.  

 

In this dialog box, type a file name for the current project in the file name edit box. For example 

type "Wrench". ELPLA will use automatically this file name in all reading and writing processes. 

Then click "Save" button to complete the definition of the calculation method and the file name 

of the project. 

 

ELPLA will activate the "Data" menu. Also the file name of the current project [Wrench] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 
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Figure 5-7 "Save as" dialog box 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 5-8 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a Plane Stress Problem" 

- Type the date of the project in the "Date" edit box 

- Type "Wrench" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 5-8 "Project identification" dialog box 

 

2.3 FE-Net data 

 

To define the net for the wrench geometry, choose "FE-Net data" command from "Data" menu. 

The "FE-Net generation" wizard appears as shown in Figure 5-9. This wizard will guide you 

through the steps required to generate a FE-Net. The first form of the wizard is the "Slab type" 

form which contains a group of templates of different shapes of nets. These net templates are 

used to generate standard nets that have constant size in both x- and y-directions.  

 

To generate the FE-Net, choose the irregular slab option then click "Next" button to go to the 

next form. 
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Figure 5-9 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 5-10. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. In this form, choose the triangle elements option then click "Next". 

 

 
Figure 5-10 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "FE-Net generation" 

dialog box in Figure 5-11 appears with the default generation parameters. In this dialog box click 

"Finish" button. 
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Figure 5-11 "FE-Net generation" dialog box 

 

ELPLA will generate an imaginary net as shown in the following embedded program, Figure 5-

12. 

 

 
Figure 5-12 Imaginary net of a rectangular area on the screen 

 

You can either draw the wrench directly on this imaginary net or input the wrench corner points 

in tabulated form. To input the FE-Net corner points, choose "Slab corners" command from "In 

Table" menu. The dialog box in Figure 5-13 appears.  
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To define the first segment of the wrench which connects points a and b (Figure 5-1) 

 

- Type 45 in the "x1" edit box to define the x-coordinate of point a 

- Type 32.5 in the "y1" edit box to define the y-coordinate of point a 

- Type 190 in the "x2" edit box to define the x-coordinate of point b 

- Type 30 in the "y2" edit box to define the y-coordinate of point b 

 

 
Figure 5-13 "Slab corners" dialog box 

 

To define the second segment of the wrench which connects points b and c 

 

- Use the Scroll bar to define segment No. 2 

- Type 190 in the "x2" edit box to define the x-coordinate of point c 

- Type 10 in the "y2" edit box to define the y-coordinate of point c 

- Select the "Use arc data" option to convert the line segment to arc segment 

- Type 10 in the "Arc radius" edit box to define the radius of the arc segment 

 

In the "Slab corners" dialog box, ELPLA assumes that there are at least three segments with three 

corner points. Since the wrench drawing contains 11 segments, you can use the command 

"Segment insert" to insert the rest of the wrench segments. Use the corner points and arc 

information provided in Table 5-1 to complete the definition of the wrench corner points. Repeat 

the steps used for defining segment No. 1 to define any line segment and repeat those used for 

segment No. 2 to define any arc segment. 
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Table 5-1 Wrench Corner Points 

Segment 

 

[-] 

Start position  End position  Arc Radius 

 

[mm] 

x1 

[mm] 

y1 

[mm] 

x2 

[mm] 

y2 

[mm] 

1 45 32.5 190 30  

2 190 30 190 10 10 

3 190 10 45 7.5  

4 45 7.5 2.5 0 30 

5 2.5 0 0 5 10 

6 0 5 22.5 5  

7 22.5 5 32.5 20  

8 32.5 20 22.5 35  

9 22.5 35 0 35  

10 0 35 2.5 40 10 

11 2.5 40 45 32.5 30 

 

After completing the definition of the wrench corner points, the slab corner dialog box should be 

like this in Figure 5-14 where a small sketch of the wrench appears in the dialog box picture. 

Click the "OK" button to see the drawing of the wrench outlines as shown in Figure 5-15. 

 

 
Figure 5-14 "Slab corners" dialog box after defining the wrench corner points 
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Figure 5-15 Wrench outlines 

 

To complete the FE-Generation of the problem, choose "Generating FE-Net" command from 

"FE-Generation" menu. The following "Generation of FE-Net" dialog box appears. 

 
Figure 5-16 "Generation of FE-Net" dialog box 
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To enter the generation data 

 

- Type 4 in the "Element circumradius" edit box to define the radius of circles containing 

elements 

- Type 2 in the "Min. element circumradius" edit box to define the minimum radius of  

circles containing elements 

- Check the "Smoothing mesh" option to optimize the dimension of FE-Net by making all 

elements having nearly the same area as possible as 

- Click "OK" button 

 

After clicking the "OK" button, FE-Net generation progress menu in Figure 5-17 appears in 

which various phases of the generation are progressively reported. After finishing the generation 

of the FE-Net and creating the wrench FE-Net as shown in Figure 5-18, do the following two 

steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 5-18 to save the data of the 

FE-Net 

- Choose "Close FE-Net" command from "File" menu in Figure 5-18 to close the "FE-Net" 

embedded program and return to the main window of  ELPLA-Data 

 

Note that the sign "√" is typed automatically beside the "FE-Net data" command in the "Data" 

menu of ELPLA-Data. 

 

 
Figure 5-17 "FE-Net generation" progress menu 
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Figure 5-18 Final FE-Net of the wrench 

 

2.4 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 5-19 appears. 
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Figure 5-19 "Supports/ Boundary conditions" embedded program 

 

Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. Considering that there are no horizontal or vertical displacements along the lines 

where the wrench contacts the bolt, all constrains will be applied only to the upper and bottom 

jaws of the wrench. 

 

To define supports on the net 

 

- Choose the "Zoom window" command from the "Window" menu to zoom the wrench 

head 

- Choose "Select nodes" command from the "Graphically" menu in Figure 5-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nods that have supports as shown in Figure 5-20 

- After selecting nodes of supports, choose "Add boundaries" command from 

"Graphically" menu in Figure 5-20. "Supports/ Boundary conditions" dialog box in 

Figure 5-21 appears 
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Figure 5-20 Selection of nodes that have supports 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Click "OK" button 

 

 
Figure 5-21 "Supports/ Boundary conditions" dialog box 

 

After you have completed the definition of supports, the screen should look like the following 

Figure 5-22. 
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Figure 5-22 Supports on the screen 

 

After entering supports, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 5-22 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure 5-

22 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of  ELPLA-Data 

 

2.5 Slab properties 

 

To define the material properties, choose "Slab properties" command from "Data" menu. The 

following embedded program in Figure 5-23 appears with default slab properties. The data of 

material properties for the current example, which are required to be defined, are wrench 

material and wrench thickness. 

 

To enter the wrench material and thickness, choose "Element groups" command from "In Table" 

menu. The following list box in Figure 5-24 appears. In this list box, enter the E-Modulus and 

Poisson’s ratio of the wrench material and wrench thickness. Then, click "OK" button to go to 

the next step. 
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Figure 5-23 "Slab properties" embedded program 

 

 
Figure 5-24 "Defining element groups" list box  

 

To enter the unit weight of the wrench material, choose "Unit weight of slab material" command 

from "Slab properties" menu in the window of Figure 5-23. The following dialog box in Figure 

5-25 with a default unit weight of 25 [kN/m3] appears. To neglect the self-weight of the wrench 

in the analysis, type 0 in the "Unit weight of slab material" edit box then click "OK" button. 
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Figure 5-25 "Unit weight of slab material" dialog box  

 

After entering the wrench material properties, do the following two steps: 

 

- Choose "Save Slab properties" command from "File" menu in Figure 5-23 to save the 

foundation properties 

- Choose "Close Slab properties" command from "File" menu in Figure 5-23 to close the 

"Slab properties" embedded program and return to the main window of ELPLA-Data 

 

Note that the sign "√" is typed automatically beside "Slab properties" command in "Data" menu 

of ELPLA-Data. 

 

2.6 Loads 

 

To define the load applied to the wrench, choose "Loads" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 5-26 appears. 

 

 
Figure 5-26 "Loads" embedded program 
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In plane stress problems, loads can be applied to nodes only. In this example the line load 

applied to the wrench will be converted to vertical concentrated loads applied to the wrench FE-

Net nodes. 

 

To enter the vertical concentrated load 

 

- Choose the "Zoom window" command from the "Window" menu to zoom the wrench 

end as shown in Figure 5-27  

- Choose "Select nodes" command from the "Graphically" menu in Figure 5-26. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair  

- Click the left mouse button on nodes that would have loads. Since the total force is 

200 [N] over a length of 100 [mm] and the nodes are generated at about [4] mm 

spacing, choose 25 nodes from the wrench end as shown in Figure 5-27 

- After selecting nodes of loads, choose "Add nodal loads" command from "Graphically" 

menu in Figure 5-27. "Nodal loads" dialog box in Figure 5-28 appears 

 

In this dialog box 

 

- Type 8 in the "Load Pv" edit box to define the vertical nodal loads 

- Click "OK" button 

 

After you have completed the definition of the concentrated loads, the screen should look like 

Figure 5-29. 

 

 
Figure 5-27 Select load nodes  
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Figure 5-28 "Nodal loads" dialog box 

 

 
Figure 5-29 Final loads 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 5-29 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 5-29 to close the "Loads" 

embedded program and return to the main window of  ELPLA-Data 

 

Creating the project of the wrench is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 
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3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 5-30 appears.  

 

 
Figure 5-30 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation        

- Analysis of plane stress 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 5-31 appears in which various phases of the calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 5-31 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

5-32 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 5-32 Opening screen of the sub program ELPLA-Graphic 
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ELPLA can show solid elements in three dimension view. To view elements with real dimension 

in 3D-view, choose "Plot parameters" command from "Options" menu of ELPLA-Graphic. The 

following "Plot parameters" dialog box in Figure 5-33 appears. In the "Solid elements" tab, 

check the following check boxes: "draw solid elements", "draw element border" and "color solid 

element", then click "OK". 

 

 
Figure 5-33 "Plot parameters" option box 

 

To view the wrench in 3D-view, choose "Data in isometric view" command from "Graphic" 

menu of ELPLA-Graphic. The following option box in Figure 5-34 appears. In this option box, 

select "Slab thickness" option, then click "OK" button. The wrench is now displayed as solid 

elements in 3D-view as shown in Figure 5-35. 

 

 
Figure 5-34 "Data in isometric view" option box 
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Figure 5-35 Wrench in isometric view 

 

To view the results as contour lines 

 

- Choose "Results as contour lines" command from "Graphic" menu of ELPLA-Graphic. 

The following option box in Figure 5-36 appears 

- In this option box, select "Maximum shear stresses max_Sigma" as a sample for the 

results to be displayed 

- Click "OK" button 

 

The maximum shear stresses are now displayed as contour lines as shown in Figure 5-37. 

 

 
Figure 5-36 "Results as contour lines" option box 
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Figure 5-37 Maximum shear stresses max_Sigma 
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