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1 Description of the problem 

 

Since truss structure is considered as a special case of plane frame problems, an example of a 

two-dimensional truss structure is selected to illustrate some features of ELPLA for analyzing 

plane frames. 

 

1.1 Loads and dimensions 

 

The truss consists of 4 equal spans. All truss members have a cross section area of 0.01 [m2] and 

moment of inertia of 0.00001 [m4]. Geometry of the truss and loads are shown in Figure 6-1.  

 

 

60 [kN]60 [kN] 60 [kN]

4*3 = 12 [m]

4 [m]

 
 

Figure 6-1 Geometry of the truss and loads 

 

1.2 Truss properties 

 

The properties of the truss are: 

 

Young's modulus   Eb = 2 * 108  [kN/m2] 

Area of the member   A = 0.01   [m2] 

Moment of inertia of the member I = 0.00001  [m4] 

 

1.3 Analysis of the grid 

 

It is required to analyze the truss assuming that all members are pin connected. This Tutorial 

Manual will not present the theoretical background of modeling the problem. For more 

information concerning the method of analysis, a complete reference for numerical calculation 

methods is well documented in the User’s Guide of ELPLA. 
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2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a truss as a plane frame 

example. The example will be processed step by step to show the possibilities and abilities of the 

program. To enter the data of the example, follow the instructions and steps in the next 

paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose the "New project" command 

from the "File" menu. The "Calculation methods" wizard appears, Figure 6-2. The wizard will 

guide you through the steps required to create the system data of the project. As shown in Figure 

6-2, the first form of the wizard is the "Analysis type" form.  

 

 
Figure 6-2 "Calculation method" wizard with "Analysis type" form  

 

In the "Analysis type" form in Figure 6-2, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a truss problem, select 

"Analysis of plane frame". Then click "Next" button to go to the next form. 

 

The next form is the "System symmetry", Figure 6-3. In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

The last form of the wizard assistant contains the "Option" list, Figure 6-4. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other.  

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 

 



 

 

                   ELPLA-Tutorial 

 

 

   6-5 

 
Figure 6-3 "System symmetry" form 

 

 
Figure 6-4 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 6-5.  

 

In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Truss". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 
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ELPLA will activate the "Data" menu. Also the file name of the current project [Truss] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 6-5 "Save as" dialog box 

 

2.2 Project identification 

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 6-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box: 

"Analysis of a plane frame" 

- Type the date of the project in the "Date" edit box 

- Type "Truss" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 6-6 "Project identification" dialog box 

 

2.3 FE-Net data 

 

To enter the truss geometry, an imaginary net must be first defined with suitable dimensions and 

then the truss is entered lately by connecting the corresponding nodes on the net that define the 

truss shape. To define the net for the truss geometry, choose "FE-Net data" command from 

"Data" menu. The "FE-Net generation" wizard appears as shown in Figure 6-7. This wizard will 

guide you through the steps required to generate the FE-Net. The first form of the wizard is the 

"Slab type" form which contains a group of templates of different shapes of nets (Figure 6-7). 
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These net templates are used to generate standard nets that have constant size in both x- and y-

directions. 

 

To generate an imaginary net 

 

- In the "Slab type" options, choose the rectangular slab option to create an imaginary net 

of a rectangular area 

- Type 12 in the "Length of rectangular slab" edit box 

- Type 4 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 6-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 6-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 
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Figure 6-8 "Generation type" form 

 

After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 6-9 appears with default values of constant element size.  

 

In this "Grid definition" dialog box 

 

- Type 12 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 4 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 1 in the "Grid interval Dx" edit box 

- Type 1 in the "Grid interval Dy" edit box 

- Click "Finish" 

 

ELPLA will generate an imaginary net for a rectangular area of 12 [m] length and 4 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 6-10 

appears with the generated imaginary net. 

 

 
Figure 6-9 "FE-Net generation" dialog box 



 

 

                   ELPLA-Tutorial 

 

 

   6-9 

 
Figure 6-10 Imaginary net of a rectangular area on the screen 

 

After finishing the generation of the imaginary net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 6-10 to save the data of the 

imaginary net 

- Choose "Close FE-Net" command from "File" menu in Figure 6-10 to close "FE-Net" 

embedded program and to return to the main window of  ELPLA-Data 

 

2.4 Girders 

 

To define the truss members, choose "Girders" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 6-11 appears. 
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Figure 6-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 6-11. The following 

option box in Figure 6-12 appears 

- In this option box select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 6-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 6-13 appears. 

 

In this list box 

 

- Enter the material properties of the girder, cross section dimensions and the girder weight 

as indicated in Figure 6-13. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" 
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Figure 6-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define girder locations on the net 

graphically. 

 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 6-11. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 6-14). Then, click on the end node. The "Girder 

elements" dialog box in Figure 6-15 appears 
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Figure 6-14 Add girder by mouse 

 

In this dialog box 

 

- Select the group No. 

- Click "OK" 

 

 
Figure 6-15 "Girder elements" dialog box 

 

Now, the first girder is defined as shown in Figure 6-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 6-17. 
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Figure 6-16 First girder on the screen 

 

 
Figure 6-17 Girders on the screen 
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After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 6-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 6-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 6-18 appears. 

  

 
Figure 6-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads, etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data. As shown in Figure 6-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. The "Plot parameters" dialog 

box in Figure 6-19 appears 

- In the "General plot parameters" tab, uncheck the "Draw thickness" check box in the 

"Girder systems" dialog box 

- Click "OK" button 

 



 

 

                   ELPLA-Tutorial 

 

 

   6-15 

 
Figure 6-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box, the girders are drawn as simple lines as 

shown in Figure 6-20. 

 

 
Figure 6-20 Girders are drawn in simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define the hinged support 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 6-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have hinged supports as shown in Figure 6-21 

- Choose "Add boundaries" command from "Graphically" menu in Figure 6-21. "Supports/ 

Boundary conditions" dialog box in Figure 6-22 appears 

 

 
Figure 6-21 Selection of hinged support node 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Click "OK" button 
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Figure 6-22 "Supports/ Boundary conditions" dialog box 

 

To define the roller support, repeat the steps used to define the hinged support except that the 

displacement in x-direction is free. To make the displacement of the roller support is free in x-

direction, type "F" in the "Displacement u" instead of typing "0". 

 

After you have completed the definition of supports, the screen should look like the following 

Figure 6-23. 

 

 
Figure 6-23 Supports on the screen 
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Defining hinges for truss members 

 

Assuming all truss members are pin connected, these members will be defined as hinged-hinged 

elements. Defining element hinges on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define element hinges 

on the net graphically. 

 

To define the element hinged, choose "Edit hinges" command from the "Graphically" menu in 

Figure 6-20. When "Edit hinges" command is chosen, the cursor will change from an arrow to a 

cross hair. Double click on the element that has the hinges. "Edit hinges" dialog box in Figure 6-

24 appears. 

 

 
Figure 6-24 "Edit hinges" dialog box 

 

In this dialog box, choose "I and J Hinge" from the hinge types list to define both ends of the 

element as hinges. Then click "OK" button. 

 

After you have completed the definition of element hinges, the screen should look like the 

following Figure 6-25. 

 

 



 

 

                   ELPLA-Tutorial 

 

 

   6-19 

 
Figure 6-25 Supports and hinges on the screen 

 

After entering supports and hinges, do the following two steps: 

 

- Choose "Save supports/ boundary conditions" command from "File" menu in Figure 6-23 

to save the data of supports 

- Choose "Close supports/ boundary conditions" command from "File" menu in Figure 6-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 6-26 appears with girders on the net. 
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Figure 6-26 "Loads" embedded program 

 

Although the user can define loads on both girder element and girder nodes in plane frame 

problem, in the truss problem we will define the loads at nodes only. 

 

To enter the concentrated load at nodes choose "Select nodes" command from "Graphically" 

menu in the window of Figure 6-26. When "Select nodes" command is chosen, the cursor is 

changed from an arrow to a cross hair. Choose nodes to be loaded as shown in Figure 6-27. Then 

choose "Add nodal loads" command from "Graphically" menu, the "Nodal loads" dialog box 

shown in Figure 6-28 appears. In this dialog box, type 60 in the "Load Pv" edit box to define the 

vertical nodal load then click "OK" button. 
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Figure 6-27 Selection of loaded nodes 

 

 
Figure 6-28 "Nodal loads" dialog box 

 

After you have completed the definition of the nodal loads, the screen should look like the 

following Figure 6-29. 
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Figure 6-29 Truss load on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 6-29 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 6-29 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

Creating the project of the grid is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 
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3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 6-30 appears.  

 

 
Figure 6-30 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation 

- Analysis of plane frame 

 

These calculation items can be carried out individually or in one time. 

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 6-31 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 

 
Figure 6-31 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

6-32 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 6-32 Opening screen of the sub program ELPLA-Graphic 
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To view the results of girders, choose "Beam results" command and then "Distribution of 

internal forces (in plane)" command from "Graphic" menu of ELPLA-Graphic. The following 

option box in Figure 6-33 appears. 

 

In this option box 

 

- Select "Beam-Normal forces N" as an example for the results to be displayed 

- Click "OK" button 

 

 
Figure 6-33 "Distribution of internal forces (in plane)" option box 

 

The normal forces are now displayed for the truss as shown in Figure 6-34. 

 

 
Figure 6-34 Truss normal forces 
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