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1 Description of the problem 

 

An example for analyzing a beam is selected to illustrate some features of ELPLA for analyzing 

beams. 

 

1.1 Loads and dimensions 

 

The beam is shown in Figure 8-1. All beam members have cross section dimensions of 0.2 [m] * 

0.5 [m]. Geometry of the beam and loads are shown in Figure 8-1. 
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Figure 8-1 Geometry of the beam and loads 

 

1.2 Beam material  

 

Material of the beam is: 

 

Young's modulus Eb = 2 * 107  [kN/m2] 

 

1.3 Analysis of the beam 

 

To analyze the beam, the beam is divided in beam elements, each has a length of 1.0 [m]. This 

Tutorial Manual will not present the theoretical background of modeling the problem. For more 

information concerning the method of analysis, a complete reference for numerical calculation 

methods is well documented in the User’s Guide of ELPLA. 

 

 

2 Creating the project 

 

In this section the user will learn how to create a project for analyzing a plane beam example. 

The example will be processed step by step to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

 

2.1 Calculation method 

 

To create the project, start the sub program ELPLA-Data. Choose "New project" command from 

the "File" menu. The "Calculation methods" wizard appears, Figure 8-2. The wizard will guide 

you through the steps required to create the system data of the project. As shown in Figure 8-2, 

the first form of the wizard is the "Analysis type" form.  
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Figure 8-2 "Calculation method" wizard with "Analysis type" form 

 

In the "Analysis type" form in Figure 8-2, define the analysis type of the problem where ELPLA 

can deal with different structural systems. As the analysis type is a plane beam problem, select 

"Analysis of plane beam". Then click "Next" button to go to the next form. 

 

The next form is the "System symmetry" (Figure 8-3). In this form 

 

- Choose "Unsymmetrical system" 

- Click "Next" button 

 

The last form of the wizard assistant contains the "Option" list, Figure 8-4. In this list, ELPLA 

displays some of the available options corresponding to the used numerical model, which differ 

from model to other.  

 

In this list 

 

- Check "Supports/ Boundary conditions" check box 

- Click "Save" button 
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Figure 8-3 "System symmetry" form 

 

 
Figure 8-4 "Options" list 

 

After clicking "Save" button, the "Save as" dialog box appears, Figure 8-5.  

 

In this dialog box 

 

- Type a file name for the current project in the file name edit box. For example type 

"Beam". ELPLA will use automatically this file name in all reading and writing processes 

- Click "Save" button to complete the definition of the calculation method and the file 

name of the project 
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ELPLA will activate the "Data" menu. Also the file name of the current project [Beam] will be 

displayed instead of the word [Untitled] in the ELPLA-Data title bar. 

 

 
Figure 8-5 "Save as" dialog box 

 

2.2 Project identification  

 

To identify the project, choose "Project identification" command from "Data" menu of ELPLA-

Data. The dialog box in Figure 8-6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a plane beam" 

- Type the date of the project in the "Date" edit box 

- Type "Beam" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 8-6 "Project identification" dialog box 

 

2.3 FE-Net data 

 

To enter the beam geometry, an imaginary net must be first defined with suitable dimensions and 

then the beam is entered lately by connecting the corresponding nodes on the net that define the 

beam shape. To define the net for the beam geometry, choose "FE-Net data" command from 

"Data" menu. The "FE-Net generation" wizard appears as shown in Figure 8-7. This wizard will 

guide you through the steps required to generate the FE-Net. The first form of the wizard is the 

"Slab type" form, which contains a group of templates of different shapes of nets. These net 

templates are used to generate standard nets that have constant size in both x- and y-directions.  
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To generate an imaginary net 

 

- In the "Slab type" options, choose the rectangular slab option to create an imaginary net 

of a rectangular area 

- Type 11 in the "Length of rectangular slab" edit box 

- Type 2 in the "Width of rectangular slab" edit box 

- Click "Next" button to go to the next form 

 

 
Figure 8-7 "FE-Net generation" wizard with "Slab type" form 

 

After clicking "Next" in the "FE-Net generation" wizard, the following "Generation type" form 

appears, Figure 8-8. ELPLA can deal with various types of generations with triangle and/ or 

rectangular elements. 

 

In this form 

 

- Choose rectangular elements 

- Click "Next" 

 

 
Figure 8-8 "Generation type" form 
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After clicking "Next" button in "Generation type" form, the following "Grid definition" dialog 

box in Figure 8-9 appears with default values of constant element size.  

 

In this dialog box 

 

- Type 11 in the "No. of grid intervals" edit box for grids in x-direction 

- Type 2 in the "No. of grid intervals" edit box for grids in y-direction 

- Type 1 in the "Grid interval Dx" edit box 

- Type 1 in the "Grid interval Dy" edit box 

- Click "Finish" button 

 

ELPLA will generate an imaginary net for a rectangular area of 11 [m] length and 2 [m] width 

with square elements of 1.0 [m] each side. The following embedded program in Figure 8-10 

appears with the generated imaginary net. 

 

 
Figure 8-9 "FE-Net generation" dialog box 
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Figure 8-10 Imaginary net of a rectangular area on the screen 

 

After finishing the generation of the imaginary net, do the following two steps: 

 

- Choose "Save FE-Net" command from "File" menu in Figure 8-10 to save the data of the 

imaginary net 

- Choose "Close FE-Net" command from "File" menu in Figure 8-10 to close "FE-Net" 

embedded program and to return to the main window of ELPLA-Data 

 

2.4 Girders 

 

To define the beam members, choose "Girders" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 8-11 appears. 
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Figure 8-11 "Girders" embedded program 

 

To enter the cross section of the girders 

 

- Choose "Girder groups" command from "In Table" menu in Figure 8-11.  

The following option box in Figure 8-12 appears 

- In this option box, select "Rectangular cross section" 

- Click "OK" button 

 

 
Figure 8-12 "Cross section definition" option box 

 

After clicking "OK" button in the "Cross section definition" option box, the following list box in 

Figure 8-13 appears. 

 

In this list box 

 

- Enter the material properties of the girder, cross-section dimensions and the girder weight 

as indicated in Figure 8-13. This is done by entering the value in the corresponding cell 

and press "Enter" button 

- Click "OK" button 
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Figure 8-13 "Defining girder groups" list box 

 

Defining the girder locations on the net 

 

Defining girder locations on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will define girder locations on the net graphically. 

 

To define the girder locations on the net graphically 

 

- Choose "Add girders" command from the "Graphically" menu in Figure 8-14. When 

"Add girders" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the start node of the first girder and drag the mouse until 

the end node of that girder (Figure 8-14). Then, click on the end node. The "Girder 

elements" dialog box in Figure 8-15 appears 

 

In this dialog box 

 

- Select the group No. 

- Click "OK" button 
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Figure 8-14 Add girder by mouse 

 

 
Figure 8-15 "Girder elements" dialog box 

 

Now, the first girder is defined as shown in Figure 8-16. Note that ELPLA has typed 

automatically the girder type on it indicating the No. of girder group. 

 

One note should be taken into consideration that girder ends are at exchanged nodes, for example 

supported nodes, hinged nodes and loaded nodes, so we should have five girders in this example. 
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Figure 8-16 First girder on the screen 

 

Repeat the previous steps to add the remaining girders on the net. After you have completed the 

definition of all girders, the screen should look like the following Figure 8-17. 

 

 
Figure 8-17 Girders on the screen 
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After entering all data and parameters of girders, do the following two steps: 

 

- Choose "Save girders" command from "File" menu in Figure 8-17 to save the data of 

girders 

- Choose "Close girders" command from "File" menu in Figure 8-17 to close the "Girders" 

embedded program and to return to the main window of ELPLA-Data 

 

2.5 Supports/ Boundary conditions 

 

To define supports, choose "Supports/ Boundary conditions" command from "Data" menu of 

ELPLA-Data. The following embedded program in Figure 8-18 appears. 

 

 
Figure 8-18 "Supports/ Boundary conditions" embedded program 

 

ELPLA can display girders, supports, loads etc. in one view together. The advantage of this 

option is that the user can control easily locations of supports or loads on the net when entering 

the rest of the data. In the case of analysis of girder problems, ELPLA displays girders during 

input of other data.  As shown in Figure 8-18, girders are drawn with the actual thickness. 

 

To view girders as simple lines 

 

- Choose "Plot parameters" command from "Options" menu. 

The "Plot parameters" dialog box in Figure 8-19 appears 

- In the "General plot parameters" tab, uncheck the "Draw girder thickness" check box in 

the "Girder systems" dialog box 

- Click "OK" button 
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Figure 8-19 "Plot parameters" dialog box 

 

After clicking "OK" in the "Plot parameters" dialog box, the girders are drawn as simple lines as 

shown in Figure 8-20. 

 

 
Figure 8-20 Girders are drawn as simple lines 
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Defining supports on the net 

 

Defining supports or boundary conditions on the net may be carried out either graphically or 

numerically (in a table). In the current example the user will learn how to define supports on the 

net graphically. 

 

To define the fixed support 

 

- Choose "Select nodes" command from the "Graphically" menu in Figure 8-20. When 

"Select nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have the fixed supports as shown in Figure 8-21 

- Choose "Add boundaries" command from "Graphically" menu in Figure 8-21 

- "Supports/   Boundary conditions" dialog box in Figure 8-22 appears 

 

 
Figure 8-21 Selection of fixed support node 

 

In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal supports 

- Type 0 in the "Displacement w" edit box to define the vertical supports 

- Type 0 in the "Rotation Theta" edit box to define the moment supports 

- Click "OK" button 
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Figure 8-22 "Supports/ Boundary conditions" dialog box 

 

To define the roller support, repeat the steps used to define the fixed support except that the 

support is free to rotate and the displacement in x-direction is free. To make the rotation of the 

roller support is free, type "F" in the "Rotation Theta" instead of typing "0". To make the 

displacement of the roller support is free in x-direction, type "F" in the "Displacement u" instead 

of typing "0". After you have completed the definition of supports, the screen should look like 

the following Figure 8-23. 

 

 
Figure 8-23 Supports on the screen 
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Defining hinges for beam members 

 

Defining element hinges on the net may be carried out either graphically or numerically (in a 

table). In the current example the user will learn how to define element hinges on the net 

graphically. 

 

To define the hinged node, the hinge is defined from two sides on both left and right elements 

that have a hinged end. Choose "Edit hinges" command from the "Graphically" menu in Figure 

8-20. When "Edit hinges" command is chosen, the cursor will change from an arrow to a cross 

hair. Double click on the element that has a hinged end. "Edit hinges" dialog box in Figure 8-24 

appears. 

 

 
Figure 8-24 "Edit hinges" dialog box 

 

In this dialog box, choose "I Hinge" from the hinge types list to define one end of the element as 

hinge. Then click "OK" button. The screen should look like Figure 8-25. 
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Figure 8-25 Hinged end of the element 

 

Double click on the other element that has the hinged end. "Edit hinges" dialog box in Figure 8-

24 appears. 

 

Choose "J Hinge" from the hinge types list to define one end of the element as hinge. Then click 

"OK" button. 

 

After you have completed the definition of element hinges, the screen should look like the 

following Figure 8-26. 
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Figure 8-26 Supports and hinges on the screen 

 

After entering supports and hinges, do the following two steps: 

 

- Choose "Save supports/ Boundary conditions" command from "File" menu in Figure 8-23 

to save the data of supports 

- Choose "Close supports/ Boundary conditions" command from "File" menu in Figure  8-

23 to close the "Supports/ Boundary conditions" embedded program and to return to the 

main window of ELPLA-Data 

 

2.6 Loads 

 

To define the concentrated load, choose "Loads" command from "Data" menu of ELPLA-Data. 

The following embedded program in Figure 8-27 appears with girders on the net. 
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Figure 8-27 "Loads" embedded program 

 

To enter the nodal loads, choose "Select nodes" command from "Graphically" menu in the 

window of Figure 8-27. When "Select nodes" command is chosen, the cursor is changed from an 

arrow to a cross hair. Choose a node to be loaded as shown in Figure 8-28.  

 

 
Figure 8-28 Selection of loaded node 
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Then choose "Add nodal loads" command from "Graphically" menu, the "Nodal loads" dialog 

box shown in Figure 8-29 appears. In this dialog box, type 100 in the "Load Pv" edit box to 

define the vertical nodal load, type also –60 in the "Moment M" edit box then click "OK" button. 

The node should be loaded as shown in Figure 8-30. 

 

 
Figure 8-29 "Nodal loads" dialog box 

 

 
Figure 8-30 Nodal loads 
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To input the uniform distributed loads, choose "Edit member load" command from "Graphically" 

menu. Then the cursor will change from an arrow to a cross hair. Double click on the element 

that has the uniform distributed load. "Edit member load" dialog box in Figure 8-31 appears. In 

this dialog box, type 80 in the "Member loads" edit box to define the member load then click 

"OK" button. The loaded member is shown in Figure 8-32. The distributed loads in this example 

are "Self weight" types. To more about distributed load types, see the ELPLA User’s Guide. 

 

 
Figure 8-31 "Edit member load" dialog box 

 

 
Figure 8-32 Loaded member 
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Use the same steps to input the uniform distributed load on the other loaded member. After you 

have completed the definition of the load data, the screen should look like the following Figure 

8-33. 

 

 
Figure 8-33 Beam loads on the screen 

 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save loads" command from "File" menu in Figure 8-33 to save the load data 

- Choose "Close loads" command from "File" menu in Figure 8-33 to close the "Loads" 

embedded program and return to the main window of ELPLA-Data 

 

You can get the supports and the system of loading together on the screen. Choose "View 

grouping" command from "Options" list and the following dialog box in Figure 8-34 appears.  

 

 
Figure 8-34 View grouping dialog box 

 

Check the "Supports/Boundary conditions" check box then click the "OK" button. The screen 

should look like Figure 8-35.  
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Figure 8-35 Beam supports and system of loading on the screen 

 

Creating the project of the beam is now complete. It is time to analyze this project. In the next 

section you will learn how to use ELPLA for analyzing projects. 

 

 

3 Carrying out the calculations 

3.1 Starting ELPLA-Solver 

 

To analyze the problem, switch to ELPLA-Solver. This is done by clicking on "Solver" in the 

menu bar of the sub programs at the upper-right corner of ELPLA-Data. Then, ELPLA-Solver 

window in Figure 8-36 appears. 

 



 

 

  ELPLA-Tutorial 

 

 

   8-26 

 
Figure 8-36 Opening screen of the sub program ELPLA-Solver 

 

ELPLA-Solver automatically opens the data file of the current example and displays the data file 

name in the title bar of ELPLA-Solver window. Also, ELPLA will active the "Calculation" menu. 

This menu contains commands of all calculations. Commands of the calculation depend on the 

analysis type. For the current example, the items, which are required to be calculated, are: 

 

- Preparing the calculation      

- Analysis of plane beam 

 

These calculation items can be carried out individually or in one time.  

 

3.2 Carrying out all computations 

 

To carry out all computations in one time, choose "Computation of all" command from 

"Calculation" menu in ELPLA-Solver window. The progress of all computations according to the 

defined analysis will be carried out automatically with displaying information through menus 

and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 8-37 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. Also, a status bar on the screen 

down of the ELPLA-Solver window displays information about the progress of calculation. 

 



 

 

  ELPLA-Tutorial 

 

 

   8-27 

 
Figure 8-37 Analysis progress menu 

 

 

4 Viewing data and result graphics  

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to ELPLA-Graphic. This is done by clicking on "Graphic" in the menu bar of the sub 

programs at the upper-right corner of ELPLA-Solver window. ELPLA-Graphic window in Figure 

8-38 appears. ELPLA-Graphic automatically opens the data file of the current example and 

displays the data file name in the title bar of ELPLA-Graphic window. 

 

 
Figure 8-38 Opening screen of the sub program ELPLA-Graphic 

 

To view the results of girders, choose "Beam results" command and then "Distribution of 

internal forces (in plane)" command from "Graphic" menu of ELPLA-Graphic. The following 

option box in Figure 8-39 appears. 

 

In this option box 

 

- Select "Beam-Bending moments Mb" as an example for the results to be displayed 

- Click "OK" button 
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Figure 8-39 "Distribution of internal forces (in plane)" option box 

 

The bending moments are now displayed for the beam as shown in Figure 8-40. 

 

 
Figure 8-40 Beam bending moments 
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